X
Tap here to go to the mobile version of the site.

Support Forum

Why won't this website http://www.virtualhousechurch.com/ run in Firefox? It runs fine in MS Edge and Chrome. It keeps giving a script error & locks Firefox.

Posted

I've tried disabling the script with YesScript plugin (no help) I've tried extending the script run time (no help) http://www.virtualhousechurch.com/ This website will not run on Firefox, why, is there a fix or a plug in that I need?

I've tried disabling the script with YesScript plugin (no help) I've tried extending the script run time (no help) http://www.virtualhousechurch.com/ This website will not run on Firefox, why, is there a fix or a plug in that I need?

Chosen solution

Works fine here (about 17 seconds).


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157862 answers

Chosen Solution

Works fine here (about 17 seconds).


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Works fine here (about 17 seconds). ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache": *Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now" "Remove the cookies" from websites that cause problems. *Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies" Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Modified by cor-el

Question owner

Adguard extension was the culprit. After removing this everything works fine. I then installed Block ads extension and everything works great. Thanks for your help.

Adguard extension was the culprit. After removing this everything works fine. I then installed Block ads extension and everything works great. Thanks for your help.