X
Tap here to go to the mobile version of the site.

Support Forum

I continue get redirection to the HTTPS version of the site.

Posted

Hi, I am using irefox 54.0 (64-bit) on archlinux. I continue get redirection to the https version of the site. I disabled autoFill and clear whole my history, cookies and everything what I found. Also, I tried function Forget About This Site which didn't help. HTTPS version of the site which I am trying to open doesn't exist. I can't get to this site through FF. Google Chrome also trying to redirect me to the HTTPS version by when it failed it allows me to open HTTP version.

Is there solution to this problem? To disable this FF policy

Thank you.

Hi, I am using irefox 54.0 (64-bit) on archlinux. I continue get redirection to the https version of the site. I disabled autoFill and clear whole my history, cookies and everything what I found. Also, I tried function Forget About This Site which didn't help. HTTPS version of the site which I am trying to open doesn't exist. I can't get to this site through FF. Google Chrome also trying to redirect me to the HTTPS version by when it failed it allows me to open HTTP version. Is there solution to this problem? To disable this FF policy Thank you.

Chosen solution

You can check the SiteSecurityServiceState.txt file in the profile folder for references about this website and remove existing lines.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157294 answers

Chosen Solution

You can check the SiteSecurityServiceState.txt file in the profile folder for references about this website and remove existing lines.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can check the SiteSecurityServiceState.txt file in the profile folder for references about this website and remove existing lines. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Thank you! It solved my problem. But also, should be mentioned that you need to delete not only main domain of the site but all higher domain for example: for site domain1.domain.com you need also delete domain.com.

What If I will go to the domain.com pages again? Will I get these lines in the SiteSecurityServiceState.txt file? Do I need to continuously delete them?

Thank you! It solved my problem. But also, should be mentioned that you need to delete not only main domain of the site but all higher domain for example: for site domain1.domain.com you need also delete domain.com. What If I will go to the domain.com pages again? Will I get these lines in the SiteSecurityServiceState.txt file? Do I need to continuously delete them?
rajgopal 0 solutions 3 answers

I tried this and it still doesn't work for me. I am using Ver. 55.02 (32 bit). I have also tried everything else suggested including setting the urlbar.* options to "false" from about:config, saying "Forget this site" from history, completing clearing all history, removing all references to https in the bookmarks - NOTHING works. At this time I am completely fed up with all the time I have wasted and I am switching to Chrome or maybe even (shudder...) IE. And by the way, the idea that this is not a Firefox problem but a domain problem is nonsense - my domain is a major university site with thousands of web pages over which I have no system-level control, and in any case, browsers are supposed to be designed to handle websites and not the other way around. Goodbye Firefox...

I tried this and it still doesn't work for me. I am using Ver. 55.02 (32 bit). I have also tried everything else suggested including setting the urlbar.* options to "false" from ''about:config'', saying "Forget this site" from history, completing clearing all history, removing all references to https in the bookmarks - NOTHING works. At this time I am completely fed up with all the time I have wasted and I am switching to Chrome or maybe even (shudder...) IE. And by the way, the idea that this is not a Firefox problem but a domain problem is nonsense - my domain is a major university site with thousands of web pages over which I have no system-level control, and in any case, browsers are supposed to be designed to handle websites and not the other way around. Goodbye Firefox...

Question owner

Are you sure that you deleted all top-level domains as I mentioned in previous post? Because I also had this issue with university pages. There were a lot of subdomains which I hadn't access to. But when I removed main domain issue was solved.

Try to use some search to find all the mentions of the domain.

Are you sure that you deleted all top-level domains as I mentioned in previous post? Because I also had this issue with university pages. There were a lot of subdomains which I hadn't access to. But when I removed main domain issue was solved. Try to use some search to find all the mentions of the domain.
rajgopal 0 solutions 3 answers

I actually deleted the entire SiteSecurityServiceState.txt file - still doesn't solve the problem. Not sure where else to look...

I actually deleted the entire SiteSecurityServiceState.txt file - still doesn't solve the problem. Not sure where else to look...
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157294 answers

Helpful Reply

Do you have an extension that might force a secure connection?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Do you have an extension that might force a secure connection? Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
rajgopal 0 solutions 3 answers

THANK YOU; you solved my problem. I started Firefox in Safe mode and everything was fine - no https redirects! So I went in to the add-ons page like you suggested but I didn't even have to go any further: found something called "https Everywhere" - no clue how this even got installed :-( Anyway, I disabled it and now everything works like a charm. And for people using this add-on, please be careful. I don't think it's malicious but it is definitely buggy. Thanks again Cor-el!

THANK YOU; you solved my problem. I started Firefox in Safe mode and everything was fine - no https redirects! So I went in to the add-ons page like you suggested but I didn't even have to go any further: found something called "https Everywhere" - no clue how this even got installed :-( Anyway, I disabled it and now everything works like a charm. And for people using this add-on, please be careful. I don't think it's malicious but it is definitely buggy. Thanks again Cor-el!
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157294 answers

You're welcome. I was already thinking that you might have such an extension that force a secure connection.

You're welcome. I was already thinking that you might have such an extension that force a secure connection.