X
Tap here to go to the mobile version of the site.

Support Forum

WHY DOES GRAMMARLY AND LUMOSITY NOT FUNCTION ON FIRFOX NOW

Posted

Am only getting ticket replies from Grammarly and Lumosity why they are not functioning on my computer. Microsoft support has run diagnostics on my laptop and report that Lumosity has an issue that micro soft can't control. Being told everything from doing things with my Chrome web, BUT I DO NOT HAVE CHROME, use Firefox. The frustrating tickets going on for awhile now...states no telephone support available. HELP. :)

Am only getting ticket replies from Grammarly and Lumosity why they are not functioning on my computer. Microsoft support has run diagnostics on my laptop and report that Lumosity has an issue that micro soft can't control. Being told everything from doing things with my Chrome web, BUT I DO NOT HAVE CHROME, use Firefox. The frustrating tickets going on for awhile now...states no telephone support available. HELP. :)
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 16.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

jscher2000
  • Top 10 Contributor
6579 solutions 53777 answers

Do the websites display any error messages? The more information you can provide about their behavior, the better.

I haven't seen other users mention these sites recently, so I'll give you "the usual":

If a site is generally known to work in Firefox, these are general suggestions to try when it stops working:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

Do the websites display any error messages? The more information you can provide about their behavior, the better. I haven't seen other users mention these sites recently, so I'll give you "the usual": If a site is generally known to work in Firefox, these are general suggestions to try when it stops working: '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]])
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
6579 solutions 53777 answers

Helpful Reply

Also, your Firefox indicated that you have version 16 of the Flash plugin. That version is obsolete and probably blocked from working in Firefox. Can you update the Flash plugin in case the sites require it? See:

Flash Plugin - Keep it up to date and troubleshoot problems

Also, your Firefox indicated that you have version 16 of the Flash plugin. That version is obsolete and probably blocked from working in Firefox. Can you update the Flash plugin in case the sites require it? See: [[Flash Plugin - Keep it up to date and troubleshoot problems]]
Was this helpful to you? 1
Quote

Question owner

An issue here is now Grammarly is actually admitting there is an issue with Grammarly being compatible with Firefox and keep getting the message to change my browser to Chrome. The Microsoft assistance discovered that when they spent 40 minutes running a complete diagnostic on my computer. I get a weekly summary still from Grammarly stating among ther statistics, I wrote over 6600 unique words, putting me in the top 97 percentile of users. But Grammarly isn't working....maybe it is just acting like a counter of words privately. And I know I'll need to get the updated Flash update, even though my computer registers that is has been already.....go figure. Lumosity is another mystery because it worked well for a month and now just isn't found on my computer, but it still produces a reminder email to train on that day's Lumosity's games......I am- not very computer literate, but this has gotten ridiculous, I have to treat it like a Monty Python moment. Thanks for all that has been suggested, Have tried some of the suggestions, and when I have the patience again tomorrow I'll try some of the generously offered ones Thank you very much.

An issue here is now Grammarly is actually admitting there is an issue with Grammarly being compatible with Firefox and keep getting the message to change my browser to Chrome. The Microsoft assistance discovered that when they spent 40 minutes running a complete diagnostic on my computer. I get a weekly summary still from Grammarly stating among ther statistics, I wrote over 6600 unique words, putting me in the top 97 percentile of users. But Grammarly isn't working....maybe it is just acting like a counter of words privately. And I know I'll need to get the updated Flash update, even though my computer registers that is has been already.....go figure. Lumosity is another mystery because it worked well for a month and now just isn't found on my computer, but it still produces a reminder email to train on that day's Lumosity's games......I am- not very computer literate, but this has gotten ridiculous, I have to treat it like a Monty Python moment. Thanks for all that has been suggested, Have tried some of the suggestions, and when I have the patience again tomorrow I'll try some of the generously offered ones Thank you very much.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3160 solutions 42648 answers

I have Grammarly and it works just fine. Disable Lumosity. Is the problem still there?

I have Grammarly and it works just fine. Disable Lumosity. Is the problem still there?
Was this helpful to you?
Quote

Question owner

Thanks, Fred. The way this forum is setup I couldn't answer you directly. I will try your suggestion tomorrow, as my sense of humor and patience have reached the limits of my medication for today. The irony is Grammarly worked properly in responding to you in this message.  :)

Thanks, Fred. The way this forum is setup I couldn't answer you directly. I will try your suggestion tomorrow, as my sense of humor and patience have reached the limits of my medication for today. The irony is Grammarly worked properly in responding to you in this message. :)
Was this helpful to you?
Quote
Pkshadow
  • Top 10 Contributor
236 solutions 2498 answers

Helpful Reply

Grammarly was just updated on June 19 if not running latest version https://addons.mozilla.org/en-US/firefox/addon/grammarly-1/

Grammarly was just updated on June 19 if not running latest version https://addons.mozilla.org/en-US/firefox/addon/grammarly-1/
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.