X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Sierra needs Javascript 8 for hotmail on Mac OS X

Posted

I have tried to install the new version of Java but every time I try to use hotmail, I am disallowed because there is no javascript! How do I install my downloaded Java on my Mac?

I have tried to install the new version of Java but every time I try to use hotmail, I am disallowed because there is no javascript! How do I install my downloaded Java on my Mac?

Chosen solution

Also make sure that uBlock Origin isn't blocking needed content.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • Firefox 53.0.3
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0
  • Support URL: https://support.mozilla.org/1/firefox/53.0.3/Darwin/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Awesome Screenshot - Capture, Annotate & More 3.0.18 (jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack)
  • Follow-on Search Telemetry 0.8.0 (followonsearch@mozilla.com)
  • History Janitor 1.2.1-signed.1-signed (history-janitor@ednovak.net)
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • NoScript 5.0.5 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Protect My Choices 1.1.15 ({dc501fe1-520b-41f2-9421-ecbb2e7f0255})
  • Shield Recipe Client 1.0.0 (shield-recipe-client@mozilla.org)
  • Smart HTTPS 0.1.8 (jid0-oFwt2ZcakHhkFl7Kp4lJn@jetpack)
  • Tiny JavaScript Debugger 1.1.6 (tinyjsdebugger@enigmail.net)
  • uBlock Origin 1.12.4 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x0166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • crashGuards: []
  • currentAudioBackend: audiounit
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'TileHeight': 512, u'TileWidth': 512, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webgl2Renderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • webglRenderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers
http://kb.mozillazine.org/JavaScript_is_not_Java
jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

Helpful Reply

Despite the similar names, they aren't related:

  • JavaScript, a widely used programming language that browsers handle using their internal code
  • Java, a different programming language used by some sites for "applets" interpreted by the Java plugin

Thank you for sharing your add-on information. Since you run the NoScript extension, and since NoScript blocks scripts by default until you allow them, I think Step #1 is to allow scripts from the various Microsoft sites needed to make https://outlook.live.com/owa/ work, including live.com and other sites shown on the NoScript drop-down or pop-up list (click its button on the toolbar) while you're on the site.

Or if you are not interested in micromanaging what scripts can run on websites, maybe NoScript isn't the best extension for you to be using? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then manage as you wish.

Note that some changes are not effective until you restart Firefox. You'll see a link above the extension to restart Firefox in that case. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

Despite the similar names, they aren't related: * JavaScript, a widely used programming language that browsers handle using their internal code * Java, a different programming language used by some sites for "applets" interpreted by the Java plugin Thank you for sharing your add-on information. Since you run the NoScript extension, and since NoScript blocks scripts by default until you allow them, I think Step #1 is to allow scripts from the various Microsoft sites needed to make https://outlook.live.com/owa/ work, including live''.''com and other sites shown on the NoScript drop-down or pop-up list (click its button on the toolbar) while you're on the site. Or if you are not interested in micromanaging what scripts can run on websites, maybe NoScript isn't the best extension for you to be using? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then manage as you wish. Note that some changes are not effective until you restart Firefox. You'll see a link above the extension to restart Firefox in that case. You can complete your work on the tab and click one of the links as the last step. Any improvement?
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157871 answers

Chosen Solution

Also make sure that uBlock Origin isn't blocking needed content.

Also make sure that uBlock Origin isn't blocking needed content.

Question owner

jscher2000 said

Despite the similar names, they aren't related:
  • JavaScript, a widely used programming language that browsers handle using their internal code
  • Java, a different programming language used by some sites for "applets" interpreted by the Java plugin
Thank you for sharing your add-on information. Since you run the NoScript extension, and since NoScript blocks scripts by default until you allow them, I think Step #1 is to allow scripts from the various Microsoft sites needed to make https://outlook.live.com/owa/ work, including live.com and other sites shown on the NoScript drop-down or pop-up list (click its button on the toolbar) while you're on the site. Or if you are not interested in micromanaging what scripts can run on websites, maybe NoScript isn't the best extension for you to be using? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:
  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Extensions. Then manage as you wish. Note that some changes are not effective until you restart Firefox. You'll see a link above the extension to restart Firefox in that case. You can complete your work on the tab and click one of the links as the last step. Any improvement?
''jscher2000 [[#answer-979455|said]]'' <blockquote> Despite the similar names, they aren't related: * JavaScript, a widely used programming language that browsers handle using their internal code * Java, a different programming language used by some sites for "applets" interpreted by the Java plugin Thank you for sharing your add-on information. Since you run the NoScript extension, and since NoScript blocks scripts by default until you allow them, I think Step #1 is to allow scripts from the various Microsoft sites needed to make https://outlook.live.com/owa/ work, including live''.''com and other sites shown on the NoScript drop-down or pop-up list (click its button on the toolbar) while you're on the site. Or if you are not interested in micromanaging what scripts can run on websites, maybe NoScript isn't the best extension for you to be using? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then manage as you wish. Note that some changes are not effective until you restart Firefox. You'll see a link above the extension to restart Firefox in that case. You can complete your work on the tab and click one of the links as the last step. Any improvement? </blockquote>

Question owner

Thank you, jscher. Finally, my problem is solved. I disabled both - NoScript and uBlock and ..... relief!! Thankyou!

Thank you, jscher. Finally, my problem is solved. I disabled both - NoScript and uBlock and ..... relief!! Thankyou!