X
Tap here to go to the mobile version of the site.

Support Forum

in outlook/live mail green padlock turn to yellow warning on CERTAIN emails?

Posted

When in Outlook/Live.com email the padlock is always green UNTIL or UNLESS I open CERTAIN emails & then it turns to yellow warning sign. SEEMS like it DOESN'T change (to yellow) when I open emails that ONLY contain writing ? Once it IS yellow it STAYS yellow - UNTIL I "Reload the tab"- so it goes back to just showing all folders, etc... with NO OPEN EMAIL. WHAT would I or should I change to make ALL email "secure". It also SEEMS like MAYBE any email with ANY picture changes it to the yellow warning. Or is this something that anyone shouldn't be very concerned about? It appears that LOT OF PEOPLE HAVE THIS "PROBLEM". And not only with the Firefox browser. This "green to yellow" situation has been with me, using Firefox as my default browser, for about as long as I can remember! A few or several years? NOBODY seems to have a SOLUTION! NOBODY! And I REALLY LIKE my email program so I DON'T want to use a different one. I tried Thunderbird but didn't care for it... but I don't remember if this problem showed up in Thunderbird or not. I wasn't looking for that/this, at the time. Thank you for ANY help that you might be able to give me.

When in Outlook/Live.com email the padlock is always green UNTIL or UNLESS I open CERTAIN emails & then it turns to yellow warning sign. SEEMS like it DOESN'T change (to yellow) when I open emails that ONLY contain writing ? Once it IS yellow it STAYS yellow - UNTIL I "Reload the tab"- so it goes back to just showing all folders, etc... with NO OPEN EMAIL. WHAT would I or should I change to make ALL email "secure". It also SEEMS like MAYBE any email with ANY picture changes it to the yellow warning. Or is this something that anyone shouldn't be very concerned about? It appears that LOT OF PEOPLE HAVE THIS "PROBLEM". And not only with the Firefox browser. This "green to yellow" situation has been with me, using Firefox as my default browser, for about as long as I can remember! A few or several years? NOBODY seems to have a SOLUTION! NOBODY! And I REALLY LIKE my email program so I DON'T want to use a different one. I tried Thunderbird but didn't care for it... but I don't remember if this problem showed up in Thunderbird or not. I wasn't looking for that/this, at the time. Thank you for ANY help that you might be able to give me.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

jscher2000
  • Top 10 Contributor
8886 solutions 72699 answers

The usual reason for this problem is that an HTML-format message has embedded images, and the links to those images use HTTP instead of HTTPS. Since this is a low risk threat, Firefox loads the images and changes the icon.

Your other options are:

(1) Block HTTP address images in HTTPS pages (internal settings change -- if you want to try it, see below) or (2) Try to force HTTPS for the images using an extension such as HTTPS Everywhere (may not be entirely successful, depending on the site where the images come from)


If you want to block HTTP images in HTTPS pages, which may be more paranoia than necessary, here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste mix and pause while the list is filtered

(3) Double-click the security.mixed_content.block_display_content preference to switch the value from false to true

The usual reason for this problem is that an HTML-format message has embedded images, and the links to those images use HTTP instead of HTTPS. Since this is a low risk threat, Firefox loads the images and changes the icon. Your other options are: (1) Block HTTP address images in HTTPS pages (internal settings change -- if you want to try it, see below) or (2) Try to force HTTPS for the images using an extension such as HTTPS Everywhere (may not be entirely successful, depending on the site where the images come from) ---- If you want to block HTTP images in HTTPS pages, which may be more paranoia than necessary, here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''mix''' and pause while the list is filtered (3) Double-click the '''security.mixed_content.block_display_content''' preference to switch the value from false to true

Question owner

IF I do the 1,2,3 things suggested and it causes other things that I "can't live with" can I just UNDO this by doing the 1,2 and then in 3 change the value back, to True? Or AM I being a bit paranoid...actually?

IF I do the 1,2,3 things suggested and it causes other things that I "can't live with" can I just UNDO this by doing the 1,2 and then in 3 change the value back, to True? Or AM I being a bit paranoid...actually?
cor-el
  • Top 10 Contributor
  • Moderator
17774 solutions 160751 answers

Blocking mixed passive content is all or nothing, so you won't see images coming over an open HTTP connection on any secure websites.

You can usually see in the Web Console what content this is about.

See also:

Blocking mixed passive content is all or nothing, so you won't see images coming over an open HTTP connection on any secure websites. You can usually see in the Web Console what content this is about. *https://developer.mozilla.org/Tools/Web_Console See also: *https://support.mozilla.org/en-US/kb/mixed-content-blocking-firefox *https://support.mozilla.org/en-US/kb/control-center-site-privacy-and-security-firefox *https://developer.mozilla.org/Security/MixedContent