X
Tap here to go to the mobile version of the site.

Support Forum

How can I fix the rendering problem I'm seeing in the Firefox Title Bar?

Posted

I'm seeing a strange intermittent rendering problem in the Firefox Title Bar.

It looks like the Windows 10 'flat' grey window elements are being partially overwritten with a pale blue Windows style theme - The screen clip shows a typical instance, but the 'split' line changes whenever I refresh, select a new tab or even move the mouse around in its vicinity.

I've tried uninstalling/reinstalling, which appears to work for a very short time, then it comes back.

I've only seen it on this machine. Another desktop of the same design/build/spec seems fine - laptop, too.

Anybody seen this before?

Any ideas for a fix?

Tolqua.

I'm seeing a strange intermittent rendering problem in the Firefox Title Bar. It looks like the Windows 10 'flat' grey window elements are being partially overwritten with a pale blue Windows style theme - The screen clip shows a typical instance, but the 'split' line changes whenever I refresh, select a new tab or even move the mouse around in its vicinity. I've tried uninstalling/reinstalling, which appears to work for a very short time, then it comes back. I've only seen it on this machine. Another desktop of the same design/build/spec seems fine - laptop, too. Anybody seen this before? Any ideas for a fix? Tolqua.
Quote

Additional System Details

Installed Plug-ins

ABP Roboform

Application

  • Firefox 53.0.3
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
  • Support URL: https://support.mozilla.org/1/firefox/53.0.3/WINNT/en-GB/

Extensions

  • Adblock Plus 2.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • RoboForm Toolbar 8.2.9.5 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Shield Recipe Client 1.0.0 (shield-recipe-client@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0042
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.15063.0
  • driverDate: 11-26-2012
  • driverDate2:
  • driverVersion: 8.15.10.2900
  • driverVersion2:
  • failures: [u'[GFX1-]: (gfxWindowsPlatform) Detected device reset: 3', u'[GFX1-]: (gfxWindowsPlatform) Finished device reset.', u'[GFX1-]: LayerManager::EndTransaction skip RenderLayer().', u'[GFX1-]: (nsWindow) Detected device reset: 3', u'[GFX1-]: (nsWindow) Finished device reset.']
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}]}
  • indices: [0, 1, 2, 3, 4]
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'skia', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_4_0 ps_4_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Helpful Reply

Here's the screen clip I wasn't able to upload with my original post...

Here's the screen clip I wasn't able to upload with my original post...

Modified by Tolqua

Was this helpful to you? 1
Quote
Scribe
  • Top 25 Contributor
605 solutions 2901 answers

Hi, this may be caused by your RoboForm Toolbar, so try disabling it - Add-ons Manager (Ctrl+Shift+A).

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Hi, this may be caused by your RoboForm Toolbar, so try disabling it - Add-ons Manager (Ctrl+Shift+A). ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!''
Was this helpful to you? 0
Quote

Question owner

Disabling RoboForm toolbar doesn't fix the issue.

Also, it wouldn't be a solution anyway, since Firefox's support for this is the very reason I started using it (IE being the only other browser to support RF integration in this way - Chrome's is much poorer).

I use the RoboForm toolbar on other PCs without this issue.

Tolqua.

Disabling RoboForm toolbar doesn't fix the issue. Also, it wouldn't be a solution anyway, since Firefox's support for this is the very reason I started using it (IE being the only other browser to support RF integration in this way - Chrome's is much poorer). I use the RoboForm toolbar on other PCs without this issue. Tolqua.
Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
281 solutions 3069 answers

Your system details show that you have AdBlock Plus 2.9 installed,
which just now has been reported to cause problems, such as preventing the RoboForm Toolbar to work properly.

It's advised to disable/remove adBlock Plus and replace it with uBlock Origin :

https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/

Your system details show that you have AdBlock Plus 2.9 installed, <BR>which just now has been reported to cause problems, such as preventing the RoboForm Toolbar to work properly. It's advised to disable/remove adBlock Plus and replace it with uBlock Origin : https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/
Was this helpful to you? 0
Quote

Question owner

After disabling the RoboForm toolbar as suggested, there was no change to the problem, but after a Firefox restart it cleared up so I worked without the RoboForm toolbar for a while to see if it showed up again. Sure enough it did later that day so I re-enabled the RoboForm toolbar.

Then I removed (not just disabled) the AdBlock Plus add-in and, once again, no impact on the problem. I restarted Firefox and, again the problem appeared to have cleared up, but returned a few minutes later. I've uploaded another screen clip.

Thanks for the suggestions, but I really don't think it's related to the add-ons as I have the same two active in Firefox on my laptop (Dell XPS13) and have never seen the issue. This doesn't prove it's not add-on related, but it does beg the question as to why I see it most of the time on this desktop PC and never on any other.

Is it not possible to investigate the issue in a more targetted way?

Tolqua.

After disabling the RoboForm toolbar as suggested, there was no change to the problem, but after a Firefox restart it cleared up so I worked without the RoboForm toolbar for a while to see if it showed up again. Sure enough it did later that day so I re-enabled the RoboForm toolbar. Then I removed (not just disabled) the AdBlock Plus add-in and, once again, no impact on the problem. I restarted Firefox and, again the problem appeared to have cleared up, but returned a few minutes later. I've uploaded another screen clip. Thanks for the suggestions, but I really don't think it's related to the add-ons as I have the same two active in Firefox on my laptop (Dell XPS13) and have never seen the issue. This doesn't prove it's not add-on related, but it does beg the question as to why I see it most of the time on this desktop PC and never on any other. Is it not possible to investigate the issue in a more targetted way? Tolqua.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

Are you using Firefox with a maximized window?

You can try to set browser.tabs.drawInTitlebar to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Are you using Firefox with a maximized window? You can try to set browser.tabs.drawInTitlebar to false on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you? 0
Quote

Question owner

No, I generally use a resizeable window, but can confirm the problem's still present when views full-screen (see new clip).

Shortly after changing ad-blocker as suggested previously, I did see the problem clear up for several hours. I started to think it may have stopped altogether, but today it's back again so I'll give the about:config edit a try.

Tolqua.

No, I generally use a resizeable window, but can confirm the problem's still present when views full-screen (see new clip). Shortly after changing ad-blocker as suggested previously, I did see the problem clear up for several hours. I started to think it may have stopped altogether, but today it's back again so I'll give the '''about:config''' edit a try. Tolqua.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

Any luck with trying a different Windows theme or otherwise change title bar settings in Windows?

Any luck with trying a different Windows theme or otherwise change title bar settings in Windows?
Was this helpful to you? 0
Quote

Question owner

Setting browser.tabs.drawInTitlebar to false on the about:config page does appear to kill the issue (didn't see a recurrence after several days), but it does add a ugly white title bar at the top which isn't normally present and I wouldn't choose for any other reason.

It's an improvement, but not a solution.

I haven't tried making changes to the Windows theme or otherwise changed title bar settings because I've never needed to do this and, unless you have some specific changes that will help yield iformation to identify the source of the issue, I'd rather leave these alone.

Tolqua.

Setting browser.tabs.drawInTitlebar to false on the about:config page does appear to kill the issue (didn't see a recurrence after several days), but it does add a ugly white title bar at the top which isn't normally present and I wouldn't choose for any other reason. It's an improvement, but not a solution. I haven't tried making changes to the Windows theme or otherwise changed title bar settings because I've never needed to do this and, unless you have some specific changes that will help yield iformation to identify the source of the issue, I'd rather leave these alone. Tolqua.

Modified by Tolqua

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

You can hide the title bar in customization mode.

  • you can toggle the title bar on/off via the "Title Bar" button at the bottom left in the Customize palette window
You can hide the title bar in customization mode. *you can toggle the title bar on/off via the "Title Bar" button at the bottom left in the Customize palette window
Was this helpful to you? 1
Quote

Question owner

Well, I was about to say that this does appear to have fixed the issue - the combination of the about:config edit and TitleBar switch did fix the issue for several days, but just as I started to type this I noticed it was back again - kinda spooky, I know, but that's the truth (see attached screen clip).

Tolqua.

Well, I was about to say that this does appear to have fixed the issue - the combination of the about:config edit and TitleBar switch did fix the issue for several days, but just as I started to type this I noticed it was back again - kinda spooky, I know, but that's the truth (see attached screen clip). Tolqua.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15341 solutions 139075 answers

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Was this helpful to you? 0
Quote

Question owner

Thanks for your help with this, but it's not working and we could go on forever with the 'just try this...' approach. Given that Mozilla has now decided to drop support for proper add-ons, the RoboFormm toolbar won't work any more. This is a profoundly stupid move in my opinion and leaves me with no good reason to continue using Firefox.

Whilst I'm looking for an alternative browser, how can I prevent Firefox from automatically updating so I can stay on 54.0.1?

Thanks for your help with this, but it's not working and we could go on forever with the 'just try this...' approach. Given that Mozilla has now decided to drop support for proper add-ons, the RoboFormm toolbar won't work any more. This is a profoundly stupid move in my opinion and leaves me with no good reason to continue using Firefox. Whilst I'm looking for an alternative browser, how can I prevent Firefox from automatically updating so I can stay on 54.0.1?
Was this helpful to you?
Quote
Scribe
  • Top 25 Contributor
605 solutions 2901 answers

Helpful Reply

Hi, please see the update tab in Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox. Check for updates, but let me choose whether to install them is the setting I use - you will be informed that an update is available, but you can download and install as and when you wish.

If you are unhappy with FF just now, be aware that big changes are coming with v57 in mid-November (do a search for 'Firefox Photon'), so you might want to take another look then. If all else fails, Pale Moon is probably your best option.

Hi, please see the update tab in [[Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox]]. '''Check for updates, but let me choose whether to install them''' is the setting I use - you will be informed that an update is available, but you can download and install as and when you wish. If you are unhappy with FF just now, be aware that big changes are coming with v57 in mid-November (do a search for 'Firefox Photon'), so you might want to take another look then. If all else fails, [http://www.palemoon.org/ Pale Moon] is probably your best option.
Was this helpful to you? 1
Quote

Question owner

Thanks for the location of the update settings. I'll stick with Firefox 54.0.1 as RoboForm toolbar doesn't seem to work in Pale Moon.

I doubt that v57 will bring any change in the decision to support only web extensions - It doesn't look like you understood that this was the reason for my dismay with Firefox or the importance of the Roboform toolbar. For that matter, neither does Roboform!

What's needed, as I've maintained all along, is a browser that incorporates this functionality as part of its design, not a whole bunch of browsers all offering the same thing.

Tolqua.

Thanks for the location of the update settings. I'll stick with Firefox 54.0.1 as RoboForm toolbar doesn't seem to work in Pale Moon. I doubt that v57 will bring any change in the decision to support only web extensions - It doesn't look like you understood that this was the reason for my dismay with Firefox or the importance of the Roboform toolbar. For that matter, neither does Roboform! What's needed, as I've maintained all along, is a browser that incorporates this functionality as part of its design, not a whole bunch of browsers all offering the same thing. Tolqua.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.