X
Tap here to go to the mobile version of the site.

Support Forum

Firefox heavily using CPU

Posted

Firefox is using consistently greater than 40% CPU usage. I will only have a handful of tabs open, and the only plugins installed are 1password and React Dev Tools, both of which about:performance says are running fine.

Im on 53.0.3 (64-bit) MAC OS 10.12.4 (16E195) 16GB Ram 2.5 GHz Intel Core i7

At first startup there is no problem, but after usage for about 20 minutes I start to notice slow downs as well as my computer fans fire up as the laptop heats up. This only ever happens when using firefox. I am a web developer and recently switch from chrome to firefox and I am loving the tools and community but having to restart my browser every 30 minutes is quite concerning. Would love some help to solve this problem.

Thanks so much for your help!

Firefox is using consistently greater than 40% CPU usage. I will only have a handful of tabs open, and the only plugins installed are 1password and React Dev Tools, both of which about:performance says are running fine. Im on 53.0.3 (64-bit) MAC OS 10.12.4 (16E195) 16GB Ram 2.5 GHz Intel Core i7 At first startup there is no problem, but after usage for about 20 minutes I start to notice slow downs as well as my computer fans fire up as the laptop heats up. This only ever happens when using firefox. I am a web developer and recently switch from chrome to firefox and I am loving the tools and community but having to restart my browser every 30 minutes is quite concerning. Would love some help to solve this problem. Thanks so much for your help!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • Firefox 53.0.3
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0
  • Support URL: https://support.mozilla.org/1/firefox/53.0.3/Darwin/en-US/

Extensions

  • 1Password 4.6.5 (onepassword4@agilebits.com)
  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • React Devtools 2.0.12 (@react-devtools)
  • Valence 0.3.7 (fxdevtools-adapters@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6821
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • crashGuards: []
  • currentAudioBackend: audiounit
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'TileHeight': 1024, u'TileWidth': 1024, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl2Renderer: ATI Technologies Inc. -- AMD Radeon R9 M370X OpenGL Engine
  • webglRenderer: ATI Technologies Inc. -- AMD Radeon R9 M370X OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4193 solutions 58540 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ----------------- https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding