X
Tap here to go to the mobile version of the site.

Support Forum

firefox downloads constantly in the background - how do i stop this?

Posted

in task manager there are 3 firefoxes running, 2 of them constantly transfer data.

i need to stop this

in task manager there are 3 firefoxes running, 2 of them constantly transfer data. i need to stop this

Chosen solution

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • Firefox 53.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
  • Support URL: https://support.mozilla.org/1/firefox/53.0.2/WINNT/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Shield Recipe Client 1.0.0 (shield-recipe-client@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • DigitalPersona Extension 5.0.0.4191 (otis@digitalpersona.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 1423103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22084
  • driverDate: 10-21-2011
  • driverDate2:
  • driverVersion: 8.15.10.2559
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'Direct2D 1.1', u'AzureContentBackend': u'Direct2D 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_4_0 ps_4_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar.
cor-el
  • Top 10 Contributor
  • Moderator
17476 solutions 157949 answers

Helpful Reply

What kind of data do these processes transfer and what IP addresses are involved?

See also:

What kind of data do these processes transfer and what IP addresses are involved? See also: *https://support.mozilla.org/en-US/kb/Firefox+makes+unrequested+connections

Question owner

FredMcD said

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page. browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

That resulted in killing 2 of the three firefox processes. sadly, the one that survived is downloading...

''FredMcD [[#answer-969359|said]]'' <blockquote> More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar. </blockquote> That resulted in killing 2 of the three firefox processes. sadly, the one that survived is downloading...

Question owner

cor-el said

What kind of data do these processes transfer and what IP addresses are involved? See also:

I don't know how to find the ip address(es)

''cor-el [[#answer-969361|said]]'' <blockquote> What kind of data do these processes transfer and what IP addresses are involved? See also: *https://support.mozilla.org/en-US/kb/Firefox+makes+unrequested+connections </blockquote> I don't know how to find the ip address(es)
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

Chosen Solution

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

the data reds have stopped. not sure exactly why but changing the setting to browser.tabs.remote.autostart = false did it, i think.

thanks guys :)

the data reds have stopped. not sure exactly why but changing the setting to browser.tabs.remote.autostart = false did it, i think. thanks guys :)
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.
barnettgs 0 solutions 10 answers

MonteWard said

the data reds have stopped. not sure exactly why but changing the setting to browser.tabs.remote.autostart = false did it, i think. thanks guys :)

This has fixed it for me. I'm not sure why it was happening for the first time. When I looked up in about:config, I actually have two of browser.tabs.remote.autostart - the one enabled is browser.tabs.remote.autostart2

Everytime I load a page and when the page has completed loading, the Firefox continues to download for several seconds more! Therefore it slows down the whole things of opening links and websites.

Now that it is turned to false, the browsing is much snapper as I only have 3 MB connection.

If it wasn't fixed in the first place, I would have to use other browser for the first time in years...this was unacceptable.

''MonteWard [[#answer-969620|said]]'' <blockquote> the data reds have stopped. not sure exactly why but changing the setting to browser.tabs.remote.autostart = false did it, i think. thanks guys :) </blockquote> This has fixed it for me. I'm not sure why it was happening for the first time. When I looked up in about:config, I actually have two of browser.tabs.remote.autostart - the one enabled is browser.tabs.remote.autostart2 Everytime I load a page and when the page has completed loading, the Firefox continues to download for several seconds more! Therefore it slows down the whole things of opening links and websites. Now that it is turned to false, the browsing is much snapper as I only have 3 MB connection. If it wasn't fixed in the first place, I would have to use other browser for the first time in years...this was unacceptable.
barnettgs 0 solutions 10 answers

It is still not fixed as it is still downloading constantly after just opening one or two tabs...what is going on?

It is still not fixed as it is still downloading constantly after just opening one or two tabs...what is going on?
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

barnettgs

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

'''barnettgs''' [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
barnettgs 0 solutions 10 answers

The safe mode was fine so I decided to do the refresh and it is still downloading in the background each time after webpage is loaded.

I believe this has occured only after Firefox update of 55.0.3, it has never been like that before.

It downloads for something like 10 seconds or more, just after the loading icon has completed.

The safe mode was fine so I decided to do the refresh and it is still downloading in the background each time after webpage is loaded. I believe this has occured only after Firefox update of 55.0.3, it has never been like that before. It downloads for something like 10 seconds or more, just after the loading icon has completed.

Modified by barnettgs

FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

Did you re-install any add-ons?


Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Did you re-install any add-ons? Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.
barnettgs 0 solutions 10 answers

Disabled both options, restarted and it still made no difference.

I decided to count the number of seconds after it has completed loading, it is over 30 seconds!

But seriously, I believe this is a network issue with Firefox but how can it be down to graphic settings that has nothing to do with downloading?

Disabled both options, restarted and it still made no difference. I decided to count the number of seconds after it has completed loading, it is over 30 seconds! But seriously, I believe this is a network issue with Firefox but how can it be down to graphic settings that has nothing to do with downloading?
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

If the page has graphics or a player, I may agree.

If the page has graphics or a player, I may agree.
barnettgs 0 solutions 10 answers

Just disabling 'S3.Google Translator' add-on seemed to have solved it as it has 'Legacy' status beside it.

I think it was Firefox's new update that caused the problem with add-ons which are not updated yet to reflect of the Firefox's new changes...

I suppose I have to find an alternative translator add-on.

Just disabling 'S3.Google Translator' add-on seemed to have solved it as it has 'Legacy' status beside it. I think it was Firefox's new update that caused the problem with add-ons which are not updated yet to reflect of the Firefox's new changes... I suppose I have to find an alternative translator add-on.

Modified by barnettgs

FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

Legacy just means that in a future version, those add-ons will not work in Firefox. They will need to be rewritten or replaced.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know. Legacy just means that in a future version, those add-ons will not work in Firefox. They will need to be rewritten or replaced.
barnettgs 0 solutions 10 answers

I would mark it as solved but there is no 'Solved' button - I think this thread was already marked as solved with the original poster, I just hijacked this thread as I had the same issue as him.

I would mark it as solved but there is no 'Solved' button - I think this thread was already marked as solved with the original poster, I just hijacked this thread as I had the same issue as him.

Modified by barnettgs

FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

Okay.

Okay.