Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My browser too often gives me .ca refernces. Can I change to US refernces?

  • 3 replies
  • 3 have this problem
  • 78 views
  • Last reply by richard2940

more options

When searching, I get mostly Canadian .ca references. Is there some change I can make to get US references? Like .com .org .net....etc I worked at the Microsoft store and they say my computer settings are set correctly, and that MS Edge works correctly. However, I would like to stay with the FireFox search engine.

Appreciate any help and or suggestions.

Richard2940

Chosen solution

Are your searches being run on

https://www.google.com/ (global)

or on

https://www.google.ca/ (Canada)

Firefox's built-in search engine plugin for Google should go to the .com site. However, Google may redirect you to a different one if it thinks it is more appropriate to your location. To trigger Google to set a cookie so that doesn't happen, you can try using the "ncr" script:

https://www.google.com/ncr

Read this answer in context 👍 2

All Replies (3)

more options

In many cases, the search results could be for your current location.

What does this web page say about your location? http://whatismyipaddress.com/ Under the map, look for Location not accurate?

more options

Chosen Solution

Are your searches being run on

https://www.google.com/ (global)

or on

https://www.google.ca/ (Canada)

Firefox's built-in search engine plugin for Google should go to the .com site. However, Google may redirect you to a different one if it thinks it is more appropriate to your location. To trigger Google to set a cookie so that doesn't happen, you can try using the "ncr" script:

https://www.google.com/ncr

more options

Solution was that the Google on my toolbar had somehow been set as the .ca. I had never looked at that very minor detail and was unaware of the error, So problem solved. Reset as suggested. This was very astute. Better thinking than the Microsoft store geniuses.

Thanks