X
Tap here to go to the mobile version of the site.

Support Forum

FF Performance and Adobe Flash

Posted

I'm having serious performance issues with Firefox. I have reset Firefox to try and address it and that didn’t help.

Pages take forever to load and the task manager indicates 50 – 75% utilization while FF struggles to load pages. This CPU action continues as long as the browser is running. The “Plugin Container for FF” in addition to “FF” itself is sucking up a lot of resources. If I kill the Plugin Container process, FF reports that Adobe Flash Plugin has crashed and certain pages load that wouldn’t load up to this point. There’s obviously something wrong in the flash. The task manager still shows a 50% CPU usage and the page loads crawl.

If I continue to kill the Plugin Container process, I can coax pages to load.

I'm running Adobe Flash version 25.0.0.171.

The plugins I'm using are:

OpenH264 Video Codec provided by Cisco Systems, Inc. File: 1.6 Path: C:\Users\Elaine\AppData\Roaming\Mozilla\Firefox\Profiles\s553bxtb.default-1494947582755\gmp-gmpopenh264\1.6 Version: 1.6 State: Enabled

Primetime Content Decryption Module provided by Adobe Systems, Incorporated File: 17 Path: C:\Users\Elaine\AppData\Roaming\Mozilla\Firefox\Profiles\s553bxtb.default-1494947582755\gmp-eme-adobe\17 Version: 17 State: Enabled Play back protected web video. MIME Type Description Suffixes

Widevine Content Decryption Module provided by Google Inc. File: 1.4.8.903 Path: C:\Users\Elaine\AppData\Roaming\Mozilla\Firefox\Profiles\s553bxtb.default-1494947582755\gmp-widevinecdm\1.4.8.903 Version: 1.4.8.903 State: Enabled Play back protected web video. MIME Type Description Suffixes

Shockwave Flash File: NPSWF64_25_0_0_171.dll Path: C:\WINDOWS\system32\Macromed\Flash\NPSWF64_25_0_0_171.dll Version: 25.0.0.171 State: Enabled Shockwave Flash 25.0 r0


I'm running Firefox 53.0.2 64bit on Window 10, Lenovo Laptop.

This problem just started recently.

I'm having serious performance issues with Firefox. I have reset Firefox to try and address it and that didn’t help. Pages take forever to load and the task manager indicates 50 – 75% utilization while FF struggles to load pages. This CPU action continues as long as the browser is running. The “Plugin Container for FF” in addition to “FF” itself is sucking up a lot of resources. If I kill the Plugin Container process, FF reports that Adobe Flash Plugin has crashed and certain pages load that wouldn’t load up to this point. There’s obviously something wrong in the flash. The task manager still shows a 50% CPU usage and the page loads crawl. If I continue to kill the Plugin Container process, I can coax pages to load. I'm running Adobe Flash version 25.0.0.171. The plugins I'm using are: OpenH264 Video Codec provided by Cisco Systems, Inc. File: 1.6 Path: C:\Users\Elaine\AppData\Roaming\Mozilla\Firefox\Profiles\s553bxtb.default-1494947582755\gmp-gmpopenh264\1.6 Version: 1.6 State: Enabled Primetime Content Decryption Module provided by Adobe Systems, Incorporated File: 17 Path: C:\Users\Elaine\AppData\Roaming\Mozilla\Firefox\Profiles\s553bxtb.default-1494947582755\gmp-eme-adobe\17 Version: 17 State: Enabled Play back protected web video. MIME Type Description Suffixes Widevine Content Decryption Module provided by Google Inc. File: 1.4.8.903 Path: C:\Users\Elaine\AppData\Roaming\Mozilla\Firefox\Profiles\s553bxtb.default-1494947582755\gmp-widevinecdm\1.4.8.903 Version: 1.4.8.903 State: Enabled Play back protected web video. MIME Type Description Suffixes Shockwave Flash File: NPSWF64_25_0_0_171.dll Path: C:\WINDOWS\system32\Macromed\Flash\NPSWF64_25_0_0_171.dll Version: 25.0.0.171 State: Enabled Shockwave Flash 25.0 r0 I'm running Firefox 53.0.2 64bit on Window 10, Lenovo Laptop. This problem just started recently.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

FredMcD
  • Top 10 Contributor
2759 solutions 37327 answers

Helpful Reply

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you? 2
Quote

Question owner

I just noticed that on the troubled laptop that when FF is running, three instances appear in the task manager. I have the exact same set up on my PC and only one pops up. (And that one is working fine.) Why would three FF's appear?

I just noticed that on the troubled laptop that when FF is running, three instances appear in the task manager. I have the exact same set up on my PC and only one pops up. (And that one is working fine.) Why would three FF's appear?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
2759 solutions 37327 answers

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar.
Was this helpful to you?
Quote

Question owner

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?
''FredMcD [[#answer-968747|said]]'' <blockquote> [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote>
Was this helpful to you?
Quote

Question owner

Yes, it's still there. When I refreshed, I got rid of all the add-on's, so that didn't help much.

Yes, it's still there. When I refreshed, I got rid of all the add-on's, so that didn't help much.
Was this helpful to you?
Quote
tomatoshadow2
  • Top 25 Contributor
3 solutions 48 answers

A refresh should of backed up your old profile automatically.

A refresh should of backed up your old profile automatically.
Was this helpful to you?
Quote

Question owner

It did, but I'm still working off of a clean FF w/o the add-in's and the problem persists. How do I put the old profile back, BTW?

It did, but I'm still working off of a clean FF w/o the add-in's and the problem persists. How do I put the old profile back, BTW?
Was this helpful to you?
Quote

Question owner

And how do I tell what version of Adobe flash FF thinks that i'm using? I updated to the current version, but i'm not sure if FF is using that.

And how do I tell what version of Adobe flash FF thinks that i'm using? I updated to the current version, but i'm not sure if FF is using that.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
2759 solutions 37327 answers
https://www.adobe.com/software/flash/about/ Flash Player Test Page This will tell you what version you are running. ------------------- Look on your desktop. Do you see a folder called; '''Old Firefox?''' https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible
Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
126 solutions 1732 answers

Have you tried to disable Multiprocess (e10s) , like FredMcD suggested earlier  ?

You can check whether you have this feature turned on as follows :

• '3-bar' menu button => ' ? ' button => Troubleshooting Information • type 'about:support ' (without the commas) in the address bar and press Enter/Return

In the first table on the page, check the row for 'Multiprocess Windows' and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s - otherwise it should read : 0/1 (Disabled).

Have you tried to disable Multiprocess (e10s) , like FredMcD suggested earlier ? You can check whether you have this feature turned on as follows : • '3-bar' menu button => ' ? ' button => Troubleshooting Information • type 'about:support ' (without the commas) in the address bar and press Enter/Return In the first table on the page, check the row for 'Multiprocess Windows' and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s - otherwise it should read : 0/1 (Disabled).
Was this helpful to you?
Quote

Question owner

Yeah, i know what version of Flash is on my computer (25.0.0), but i wanted to find that in FF to make sure it was leveraging that version, just in case there's a possibility it's not. I was off my wireless for a while and noticed that the excessive CPU usage exists even when the page can't load.

Yeah, i know what version of Flash is on my computer (25.0.0), but i wanted to find that in FF to make sure it was leveraging that version, just in case there's a possibility it's not. I was off my wireless for a while and noticed that the excessive CPU usage exists even when the page can't load.
Was this helpful to you?
Quote
tomatoshadow2
  • Top 25 Contributor
3 solutions 48 answers

Click on the 3 bar menu, click add-ons and go to plugins and click on flash, that will tell you the version Firefox is using.

Click on the 3 bar menu, click add-ons and go to plugins and click on flash, that will tell you the version Firefox is using.
Was this helpful to you?
Quote

Question owner

Ah, 25.0 r0

Ah, 25.0 r0
Was this helpful to you?
Quote

Question owner

I have no add-ins and only three plug-ins installed and FF continues to churn at 33% of my CPU...

I have no add-ins and only three plug-ins installed and FF continues to churn at 33% of my CPU...
Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
126 solutions 1732 answers

WSC3 said

Ah, 25.0 r0

In your first post you mentioned that you have Flash Player version 25.0.0.171 installed, as well that your Shockwave Flash version is 25.0.r0.

But you still haven't said if you have tried FredMcD's suggestion about turning off Multiprocess (e10s), if you have that feature enabled (?)

''WSC3 [[#answer-969186|said]]'' <blockquote> Ah, 25.0 r0 </blockquote> In your first post you mentioned that you have Flash Player version 25.0.0.171 installed, as well that your Shockwave Flash version is 25.0.r0. But you still haven't said if you have tried FredMcD's suggestion about turning off Multiprocess (e10s), if you have that feature enabled (?)
Was this helpful to you?
Quote
tomatoshadow2
  • Top 25 Contributor
3 solutions 48 answers

Yes I agree with Happy 112, try FredMcD's suggestion and let us know if it works, also do you have flash ask to activate set?

Yes I agree with Happy 112, try FredMcD's suggestion and let us know if it works, also do you have flash ask to activate set?
Was this helpful to you?
Quote

Question owner

Happy 112: I only have shockwave listed. I don't have Adobe Flash listed under my add-ons. In fact, I don't Adobe Flash listed on FF on my desktop either. I thought they were the same.

I will figure out how to turn off multiprocesses.

What does it mean to have "flash ask to activate set?"

Happy 112: I only have shockwave listed. I don't have Adobe Flash listed under my add-ons. In fact, I don't Adobe Flash listed on FF on my desktop either. I thought they were the same. I will figure out how to turn off multiprocesses. What does it mean to have "flash ask to activate set?"
Was this helpful to you?
Quote

Question owner

If I understand, on both computers I have shockwave set to "Always activate." Should I change that to "ask?"

If I understand, on both computers I have shockwave set to "Always activate." Should I change that to "ask?"
Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
126 solutions 1732 answers

WSC3 said

Happy 112: I only have shockwave listed. I don't have Adobe Flash listed under my add-ons.

Totally understand your confusion   ! Adobe Flash Player is installed on your system, and you can check for updates as follows : Click on the magnifying glass on your task bar and type :   'Flash'. The Flash icon will appear on your taskbar   (it'll disappear again afterwards) Click on it, and the Flash Player Settings Manager will appear. There you can click on   'Updates',   to see if you have the latest version, which, as you already know, is 25.0.0.171.

''WSC3 [[#answer-969243|said]]'' <blockquote> Happy 112: I only have shockwave listed. I don't have Adobe Flash listed under my add-ons. </blockquote> Totally understand your confusion &nbsp; ! Adobe Flash Player is installed on your system, and you can check for updates as follows : Click on the magnifying glass on your task bar and type : &nbsp; 'Flash'. The Flash icon will appear on your taskbar &nbsp; (it'll disappear again afterwards) Click on it, and the Flash Player Settings Manager will appear. There you can click on &nbsp; 'Updates', &nbsp; to see if you have the latest version, which, as you already know, is 25.0.0.171.
Was this helpful to you?
Quote
Happy112
  • Top 10 Contributor
126 solutions 1732 answers

WSC3 said

If I understand, on both computers I have shockwave set to "Always activate." Should I change that to "ask?"

No,   you can leave it just as it is now.

And now, when you're ready and feel up to it : Go check and see if you have this Multiprocess feature turned on, and if so :   disabled it. It may sound a bit daunting,   but it really is a piece of cake   -   you'll see.

''WSC3 [[#answer-969248|said]]'' <blockquote> If I understand, on both computers I have shockwave set to "Always activate." Should I change that to "ask?" </blockquote> No, &nbsp; you can leave it just as it is now. And now, when you're ready and feel up to it : Go check and see if you have this Multiprocess feature turned on, and if so : &nbsp; disabled it. It may sound a bit daunting, &nbsp; but it really is a piece of cake &nbsp; - &nbsp; you'll see.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.