Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I screwed up Firefox browser Size!

  • 8 replies
  • 1 has this problem
  • 157 views
  • Last reply by John99

more options

Whilst trying to resize the Firefox browser by going to about:config I made the mistake of resetting the size settings from -0.1 to 1.00 and the Firefox browser went ALL HUGE... I could not see a thing in order to reset it to a workable size. I then uninstalled Firefox and reinstalled the latest version twice and am still getting a HUGELY oversized browser that is IMPOSSIBLE, IMPOSSIBLE to see or do anything with. I cannot go to Safe mode as I cant see a thing. My re-installations of Firefox have had no positive results. Despite the re-installations, there is something somewhere that is remembering my originally set oversized browser and I cannot get past that. The Enormous size of the browser has made it impossible to make changes on the browser and there I am in the real sense of the word STUCK. I will have to use other browsers if this is not fixed.l I dont want to use Edge, Chrome or IE. I want my Firefox back. Please help how can I get it back? I am on Windows 10 with all its current updates. Thank you very much.

Chosen solution

hi, please go into your firefox profile folder, edit the prefs.js file with a text editor and change/remove the preference you've edited in about:config in the file.

Profiles - Where Firefox stores your bookmarks, passwords and other user data

Read this answer in context 👍 1

All Replies (8)

more options

Chosen Solution

hi, please go into your firefox profile folder, edit the prefs.js file with a text editor and change/remove the preference you've edited in about:config in the file.

Profiles - Where Firefox stores your bookmarks, passwords and other user data

more options

Hi   ! 'Totally understand your frustration   ! Am I right assuming that you changed the value of the preference 'layout.css.devPixelsPerPx'   ? And now you can't change it back to it's default value, because of the screen size. Telling you to go to the 3-bar menu is pointless;   all I can think of right now is to ask you to try pressing 'Ctrl' and the '-' a number of times.
Does that work   ?

more options

Thank you for reply Philipp. I am in the notepad to make this change. After making the change, do I just close the notepad or save something? Thank you.

philipp said

hi, please go into your firefox profile folder, edit the prefs.js file with a text editor and change/remove the preference you've edited in about:config in the file. Profiles - Where Firefox stores your bookmarks, passwords and other user data
more options

I did try the Ctl and - sign several times and it did not help. I am now trying to do what Philipp suggested and await further inputs from him. Thank you for your help. Will get back to you guys if none work. but I have a feeling Phillipp's suggestion will work.... just am scared to change things and waiting to get more info from the Mod.

Happy112 said

Hi   ! 'Totally understand your frustration   ! Am I right assuming that you changed the value of the preference 'layout.css.devPixelsPerPx'   ? And now you can't change it back to it's default value, because of the screen size. Telling you to go to the 3-bar menu is pointless;   all I can think of right now is to ask you to try pressing 'Ctrl' and the '-' a number of times.
Does that work   ?
more options

yes, please save the changes you have made in notepad, then close the file and try to start up firefox again :-)

more options

philipp said

hi, please go into your firefox profile folder, edit the prefs.js file with a text editor and change/remove the preference you've edited in about:config in the file. Profiles - Where Firefox stores your bookmarks, passwords and other user data

Brilliant advice   !!!

more options

Hoorah...... it worked. I got my Firefox back. Thanks a million!!!!!


philipp said

yes, please save the changes you have made in notepad, then close the file and try to start up firefox again :-)
more options

You need to save the changed file, but you need to take care it is saved with the correct name and that you can see the full name.

The very simplest solution is to try a refresh that should resolve the issue.

Personally I would only suggest you try that if you get stuck. Read that article however as it mentioned file prefs.js

but again it is much better to just edit the file.

If you save the prefs.js file before editing it as prefs js.old that gives you an easy route to reversing changes if necessary. The amended file should be saved as prefs.js NOT as prefs.js.TXT


By default Windows Notepad probably saves files as <name>.txt so you will tend to save a file prefs.js as prefs.js.txt Sometimes Windows hides the part of a name after the dot you need to make sure you can see file extensions;

Using the Control key probably will not work because you may have changed the browse Chrome, the bits that are normally the fixed interface

Edit I see it is already solved but I will leave this post here as some users may run in to issues of saving the file under the wrong name. (That may even fix the issue if it renames the file but could then inadvertently reset other things also).

Modified by John99