Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Newly built computer Firefox constantly crashing

  • 24 replies
  • 1 has this problem
  • 150 views
  • Last reply by FredMcD

more options

I just had this computer built three weeks ago and since I've brought it home Firefox crashes constantly. When I tried creating a new user Firefox would crash at startup. It still crashes in Safe Mode. I tried uninstalling a reinstalling, clearing the cache, booting in safe mode, system restore, turning off hardware acceleration, and getting rid of the anti-virus I had (Avast), nothing will stop the crashing. Windows is up to date, as is my graphics card. When I took the computer to the place I had it built someone told me the version of Firefox may not be compatible with Windows 7, which didn't make any sense to me as it should be compatible with all current OS. I'm at my wits end with this computer, its the same OS my old one had and I never had Firefox crash on it.

There is no set websites that seem to cause the crashes, but I noted they usually occur when pages are loading.

Modified by RandomWindowArt

All Replies (4)

more options

Signature: atiumdag.dll | atiu9pag.dll | aticfx32.dll | CreateDeviceLHDDI

ole32.dll = Microsoft's framework

atiumdag.dll = ATI Technologies Inc = Radeon DirectX Universal Driver

aticfx32.dll = AMD Inc Radeon DirectX 11 Driver = Advanced Micro Devices

atiu9pag.dll = Advanced Micro Devices Inc PowerXpress Vista User Mode Driver

more options

Thank you FredMcD, I have contacted AMD Tech support. Hopefully they can get this sorted out for me.

more options

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

  1. 1
  2. 2