X
Tap here to go to the mobile version of the site.

Support Forum

The keyboard mapping in Firefox is different to the rest of the computer.

Posted

Ok, this is slightly weird, but after some trouble logging in to, well, anything, I discovered that the @ symbol is mapped to the number 2 when shifted (as if it is a US keyboard map) but why? It never was before. I'm using a new keyboard, but the old keyboard does the same now, and, of course, it is only doing it in Firefox.

|\ are wrong - should be tilde and hash, :; are correct. Pretty sure it is the US map.

TIA.

Ok, this is slightly weird, but after some trouble logging in to, well, anything, I discovered that the @ symbol is mapped to the number 2 when shifted (as if it is a US keyboard map) but why? It never was before. I'm using a new keyboard, but the old keyboard does the same now, and, of course, it is only doing it in Firefox. |\ are wrong - should be tilde and hash, :; are correct. Pretty sure it is the US map. TIA.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • DivX Web Player version 3.7.2.365
  • DivX VOD Helper Plug-in
  • Foxit Reader Plug-In For Firefox and Netscape
  • Version 5.41.3.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • LastPass Plugin
  • BlackBerry WebSL Browser Plug-In
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Roblox Launcher Plugin
  • Shockwave Flash 25.0 r0
  • Shockwave Flash 11.6 r602
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158604 answers

Helpful Reply

What keyboard layout is selected?

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select each keyboard layout and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift).

  • (XP) Control Panel -> Regional and Language Options -> Languages -> Text services and input languages -> Details -> Key Settings -> Change Key Sequence
What keyboard layout is selected? Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut. * http://support.microsoft.com/kb/306993 - HOW TO: Use the Language Bar in Windows XP To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select each keyboard layout and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift). * (XP) Control Panel -> Regional and Language Options -> Languages -> Text services and input languages -> Details -> Key Settings -> Change Key Sequence

Question owner

I'm fairly certain it isn't just that, as restarting with add-ons disabled put the software mapping of the keyboard back to normal in FF! Turning them back on set it wrongly again.

However, playing with the language bar did change it in FF, and toggling it away from UK English to US and back has, for now, solved it!

I can type @ correctly, so all those email addresses will work again. Thanks.

I'm fairly certain it isn't just that, as restarting with add-ons disabled put the software mapping of the keyboard back to normal in FF! Turning them back on set it wrongly again. However, playing with the language bar did change it in FF, and toggling it away from UK English to US and back has, for now, solved it! I can type @ correctly, so all those email addresses will work again. Thanks.