X
Tap here to go to the mobile version of the site.

Support Forum

why all of sudden is Firefox saying my bank configuration is not secure and won't let me in?

Posted

two complaints that I have and hope to get them solved before I leave.

First issue is this, I have used Wa Trust bank always even before Firefox and just yesterday it came back saying their website is not secure. This problem is obviously a Firefox problem!!(  and I had to go to Internet Explorer to log into Wa Trust to pay my bills.A totally frustrated day I had.

Secondly Fire fox will not let use my Amazon Prime to watch movies which is another total frustration , there must be a way to fix that. It would be these two issues that will cause me to go to another Web Browser. Hope to hear back from you with Good News of your fixing these issues Thanks Rose

two complaints that I have and hope to get them solved before I leave. First issue is this, I have used Wa Trust bank always even before Firefox and just yesterday it came back saying their website is not secure. This problem is obviously a Firefox problem!!( and I had to go to Internet Explorer to log into Wa Trust to pay my bills.A totally frustrated day I had. Secondly Fire fox will not let use my Amazon Prime to watch movies which is another total frustration , there must be a way to fix that. It would be these two issues that will cause me to go to another Web Browser. Hope to hear back from you with Good News of your fixing these issues Thanks Rose

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • Firefox 53.0
  • User Agent: Mozilla/5.0 (Windows NT 4.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
  • Support URL: https://support.mozilla.org/1/firefox/53.0/WINNT/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Webroot Filtering Extension 1.2.0.73 (webrootsecure@webroot.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x22b1
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 22b11849
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22084
  • driverDate: 4-10-2015
  • driverDate2:
  • driverVersion: 10.18.14.4189
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'skia', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
jscher2000
  • Top 10 Contributor
8871 solutions 72573 answers

Hi Rose, your browser mentioned that it was running on a very old version of Windows (NT 4.0) that Firefox can't run on. If your Firefox is set to use compatibility options, can you turn those off, then exit Firefox and test the problem sites again? Here's where you do that -- either:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. Click the Compatibility tab. For best results, make sure no checkboxes are checked here. (Example screenshot attached.)

Hi Rose, your browser mentioned that it was running on a very old version of Windows (NT 4.0) that Firefox can't run on. If your Firefox is set to use compatibility options, can you turn those off, then exit Firefox and test the problem sites again? Here's where you do that -- either: * Desktop shortcut: right-click the icon, choose Properties * Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. Click the Compatibility tab. For best results, make sure no checkboxes are checked here. (Example screenshot attached.)
jscher2000
  • Top 10 Contributor
8871 solutions 72573 answers

primrose1 said

I have used Wa Trust bank always even before Firefox and just yesterday it came back saying their website is not secure. This problem is obviously a Firefox problem!!

First, I just want to clarify: when Firefox cannot form a secure connection with a server, that is not an indication that a site is unsafe, it is an indication that the server failed to prove to Firefox's requirements that it actually is the site you want to reach. It could be a fake, or it could have obsolete security which Firefox considers insecure, or there could be a "man in the middle" reading all your communications with that server. You should never need to make exceptions for well run sites.

Okay, now, to figure out what the problem is. Could you copy/paste the text from the error page in a reply. If there is an Advanced button, please click that and copy the more technical explanation there, too.

''primrose1 [[#question-1158899|said]]'' <blockquote> I have used Wa Trust bank always even before Firefox and just yesterday it came back saying their website is not secure. This problem is obviously a Firefox problem!!</blockquote> First, I just want to clarify: when Firefox cannot form a secure connection with a server, that is not an indication that a site is unsafe, it is an indication that the server failed to prove to Firefox's requirements that it actually is the site you want to reach. It could be a fake, or it could have obsolete security which Firefox considers insecure, or there could be a "man in the middle" reading all your communications with that server. You should '''never''' need to make exceptions for well run sites. Okay, now, to figure out what the problem is. Could you copy/paste the text from the error page in a reply. If there is an Advanced button, please click that and copy the more technical explanation there, too.