X
Tap here to go to the mobile version of the site.

Support Forum

I need assistance installing Firefox update onto my Mac Book Air

Posted

i have been in a car wreck and my brain is still healing. Verbiage i used to understand I now struggle with. I don't understand the directions on how to install the updated version of Firefox. i need assistance to make this happen as soon as possible. Thank you, Emily

i have been in a car wreck and my brain is still healing. Verbiage i used to understand I now struggle with. I don't understand the directions on how to install the updated version of Firefox. i need assistance to make this happen as soon as possible. Thank you, Emily

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 17.009.20044
  • Shockwave Flash 25.0 r0
  • 5.1.50428.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59404 answers
https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Update Firefox to the latest version 53
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157942 answers

The System Details list shows some plugins:

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 17.009.20044
  • Shockwave Flash 25.0 r0
  • 5.1.50428.0 (Silverlight)

Firefox 52 and later releases only support the Shockwave Flash plugin and disable all other plugins. You can use the Firefox 52 ESR release if you need to use other plugins.

Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no longer work.

You can find the Firefox 52.1.0 ESR on this page:

See also:

The System Details list shows some plugins: * Adobe® Acrobat® Plug-in for Web Browsers, Version 17.009.20044 * Shockwave Flash 25.0 r0 * 5.1.50428.0 (Silverlight) Firefox 52 and later releases only support the Shockwave Flash plugin and disable all other plugins. You can use the Firefox 52 ESR release if you need to use other plugins. Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no longer work. *https://support.mozilla.org/en-US/kb/npapi-plugins You can find the Firefox 52.1.0 ESR on this page: *https://www.mozilla.org/en-US/firefox/organizations/all/ *https://www.mozilla.org/en-US/firefox/organizations/notes/ *https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ See also: *https://support.mozilla.org/en-US/kb/Installing+Firefox+on+Mac