Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

To get Firefox to open, I have to click 4-5 times... and my Taskmanager always show at least 3 Firefox open

  • 14 replies
  • 2 have this problem
  • 35 views
  • Last reply by FredMcD

more options

Firefox - only on this computer - won't start unless I click (Taskmanager shows Firefox open - nothing on screen), then click several tims more. Then reluctantly I get 3,4,5 or more windows opening all together. If i close all of them but one, Taskmanager (see image) still shows at least 3 open. And they all show different size of memory. EVEN IF ONLY ONE WINDOW IS OPEN! Very frustrating.

Attached screenshots

All Replies (14)

more options

Application Basics


Name: Firefox Version: 53.0 Build ID: 20170413192749 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 OS: Windows_NT 6.1 Multiprocess Windows: 0/1 (Disabled) Safe Mode: false

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Application Update Service Helper Version: 2.0 Enabled: true ID: aushelper@mozilla.org

Name: Multi-process staged rollout Version: 1.14 Enabled: true ID: e10srollout@mozilla.org

Name: Pocket Version: 1.0.5 Enabled: true ID: firefox@getpocket.com

Name: Web Compat Version: 1.0 Enabled: true ID: webcompat@mozilla.org

Name: Adobe Acrobat DC - Create PDF Version: 15 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom

Name: Dell Data Protection | Security Tools Version: 1.0.0.5842 Enabled: false ID: dpmaxz_ng@jetpack

Name: Skype Version: 8.0.0.9103 Enabled: false ID: {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}

Graphics


Features Compositing: Direct3D 11 Asynchronous Pan/Zoom: none WebGL Renderer: Google Inc. -- ANGLE (NVIDIA NVS 310 Direct3D11 vs_5_0 ps_5_0) WebGL2 Renderer: Google Inc. -- ANGLE (NVIDIA NVS 310 Direct3D11 vs_5_0 ps_5_0) Audio Backend: wasapi Direct2D: true DirectWrite: true (6.2.9200.22084) GPU #1 Active: Yes Description: NVIDIA NVS 310 Vendor ID: 0x10de Device ID: 0x107d Driver Version: 9.18.13.3182 Driver Date: 11-11-2013 Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Subsys ID: 094e10de RAM: 512

Diagnostics AzureCanvasAccelerated: 0 AzureCanvasBackend: direct2d 1.1 AzureContentBackend: direct2d 1.1 AzureFallbackCanvasBackend: skia Decision Log D3D9_COMPOSITING: disabled by default: Disabled by default GPU_PROCESS: unavailable by runtime: Multi-process mode is not enabled



Important Modified Preferences


browser.cache.disk.capacity: 1048576 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.frecency_experiment: 1 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 8 browser.sessionstore.upgradeBackup.latestBuildID: 20170413192749 browser.startup.homepage_override.buildID: 20170413192749 browser.startup.homepage_override.mstone: 53.0 browser.tabs.remote.autostart.2: true extensions.lastAppVersion: 53.0 gfx.crash-guard.d3d11layers.appVersion: 53.0 gfx.crash-guard.d3d11layers.deviceID: 0x107d gfx.crash-guard.d3d11layers.driverVersion: 9.18.13.3182 gfx.crash-guard.d3d11layers.feature-d2d: true gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.status.d3d11layers: 2 gfx.crash-guard.status.d3d9video: 2 media.gmp.storage.version.observed: 1 media.hardware-video-decoding.failed: false network.cookie.prefsMigrated: true places.history.expiration.transient_current_max_pages: 65014 plugin.disable_full_page_plugin_for_types: application/pdf security.sandbox.content.tempDirSuffix: {4f316bcf-9ca8-42d4-a3be-6414d39b40d6}

Important Locked Preferences


Places Database


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.13.1 Version in use: 4.13.1

NSS Expected minimum version: 3.29.5 Version in use: 3.29.5

NSSSMIME Expected minimum version: 3.29.5 Version in use: 3.29.5

NSSSSL Expected minimum version: 3.29.5 Version in use: 3.29.5

NSSUTIL Expected minimum version: 3.29.5 Version in use: 3.29.5

Experimental Features


Sandbox


Content Process Sandbox Level: 1

more options

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.


Start Firefox in Safe Mode by holding down the <Shift> (Mac=Options) key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Even doing what you said "Start in safe mode" resulted (seen in taskmanager) firefox being "open" but nothing on screen. I had to click your "This Doesn't Solve my problem" four times to get it to open at all. I reset Firefox. I have disabled every add-on (not many of them). I disabled AVG Safe Surfing too... Firefox just won't open any more except or unless I keep clicking and then 3+ pages show up. And it is NOT tabs... I open on DuckDuckGo, one tab homepage only. Windows Internet Explorer opens with one click in tool bar.

more options

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac:’’' *~/Library/Application Support/Firefox/
  • Linux:’’' *~/.mozilla/firefox/
  • Windows:’’' %AppData%\Mozilla\Firefox\
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\

Locate the above files. Then rename or delete them. Restart Firefox.

more options

Those files do not exist. See attached screen shot

more options

C:\Users\Fred\AppData\Roaming\Mozilla\Firefox\Profiles Takes you to the Profiles folder. Find the profile you are currently using. In that folder, delete those files.

You can also do a file search and remove all those files.

more options

FredMcD said

C:\Users\Fred\AppData\Roaming\Mozilla\Firefox\Profiles Takes you to the Profiles folder. Find the profile you are currently using. In that folder, delete those files. You can also do a file search and remove all those files.
more options

Why would I want to delete my profile - which populates across several machines???

more options

Not the profiles. Search for these files in the Profiles folder, and rename them all. xulstore.json and Localstore.rdf

more options

Found xulstore.json renamed as xulstoreold.json. did not find other. trying fix...

By the way, found in C:\Users\Peter Riva\AppData\Roaming\Mozilla\Firefox\Profiles\n4f4i9f2.default-1493247850029

more options

Still very slow to open (22 seconds) to homepage only. Other Firefox computers under 3 seconds. BUT at least it opened on one click only!

more options

What are you using as your homepage?

Start Firefox in Safe Mode by holding down the <Shift> (Mac=Options) key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


peterriva said

By the way, found in
C:\Users\Peter Riva\AppData\Roaming\Mozilla\Firefox\Profiles\n4f4i9f2.default-1493247850029

That, I think, is your default profile.

more options

Opening in safe mode = longer time

home page = duckduckgo (no sign in)

more options

Change your homepage to about:blank Is the problem still there?

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?