Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

gmail master password

  • 4 replies
  • 6 have this problem
  • 96 views
  • Last reply by hoesel

more options

Hi, when the master password feature is activated, firefox automatically logins to gmail.com without ever asking for the master password, even immediately after a reboot. That is not why I expected (and previous version on windows 7 did ask for the master password, but I switched to a brand new install of windows 10 and the latest firefox. This happens after I shutdown windows when browser is still active, But surely it should ask for the password. It just doesn't.

Chosen solution

that setting will only apply to new cookies - so please delete all your existing cookies from google.com.

i'm also not sure if this setting will be overwritten by session restore which might also keep a record of the cookies of the sites that where open when you closed the browser - more infos and workaround here: https://support.mozilla.org/en-US/questions/970539#answer-476964

Read this answer in context 👍 1

All Replies (4)

more options

hi, a master password protects access to somebody going into the firefox preferences > security settings and taking a look at all your passwords or once credentials are about to be autofilled into a login form.

you staying logged in at a website through multiple sessions requires neither of those possibilities - this is controlled by cookies that websites store in your firefox profile. so you should either untick the option to stay logged in during signin to gmail or set firefox to clear cookies after the session...

Enhanced Tracking Protection in Firefox for desktop

more options

So I changed my settings. Under privacy, History I now have selected "use custom settings for history" and there are checkmarks for "remember my browsing and download history" "remember seach and form history" and "accept cookies from sites. Accept third-party cookies is set to "never" and Keep until: "I close Firefox".

still aftor doing that closing firefox and starting it again, I'm automatically logged in to gmail. Even after reboot, firefox will log me in into gmail.

more options

Chosen Solution

that setting will only apply to new cookies - so please delete all your existing cookies from google.com.

i'm also not sure if this setting will be overwritten by session restore which might also keep a record of the cookies of the sites that where open when you closed the browser - more infos and workaround here: https://support.mozilla.org/en-US/questions/970539#answer-476964

more options

Thanks Phillipp!!