Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox video lags when in fullscreen since Windows 10 Creator's Update

more options

After updating Windows 10 Pro x64 to the Creator's Update any video, when put to fullscreen, starts to lag. I've tried Firefox portable and the problem still persists. I have Chrome as well, but the problem does not occur. I've tried reinstallation and both 32 and 64 bit versions, but no luck.

Any help is appreciated!

Thanks!

All Replies (5)

more options

Fix common audio and video issues is a good reference to start general troubleshooting.

Recently I saw an increase in video issues for users who do not have Adobe Primetime or the OpenH264 Video Codec , or Widevine Content Decryption Module provided by Google Inc. - these are downloaded when DRM is enabled in your profile.

Can you confirm what plugins you have installed please.

more options

Here are the plugins I have installed. I have tried both enabled and disabled states, but no change.

OpenH264 Video Codec Shockwave flash Widevine Content Decryption Module

I tried the methods in the link you provided (thanks), but results are still the same.

more options

Do you notice a difference between the Adobe Shockwave Player and the Adobe Flash Player? There are a number of branches for Adobe Flash Player. http://www.adobe.com/software/flash/about/

Safe Mode usually tells if it is an addon, however you mentioned already trying that with the video troubleshooting.

I would then try a new profile. Start Firefox with the Profile Manager and create a new profile: Profile Manager - Create, remove, or switch Firefox profiles

more options

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

Well the problem has stopped, but I can't tell if the problem was a plugin (Hide Favicons) or Silverlight. In the portable version of Firefox, I have no plugins, it is absolute default, but the lag still existed. With the installed version, I tried safe mode, but it didn't help the first time, but it did the second time. So I narrowed it down to the Favicons add-on and the lag stopped. Why the portable version stopped lagging, I'm not sure. I installed Silverlight earlier today for Amazon video. Possibly linked to that. Looks as though Windows Update removed it with the Creator's Update. Either way the problem appears to be solved.

Anyway, thank you both for your help!! I really appreciate it!