Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox home page keeps getting highjacked by unwanted program.

  • 2 replies
  • 1 has this problem
  • 7 views
  • Last reply by jscher2000

more options

I have tried to remove from doc to pdf from myway several times. It is gone for a day or two but then comes back having taken over my firefox homepage. Don't trust this page at all. Have gone through the procedure described in the help section but still returns. Please help!

All Replies (2)

more options

I highly recommend also doing a virus scan. In your current Firefox profile, something could have been changed. I would try to add a restriction on redirects, making sure these options are marked: https://www.screencast.com/t/bjQggOcNO then lastly a Refresh Firefox - reset add-ons and settings fresh.


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista if you don't already have one. Windows 8/10 have antivirus protection built-in.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Please post back with your results.

more options

After cleaning up generally, I suggest also:

(1) Open the Windows Control Panel, Uninstall a Program.

After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it.

Take out as much trash as possible here. If you're not sure, feel free to post program names or a screenshot of the list.

(2) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. All extensions are optional; the troublemaker might not be obvious from its name.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?