X
Tap here to go to the mobile version of the site.

Support Forum

Memory usage increases in spite of steady number of open tabs - after 6h at 3.5 GB

Posted

There is a section in the memory usage guide mentioning such an effect, but that's for "a long time", whereas I already notice the memory usage at 3.5 GB after less than 6 hours of use. Therefore there must be something that exacerbates the problem, which I haven't been able to figure out.

For more information I've uploaded two anonymized memory reports: https://www.dropbox.com/s/ot1an2hdjqptqrt/memory-report.anonymized.after_startup.json.gz?dl=0 https://www.dropbox.com/s/oajyd6od2d4k46b/memory-report.anonymized.6h.json.gz?dl=0 If someone has an idea how this could happen, I would be very glad to hear it! And of course please don't hestitate to ask for more information.

There is a section in the memory usage guide mentioning such an effect, but that's for "a long time", whereas I already notice the memory usage at 3.5 GB after less than 6 hours of use. Therefore there must be something that exacerbates the problem, which I haven't been able to figure out. For more information I've uploaded two anonymized memory reports: https://www.dropbox.com/s/ot1an2hdjqptqrt/memory-report.anonymized.after_startup.json.gz?dl=0 https://www.dropbox.com/s/oajyd6od2d4k46b/memory-report.anonymized.6h.json.gz?dl=0 If someone has an idea how this could happen, I would be very glad to hear it! And of course please don't hestitate to ask for more information.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 24.0 r0
  • The Videos 3.10.1 plugin handles video and audio streams.

Application

  • Firefox 50.1.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.1.0/Linux/en-GB/

Extensions

  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • CacheViewer 0.8.6.3.1-let-fixed ({71328583-3CA7-4809-B4BA-570A85818FBB})
  • fxdpi 1.2.1 (jid1-NBeCpDs9Bnbk3Q@jetpack)
  • HTML5 Notifications 1.2.2.1-signed.1-signed (html5notifications@paxal.net)
  • LeechBlock 1.0.5 ({a95d8332-e4b4-6e7f-98ac-20b733364387})
  • Min Vid 0.3.3 (@min-vid)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Privacy Badger 2016.12.15.1 (jid1-MnnxcxisBPnSXQ-eff@jetpack)
  • pwgen - Password Generator 0.5.2.1-signed.1-signed (pwgen@alouche.net)
  • Test Pilot 0.9.3-dev-e085559 (@testpilot-addon)
  • Tracking Protection Experiment 1.1 (blok@mozilla.org)
  • uBlock Origin 1.10.4 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Broadwell
  • adapterDeviceID: Mesa DRI Intel(R) Broadwell
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • crashGuards: []
  • currentAudioBackend: pulse
  • driverDate:
  • driverVersion: 3.0 Mesa 10.1.3
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'CairoUseXRender': 0, u'AzureContentBackend': u'cairo'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 6
  • supportsHardwareH264: No
  • webgl2Renderer: (no info)
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Broadwell
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

Did you try Safe Mode or a new profile?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

(diff report attached)

Did you try Safe Mode or a new profile? Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *Do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes (diff report attached)