Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox downloads via a shortcut on our intranet page an excel file in stead of opening it straight away.

  • 11 replies
  • 3 have this problem
  • 66 views
  • Last reply by FredMcD

more options

If I click the shortcut, I can choose to open it directly or to download it. I choose open in with excel (2013) but before doing that, the file download first and then opens in excel. If I refresh firefox, the problem is solved but after one session, the problem occurs again. Other times, it last for a week or serveral weeks and then occurs again. Some pc's have this problem, others don't. All have the latest updates of firefox / windows... There's no logic explanation, it occors with windows 7 - 10 thanks in advance...

All Replies (11)

more options

I am not sure what your problem is.

Whether you are saving the file or just viewing it, it still needs to be downloaded. If it is being viewed, it is placed in a temp folder and removed later.

more options

The intranet pages are on our on-site server. We placed an hour registration system for every individual employee on this site. If I click my registration sheet, I can choose to open with excel or download it first. Normally if it opens directly in excel, so no explicite download, I can modify the file and save it over the original file on the original location. If you choose download, the file goes in a standard map for example 'downloads' on your local computer and if you safe it, it will be saved there.

We had never had this issue until a few months ago. And like I already said, windows 7 32 / 64bit pc's, windows 10 pc's, latested firefox edition, there is no logic in it.

more options

What changed a few months ago? Protection programs? FF version?

more options

Protection is the same as before - Norton. FF updates when there is a newer version. (now 50.1.0) Office 2013 on all our pc's. So no manor changes.

more options

A thought; did you set that type of file to open in Firefox?

Deleting mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

more options

Thanks for a possible solution FredMcD. Unfortunately, the problem isn't solved. My only solution that sometimes works is to choose to refresh firefox. The first FF-session works like a charm, but after a restart, the problem occurs again.

more options

I called for more help.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Just tried it and yes, it still is...

more options
more options

I created a new profile and started firefox up. Again, the same result, it automatically download the excel file, although I choose for open directly in excel. After a refresh in the new profile, it works. But after a restart of firefox the problem is back.

more options

I called for more help