Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

drop-downs don't appear in firefox

  • 8 replies
  • 2 have this problem
  • 78 views
  • Last reply by stolzy

more options

On a number of websites I find that drop down boxes for dates etc don't work in Firefox, though they work fine in Safari. I have problems with these sites for example:

https://www.thetrainline.com https://www.airbnb.co.uk

All Replies (8)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

more options

FredMcD said

Many site issues can be caused by corrupt cookies or cache.
  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.
Type about:preferences<Enter> in the address bar.
  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.
If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode; Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Poke around safe websites. Are there any problems? Then restart.

Thanks for the suggestions, but none made any difference - the date fields remain un-selectable. Neither of sites quoted will let me click into the data field. In Safari, clicking on the date fields reveals a calendar.

AirBnB recommends Firefox, but poking around the web suggests that this is a common problem.

Modified by stolzy

more options

No problems here with opening the calendar with the current Firefox release on Linux.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Did you try Safe Mode?

more options

cor-el said

No problems here with opening the calendar with the current Firefox release on Linux. You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
Did you try Safe Mode?

Thanks for chipping in, but the fields are still inaccessible. Same in safe mode.

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Can you find these buttons in the Inspector and do they have an 'ev' button appended to indicate that there is a JavaScript onclick event attached?

You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools -> Web Developer) with this element selected.

You may have to search for these input fields. The screenshot I posted above shows part of the path in the DOM tree.

more options

cor-el said

Can you find these buttons in the Inspector and do they have an 'ev' button appended to indicate that there is a JavaScript onclick event attached? You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools -> Web Developer) with this element selected. You may have to search for these input fields. The screenshot I posted above shows part of the path in the DOM tree.

Thanks for helping out, but the output from the page inspector makes no sense to me (I'm not a programmer).

Maybe I just have to resign myself to using Safari for some websites :-(