X
Tap here to go to the mobile version of the site.

Support Forum

which webinar software should I use?

Posted

gotomeeting won't run on mozilla, so which should I use?

gotomeeting won't run on mozilla, so which should I use?

Chosen solution

Hi

This is not really a support issue with Firefox, but I will do my best to help.

I would recommend using the software that your fellow participants are using as you will probably all need to be on the same platform. Some suggestions that you could use are listed here.

I notice that you are using an older version of Firefox. I strongly recommend that you update to make sure that you have the latest security and stability fixes as well as new features. You can read more about how to update here.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 8.3.1
  • Citrix Online App Detector Plugin
  • GEPlugin
  • Google Update
  • Office Live Update v1.5
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 23.0 r0
  • 5.1.30514.0
  • Virtual Earth 3D 4.00090316005 plugin for Mozilla
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

Seburo
  • Top 10 Contributor
  • Moderator
714 solutions 5240 answers

Chosen Solution

Hi

This is not really a support issue with Firefox, but I will do my best to help.

I would recommend using the software that your fellow participants are using as you will probably all need to be on the same platform. Some suggestions that you could use are listed here.

I notice that you are using an older version of Firefox. I strongly recommend that you update to make sure that you have the latest security and stability fixes as well as new features. You can read more about how to update here.

Hi This is not really a support issue with Firefox, but I will do my best to help. I would recommend using the software that your fellow participants are using as you will probably all need to be on the same platform. Some suggestions that you could use are listed [https://support.mozilla.org/en-US/kb/hello-status here]. I notice that you are using an older version of Firefox. I strongly recommend that you update to make sure that you have the latest security and stability fixes as well as new features. You can read more about how to update [https://support.mozilla.org/en-US/kb/update-firefox-latest-version here].