Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spell check wont work

  • 2 replies
  • 13 have this problem
  • 264 views
  • Last reply by cor-el

more options

Spell check wont work, ive installed a dictonary, and the box is checked for check as i type

All Replies (2)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries: