On Monday September 25th from 10PM EDT - 12AM EDT (2AM UTC - 4AM UTC on September 26th), we will be performing system maintenance on the Firefox Accounts databases for two hours. During the maintenance window, there will be brief periods of a few minutes where users will not be able to login to their accounts. Please try again at a later time.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

From boot up FF ALWAYS opens with blank page.

  • 11 replies
  • 1 has this problem
  • 29 views
  • Last reply by Starnellka

more options

This has been going on for a couple of months. I've uninstalled and downloaded a new version, followed suggestions from the Tech Support Guy but FF is still opening a blank page. The only way I can then access my home pages is to close it down and open it from the programs list. FF is set to open on start up but it's gone wrong so all I can do is uncheck FF in msconfig/startup and try to manually make it open properly. This is infuriating as I like FF far better than any other but if it can't be solved I shall just have to uninstall it permanently and make do with Chrome. In addition I frequently get "Script may be busy...." messages on certain email links.

The same thing is happening on the laptop - FF opens with a blank page and then nothing works.

Can anybody help?

This has been going on for a couple of months. I've uninstalled and downloaded a new version, followed suggestions from the Tech Support Guy but FF is still opening a blank page. The only way I can then access my home pages is to close it down and open it from the programs list. FF is set to open on start up but it's gone wrong so all I can do is uncheck FF in msconfig/startup and try to manually make it open properly. This is infuriating as I like FF far better than any other but if it can't be solved I shall just have to uninstall it permanently and make do with Chrome. In addition I frequently get "Script may be busy...." messages on certain email links. The same thing is happening on the laptop - FF opens with a blank page and then nothing works. Can anybody help?

All Replies (11)

more options

Hello,

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu, click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

I really don't want to lose my customizations, extensions and preferences and have been trying to avoid doing it. I'm not young so it will be a real headache trying to put everything back. Isn't there another way?

And why is FF acting up on the laptop which my husband uses?

more options

Hi

Okay, please can you try:

  1. Type about:preferences into the address bar and open the General tab.
  2. What does it say next to Home Page: ?

Modified by Paul

more options

Starnellka said

FF is set to open on start up but it's gone wrong so all I can do is uncheck FF in msconfig/startup and try to manually make it open properly.

How did you set Firefox to launch at startup? For example, did you:

  • copy a program shortcut to a folder that Windows uses at startup?
  • add a command line to a Registry key?
  • something else?

If you followed some online instructions, can you provide a link to that page?

more options

Starnellka said

In addition I frequently get "Script may be busy...." messages on certain email links.

Are these links you are launching from an external email program (e.g., Thunderbird or the Outlook that comes with Microsoft Office), or from a webmail site (e.g., Outlook.com, Gmail, Yahoo!)?

It may be worth noting the address on the unresponsive script dialog:

  • addresses starting with the name of the site usually are features/functions of the page
  • addresses from other sites often (but not always) are advertising networks - using an ad blocking extension can help address issues with slow or dysfunctional ad network scripts
  • addresses starting with chrome:// usually are part of Firefox or of an extension you installed - the Skype extension sometimes causes this problem, for example

We have a general support article addressing potential solutions to this issue: Warning Unresponsive script - What it means and how to fix it.

Another common cause of unresponsive script errors on Windows 7 is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

Next to Home Page is says http://www.bbc.co.uk/news/uk which is the page I want. The main link, though there are a few others, that brings up the Script error page is via a TB email program.

As for how I set up FF to open on start up I really can't remember as I've been using it for years. I think it might have done it by itself but can't be sure as it's too long ago. I certainly wouldn't have touched the Registry then though I do now. Yesterday I unchecked the box in MSconfig/Start up so today I just clicked the icon on the taskbar. It opened as it should so perhaps, Seburo, you're on the right lines in that it's a start up problem. All you have to do is find out what to do next. Easy peasy! If only......

I really appreciate all the help you folks are giving me.

more options

Today I did a FF Refresh and discovered something I didn't know. I've used WOT Web of Trust for some years now without any noticeable problem but when I went to reinstall it I found that FF no longer supports it. Could that Add-on have been causing all the trouble?

I shall let you know if a Refresh has solved the original problem but it has certainly made FF faster though it still hangs near the end when I open a new webpage.

Modified by Starnellka

more options

Hi Starnellka, WOT was removed from the Add-ons site due to a data sharing issue. I don't know what effect it had when it was running.

More background: http://www.ghacks.net/2016/11/05/mozilla-and-google-remove-wot-extension/

more options

After trying all the solutions I can find here, on Tech Guy Solutions and on Google not much has changed. I now open FF manually via the short cut on the Taskbar. Sometimes it works, sometimes it opens with a blank page with a tiny white page attached to the cursor. The only thing I can do is to close the window and open it again, this time from the Windows list. Then I get the "Well, this is embarrassing...." message.

I'm now feeling very frustrated and fed up. I really, really like FF and don't want to change but this has become more than an annoying niggle.

more options

Something's definitely wrong with your Firefox and I hope we can figure it out.

I now open FF manually via the short cut on the Taskbar. Sometimes it works, sometimes it opens with a blank page with a tiny white page attached to the cursor.

I'm not sure I've seen the second thing you describe. There is a white box that follows the mouse pointer around the screen? Does that last indefinitely or does it go away after a little while?

When the blank page opens, do you get a window on screen, or only the blank page thumbnail above the Firefox icon on the Windows Taskbar?

Assuming you get a window on screen, do any buttons or controls work? For example, does the home button load your home page, or if you submit a search in the address bar, does your default search engine appear with results?

If Firefox works normally after the home page fails to load, it reminds me of a problem from a year or three ago. Not sure how to find those threads to see what was causing that...

The only thing I can do is to close the window and open it again, this time from the Windows list. Then I get the "Well, this is embarrassing...." message.

That screen usually appears if Firefox crashed (did not shut down normally) and then was unable to automatically restore your previous session windows and tabs. So two things had to go wrong to see that.

Does the box on the page list the expected windows and tabs or is the box also blank?

more options

Firstly, when FF opens with a blank page and the little page attached to the cursor nothing works so I can only close it down from the task bar. The blank page doesn't show any tabs or tab headings but does show the toolbars. The little page attached to the cursor lasts indefinitely. Cannot submit a search or do anything else.

When FF opens (from the Windows listing) I get the 'embarrassing' message and it asks me if I would like to restore my pages. These pages are always my home page and a Windows page (not sure what that is). I then have the option to either restore or Close. I usually close but restore does work.

I hope this information will help you to discover the problem because Chrome opens without any niggles at all. The trouble is that I so prefer FF which is customisable.