X
Tap here to go to the mobile version of the site.

Support Forum

how do i get the annoying notification about fullscreen video disabled, from blocking my view of video...i could care less about fullscreen...please help!!!

Posted

i couldn't care less about viewing full screen, just want that annoyoing notification from appearing, when i watch a video, and it doesn't block the name of the video...please help!!!

i couldn't care less about viewing full screen, just want that annoyoing notification from appearing, when i watch a video, and it doesn't block the name of the video...please help!!!

Additional System Details

Installed Plug-ins

  • Adobe Acrobat Plug-In Version 5.00 for Netscape
  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • Shockwave Flash 23.0 r0

Application

  • Firefox 50.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.0.2/WINNT/en-US/

Extensions

  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • PC Matic 1.01 (noreply@pcpitstop.com)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Video DownloadHelper 6.1.1 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 745
  • adapterDescription2:
  • adapterDeviceID: 0x1382
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nvhdcwu.inf_amd64_16f6c9b501baeb7d\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nvhdcwu.inf_amd64_16f6c9b501baeb7d\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvhdcwu.inf_amd64_16f6c9b501baeb7d\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvhdcwu.inf_amd64_16f6c9b501baeb7d\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nvhdcwu.inf_amd64_16f6c9b501baeb7d\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nvhdcwu.inf_amd64_16f6c9b501baeb7d\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvhdcwu.inf_amd64_16f6c9b501baeb7d\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvhdcwu.inf_amd64_16f6c9b501baeb7d\nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 4096
  • adapterRAM2:
  • adapterSubsysID: 6893103c
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.14393.351
  • driverDate: 8-1-2016
  • driverDate2:
  • driverVersion: 21.21.13.6909
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'ApzWheelInput': 1}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: Yes; Using D3D11 API
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 745 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Happy112 561 solutions 5694 answers

Helpful Reply

Hi   !
That will take you only a few minutes   :
Type in the address bar :   about:config (promise to be careful) Type :   full Look for :  full-screen-api.warning.timeout and change it's value from   '3000'   to   0
Done   !

Hi &nbsp; !<BR> That will take you only a few minutes &nbsp; :<BR> Type in the address bar : &nbsp; '''about:config''' (promise to be careful) Type : &nbsp; ''' full''' Look for :&nbsp; '''full-screen-api.warning.timeout''' and change it's value from &nbsp; '3000' &nbsp; to &nbsp; '''0'''<BR> Done &nbsp; !

Question owner

thank you for the help, changed number to "0", but annoying notifications still appear...restarted computer and went back to page, and "0" is still there, but also the notifications.

thank you for the help, changed number to "0", but annoying notifications still appear...restarted computer and went back to page, and "0" is still there, but also the notifications.
Happy112 561 solutions 5694 answers

Bummer   !   That should have worked   ......
But here's an add-on that should do the trick:
https://addons.mozilla.org/en-US/firefox/addon/disable-html5-fullscreen-alert/

Bummer &nbsp; ! &nbsp; That should have worked &nbsp; ......<BR> But here's an add-on that should do the trick:<BR> https://addons.mozilla.org/en-US/firefox/addon/disable-html5-fullscreen-alert/

Question owner

appreciate your help, but it didn't work...read the reviews and changed the number to a minus, but still didn't work...a bunch said it didn't work on 42 or better...i do have a few old files, maybe tomorrow i'll install an older one, again thanks!!!

appreciate your help, but it didn't work...read the reviews and changed the number to a minus, but still didn't work...a bunch said it didn't work on 42 or better...i do have a few old files, maybe tomorrow i'll install an older one, again thanks!!!
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40244 answers

See if this works.

full-screen-api.warning.timeout to -1

See if this works. '''full-screen-api.warning.timeout ''' to '''-1'''
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB

Note that you can get this alert if the video is embedded in an iframe and that the outermost iframe is missing the allowfullscreen="true" attribute that Firefox needs. You can set dom.event.contextmenu.enabled to false as a workaround. Then you have a Full Screen item in the right-click context menu.

Can you attach a screenshot? *https://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot *make sure you do not exceed the maximum size of 1 MB ----- Note that you can get this alert if the video is embedded in an iframe and that the outermost iframe is missing the allowfullscreen="true" attribute that Firefox needs. You can set dom.event.contextmenu.enabled to false as a workaround. Then you have a Full Screen item in the right-click context menu. *https://blog.pearce.org.nz/2011/11/firefoxs-html-full-screen-api-enabled.html
Happy112 561 solutions 5694 answers

Helpful Reply

Do you see this in   'about:config' : full-screen-api.approval-required If so, set it's value to   false (haven't tried this myself, as it's not in my   'about:config')

Do you see this in &nbsp; 'about:config' : '''full-screen-api.approval-required''' If so, set it's value to &nbsp; '''false''' (haven't tried this myself, as it's not in my &nbsp; 'about:config')

Question owner

thank you, but it was already false.

thank you, but it was already false.
Happy112 561 solutions 5694 answers

makesimple said

thank you, but it was already false.

Then would you set it to   true   please   (makes way more sense, doesn't it   ?).

''makesimple [[#answer-941187|said]]'' <blockquote> thank you, but it was already false. </blockquote> Then would you set it to &nbsp; '''true''' &nbsp; please &nbsp; (makes way more sense, doesn't it &nbsp; ?).

Question owner

unfortunately the dreaded notification still appears...thank you.

unfortunately the dreaded notification still appears...thank you.
Happy112 561 solutions 5694 answers

Bummer   !!! How about what 'the-edmeister' suggested:
full-screen-api.warning.timeout and set it's value to -1   (?)

Bummer &nbsp; !!! How about what 'the-edmeister' suggested:<BR> '''full-screen-api.warning.timeout''' and set it's value to '''-1''' &nbsp; (?)

Question owner

tried that, when i go back, it resets at 0. thank you.

tried that, when i go back, it resets at 0. thank you.
Happy112 561 solutions 5694 answers

I'm running completely out of ideas ......... Would you take a look at this and see if maybe there's something here that you'd like to try:
superuser.com/questions/613794/disable-firefox-fullscreen-warning-with-html5-stuff

I'm running completely out of ideas ......... Would you take a look at this and see if maybe there's something here that you'd like to try:<BR> superuser.com/questions/613794/disable-firefox-fullscreen-warning-with-html5-stuff
Happy112 561 solutions 5694 answers

Did some more searching and found this:
in   about:config full-screen-api.warning.delay change it's value from '500' to 20

By the way: The reason for this annoying warning is just in case some bad site tries to fool you with a full screen replica. Full screen is not limited to videos.

Did some more searching and found this:<BR> in &nbsp; '''about:config''' '''full-screen-api.warning.delay''' change it's value from '500' to '''20'''<BR> By the way: The reason for this annoying warning is just in case some bad site tries to fool you with a full screen replica. Full screen is not limited to videos.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40244 answers

Happy112 said

superuser.com/questions/613794/disable-firefox-fullscreen-warning-with-html5-stuff

asked - 3 years ago viewed - 25432 times active - 1 year ago

That could be why a particular pref doesn't appear in a current version of Firefox.

As cor-el requested - please post a screenshot of the meassge that you want to block or hide. There is more than one "fill screen" message, even for videos, afaik. The one for Flash is the one I object to, but not enough to hide it.

See this support article. How do I create a screenshot of my problem? It is best to use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed a maximum file size of 1 MB.

Then use the Browse .... button below the Post a Reply text box to upload the screenshot.

''Happy112 [[#answer-941250|said]]'' <blockquote> '''superuser.com/questions/613794/disable-firefox-fullscreen-warning-with-html5-stuff''' </blockquote> '''asked - 3 years ago''' viewed - 25432 times active - 1 year ago That could be why a particular pref doesn't appear in a current version of Firefox. As cor-el requested - '''please post a screenshot of the meassge that you want to block or hide.''' There is more than one "fill screen" message, even for videos, afaik. ''The one for Flash is the one I object to, but not enough to hide it.'' See this support article. [https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem How do I create a screenshot of my problem?] It is best to use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed a maximum file size of 1 MB. Then use the '''Browse ....''' button below the '''''Post a Reply''''' text box to upload the screenshot.

Question owner

i appreciate your help, set it to 20, annoying note still appears...the amusing thing is i'm not using fullscreen, and i can't read the artist name, unless i play the video, and can figure out who they are. thank you.

i appreciate your help, set it to 20, annoying note still appears...the amusing thing is i'm not using fullscreen, and i can't read the artist name, unless i play the video, and can figure out who they are. thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

I assume that this is about media on a web page uses the HTML5 media player and that this player is embedded. If you click the full screen button on that player then you can get this warning if Full Screen mode isn't available for some reason, likely a missing allowfullscreen="true" attribute like I wrote above. The warning that the others contributors address is about the message you see if you open the player in full screen mode.

I assume that this is about media on a web page uses the HTML5 media player and that this player is embedded. If you click the full screen button on that player then you can get this warning if Full Screen mode isn't available for some reason, likely a missing allowfullscreen="true" attribute like I wrote above. The warning that the others contributors address is about the message you see if you open the player in full screen mode.

Question owner

i've been trying to make a screenshot, but not the brightest bulb when it comes to computers. it appears in upper left corner and covers the artist name, and most of the title of the song.

i've been trying to make a screenshot, but not the brightest bulb when it comes to computers. it appears in upper left corner and covers the artist name, and most of the title of the song.

Question owner

i could understand if i were trying to go full screen, and note appears, but most of the time, i'm curious who and what they are playing.

i could understand if i were trying to go full screen, and note appears, but most of the time, i'm curious who and what they are playing.