Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox causes BSOD issue 41

  • 5 replies
  • 1 has this problem
  • 655 views
  • Last reply by ilozen

more options

I'm having constant BSODs on Firefox when browsing the web. It seems random, sometimes appears on facebook, youtube, other sites.

I've disabled hardware acceleration in FF but it didn't help. I'm using Win7 which is up to date.

I don't know what other info would be needed so please let me know and I will provide it.

Chosen solution

Thank you, I will try it!

Edit: Due to other issues I had to change RAM and reinstall system in my machine and it seems that since I did that the problem is gone.

Read this answer in context 👍 0

All Replies (5)

more options

How long before the BSOD? Keep track of what was on the page at the time. Text, clips . . .

Did you get any crash reports from Firefox?

more options

Thank you for a quick reply.

Usually it's about 2-3 seconds after the page starts loading. As far as I can tell the BSOD happens before the page finishes loading in full. As for contents: it's enough if it has text and images. So far 90% was when there was some clip playing but I had some where there were no clips at all.

I'm not getting any crash reports. One second FF is loading up the page and the next it's already the BSOD screen. I checked the Crash reports folder on my drive and there are no reports (sent or pending) from last BSOD.

Also I forgot to say previously - I've been having this issue for a few months now. Since it started happening I haven't changed my hardware or system in any way. I've already reinstalled FF. I though I got rid of it but it came back.

Modified by ilozen

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you!

more options

If Firefox runs well in the diagnostic Safe Mode, a good first thing to try in Standard Mode is to disable your QCLean extension. It is known to have caused problems.

Modified by alan_r

more options

Chosen Solution

Thank you, I will try it!

Edit: Due to other issues I had to change RAM and reinstall system in my machine and it seems that since I did that the problem is gone.

Modified by ilozen