Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My AOL email keeps showing "connection is not secure". I tried changing default programs to open on both PC & FF but no fix! Gray padlock w/yellow triangle.

  • 1 reply
  • 1 has this problem
  • 7 views
  • Last reply by jscher2000

more options

Opening AOL emails only (not spam) using: mail.aol.com I get the grey padlock with the yellow triangle. Clicking on it says "connection is not secure", "parts of this page are not secure". I've read and tried every suggestion without any luck.

I also get another message "You have not granted this site any special permissions", however, the check box and x are both grayed out, so not sure if that's part of the error's or not.

I also get another message from the yellow triangle, under "more information", security "view certificate ":

Owner: This website does not supply ownership information. Verified by: Not specified

And finally, under security: under Technical Details: Connection Partially Encrypted Parts of the page you are viewing...

I've tried changing the default programs using: start, all programs, set default programs, I don't actually see "AOL mail" listed but I chose "Windows Mail" and and set that as default. In the same window I also tried choosing Firefox and setting that as default, neither one fixed the issue.

Then I went to the Firefox "menu" (top right), chose "options" and chose Firefox as my default browser (it was already set).

I just downloaded Firefox 49.0 for the first time as my only browser because Google stopped all updates on Flash player for Vista OS (sucks), I then deleted all Google stuff.

I then tried going to AOL for help. UGH! I only use AOL for my email account because AOL sucks big time, but I don't want to change my email address, so I'm basically stuck with AOL mail. AOL (of course) didn't give me any information on how to make my email account "a secure connection" on my new Firefox browser account so that I see only a green padlock with no grey padlock and no yellow triangles.

I've searched for fixes going on a week now with no luck, so I hope someone can give me a fix to this annoying issue I am having.

All Replies (1)

more options

When a page uses an HTTPS address, but some elements of the page would be loaded on an HTTP address, this is considered a "mixed content" situation. Firefox has two behaviors:

(1) Blocking mode: Firefox blocks the most dangerous kinds of mixed content, such as scripts.

(2) Advisory mode: Firefox loads low risk mixed content, such as images, and changes the icon to the gray lock with the warning triangle.

This article has more information on mixed content and the icons: Mixed content blocking in Firefox.

Now... the key question is whether you should be concerned.

When you are working with user-generated content such as email messages or forum posts, the user may never have anticipated that the content would be viewed on a secure connection and therefore didn't think to use HTTPS links. And some embedded images might not be available through an HTTPS connection anyway. In these situations, if you are interested in the content and not exposing personal information in the page, it seems like a reasonable risk to run.

You would never expect to see mixed content on a site dealing with highly sensitive information, such as financial or health information. You also would not expect to see the icon on a page that isn't displaying user-generated images. If that happens, it could be flagging a bad add-on that is injected unwanted ads into a page. In those cases, it would be worth investigating the warning in more detail. One way to do that is:

  • Open Firefox's Web Console in the lower part of the tab using either:
    • Ctrl+Shift+k
    • "3-bar" menu button > Developer > Web Console
  • The Web Console should open in the lower part of the tab. Then reload the page (Ctrl+r) and the console will display some warnings and errors. To filter the list, type mix in the box at the upper right of the list that says Filter output and you should see specific messages about the mixed content in the page that triggered the warning.