Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

All Facebook links return a page of symbols, gibberish

  • 3 replies
  • 1 has this problem
  • 29 views
  • Last reply by jscher2000

more options

Other browsers work on my system. I've tried refreshing Firefox, updating and disabling plugins, and removing cookies and cache. I found another related question and solution (it was actually a work around) for this on the forum but I did not understand how to implement it.

Chosen solution

Excellent! That worked!

Yes we use Qustodio and Open DNS filters. Should I change the config back and try to debug? or just leave it alone now that it works?

Read this answer in context 👍 0

All Replies (3)

more options

Did the other thread mention "Brotli" compression? There was a problem when Firefox and Facebook first started using Brotli compression to speed transfers from the site because some users had filtering software that didn't understand this new thing. Can you think of any filtering software you might be using? It could be part of your security software or parental control software or ... malware, but hopefully not.

The workaround is to edit a Firefox preference so that Firefox does not tell sites it can use Brotli compression. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste enco and pause while the list is filtered

(3) Double-click the network.http.accept-encoding.secure preference and edit as follows: delete the , br from the end so it just reads gzip, deflate like the preference above it in the list, and then click OK

Facebook will use the older gzip form of compression instead.

Any difference? If so, we should try to figure out what is wrong with your web filtering software (or whether you have malware intercepting your connection).

more options

Chosen Solution

Excellent! That worked!

Yes we use Qustodio and Open DNS filters. Should I change the config back and try to debug? or just leave it alone now that it works?

more options

The issue is probably with Qustodio. You might mention it to them.

To my knowledge, OpenDNS doesn't proxy your connection, it checks the server against a blacklist and redirects to an error page if the site is dangerous or violates policy. So I don't think OpenDNS is the problem.