Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am no longer able to sync my bookmarks because they continuously duplicate.

  • 11 replies
  • 1 has this problem
  • 54 views
  • Last reply by ibeforem

more options

I am running Firefox with Sync on 3 different machines. I can no longer sync my bookmarks because they continuously duplicate. It got to the point where my browser was unusable. I've already reinstalled on all machines with a fresh profile and thought I would be okay to sync my bookmarks again, but when I logged in this morning my bookmarks had duplicated again, at least 3 times. Thankfully this time I was able to remove bookmarks from sync and delete the extras without having to blow everything up, but I'd really like to be able to keep my bookmarks in sync again.

Chosen solution

Please don't use iCloud [or any other "sync"-type service] for bookmarks along with using Sync. Known to cause compatibility problems and won't fix anything; it's only liable to exacerbate the issue.


Starting from scratch on all devices and not clearing the corrupt data from the Sync server just 'syncs' the corrupted data to all your devices all over again. The initial cause needs to be fixed.


To fix this situation. 1. Disable Sync on all devices until all devices are fixed. 2. Run Places Maintenance on all devices, to effect a fix of the Places database on each device, https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ 3. Change your Firefox Account password (for Sync) to clear the corrupt data from the Sync server. 4. Then connect the first "desktop" device to the Sync server and let that device to stay connected to Sync for an extended period (IOW, keep Firefox on that device running for a long time). 5. The following day connect the 2nd "desktop" device to Sync and let that one run for an extended period. Make sure that your bookmarks are synchronizing correctly and you aren't losing any of them or seeing them getting corrupted in any manner before proceeding to additional devices.

Read this answer in context 👍 0

All Replies (11)

more options

Hi   !
Maybe this will help:
https://addons.mozilla.org/en-US/firefox/addon/bookmark-duplicate-cleaner
If this doesn't solve the problem, or is not what you want:   we will have to keep looking  ......

more options

I've tried the duplicate cleanser to help clean up the mess afterwards. The first time, there were just too many duplicated -- literally over 10,000. This time I was able to clean it up. But it's not keeping the duplicates from happening again.

more options

Stab in the dark: Are you by any chance running a standalone copy of Xmarks for IE   ? If so:   uninstall it.

more options

No, these machines were set up after the demise of Xmarks. But thank you for trying!

more options

Not giving up just yet and here's another stab in the dark: Maybe, just maybe, your iCloud bookmark sync with Firefox is syncing 2-way instead of 1-way   ......

more options

Do you know where to check that setting? I can't find it. But for what it's worth, I only have one set of bookmarks on my phone (though I don't know how often it syncs with my phone).

more options

Had to look that up myself   (I don't 'sync' anything;   I only use a laptop). Here's what I found:

  • Open iCloud for Windows.
  • Click Options next to Bookmarks.
  • Deselect the Firefox checkbox. Click OK.
  • Click Apply, then click Remove.

Maybe you don't even have iCloud,   but something like   OneDrive
instead   .......

Modified by Happy112

more options

I'll give that a shot, thanks!

more options

ibeforem said

I'll give that a shot, thanks!

Take your time   !
(but let us know how you're getting on,  will you   ?)

more options

Chosen Solution

Please don't use iCloud [or any other "sync"-type service] for bookmarks along with using Sync. Known to cause compatibility problems and won't fix anything; it's only liable to exacerbate the issue.


Starting from scratch on all devices and not clearing the corrupt data from the Sync server just 'syncs' the corrupted data to all your devices all over again. The initial cause needs to be fixed.


To fix this situation. 1. Disable Sync on all devices until all devices are fixed. 2. Run Places Maintenance on all devices, to effect a fix of the Places database on each device, https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ 3. Change your Firefox Account password (for Sync) to clear the corrupt data from the Sync server. 4. Then connect the first "desktop" device to the Sync server and let that device to stay connected to Sync for an extended period (IOW, keep Firefox on that device running for a long time). 5. The following day connect the 2nd "desktop" device to Sync and let that one run for an extended period. Make sure that your bookmarks are synchronizing correctly and you aren't losing any of them or seeing them getting corrupted in any manner before proceeding to additional devices.

more options

I think turning off the iCloud sync did the trick! Things have been straightened out for a few days. Thanks for all your help!