X
Tap here to go to the mobile version of the site.

Support Forum

What in the heii is going on with this bloody browser!?!?

Posted

OK, so what in the heck is going on ..... !?

It seems like ever since a few MS patch Tuesdays a while ago my Firefox'es are now acting like crap ..... I'm getting constant crashes and restarts! I can't even run it on some machines at home now so I have to use chrome because flash stuff keeps barfing ....

I'm also getting this constant crap where its asking me where it keeps asking me if I want to allow all of my add-in's - constantly!! (see attachment) It opens multiple tabs across the top for each of my add-in's - "oh do you want to allow this" - well DUH - WTF ?? - I added them in for a reason!!!

I am getting so pissed with Firefox I've even resorted to added Chrome on to all of my systems, Booo!

It used to be a good stable browser, why is it screwing up the same way on 5 different PC's? Yes, you can tell from my tone that it's driving me nuts!!! It almost feels like MS did something in the last few batches in Patch Tues to deliberately screw up Fire fox!!

Is anyone else seeing this .....?

Cheers' Dave

OK, so what in the heck is going on ..... !? It seems like ever since a few MS patch Tuesdays a while ago my Firefox'es are now acting like crap ..... I'm getting constant crashes and restarts! I can't even run it on some machines at home now so I have to use chrome because flash stuff keeps barfing .... I'm also getting this constant crap where its asking me where it keeps asking me if I want to allow all of my add-in's - constantly!! (see attachment) It opens multiple tabs across the top for each of my add-in's - "oh do you want to allow this" - well DUH - WTF ?? - I added them in for a reason!!! I am getting so pissed with Firefox I've even resorted to added Chrome on to all of my systems, Booo! It used to be a good stable browser, why is it screwing up the same way on 5 different PC's? Yes, you can tell from my tone that it's driving me nuts!!! It almost feels like MS did something in the last few batches in Patch Tues to deliberately screw up Fire fox!! Is anyone else seeing this .....? Cheers' Dave
Attached screenshots

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Citrix Online App Detector Plugin
  • GEPlugin
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • PDF-XChange Viewer Netscape Gecko Plugin
  • Shockwave Flash 23.0 r0
  • 5.1.50901.0
  • VLC media player Web Plugin

Application

  • Firefox 49.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
  • Support URL: https://support.mozilla.org/1/firefox/49.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.8.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Asynchronous Plugin Rendering 2.0 (asyncrendering@mozilla.org)
  • F.B Purity - Cleans up Facebook (WX) 16.0.0.13 (fbpElectroWebExt@fbpurity.com)
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Multirow Bookmarks Toolbar 6.0 ({FBF6D7FB-F305-4445-BB3D-FEF66579A033})
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6739
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 21f81458
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 10-12-2011
  • driverDate2:
  • driverVersion: 8.902.0.0
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: No; D3D9 blacklisted with DLL atiumd64.dll (7.14.10.867)
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6800 Series Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4271 solutions 59919 answers

davecason said

it keeps asking me if I want to allow all of my add-in's - constantly!!

It is possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete all extensions files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":


You will have to approve the updating one last time.

''davecason [[#question-1145494|said]]'' <blockquote> it keeps asking me if I want to allow all of my add-in's - constantly!! </blockquote> It is possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Folder.''' To its right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Delete all '''extensions''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons ----------- You will have to approve the updating one last time.
FredMcD
  • Top 10 Contributor
4271 solutions 59919 answers

davecason said

I'm getting constant crashes and restarts!

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx29
''davecason [[#question-1145494|said]]'' <blockquote> I'm getting constant crashes and restarts! </blockquote> In the address bar, type '''about:crashes'''<enter>.''' Note:''' If any reports do not have '''BP''' in front of the numbers/letters, click it to submit them. '''The crash report is several pages of data.''' '''We need the report numbers to see the whole report.''' Using your mouse, '''mark''' the most '''resent 7 - 10''' crash reports, and '''copy''' them. Now go to the reply box below and '''paste''' them in. (Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.) ;[[Image:aboutcrashesFx29|width=500]]
FredMcD
  • Top 10 Contributor
4271 solutions 59919 answers

davecason said

flash stuff keeps barfing

What do you mean by this?

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

''davecason [[#question-1145494|said]]'' <blockquote> flash stuff keeps barfing </blockquote> What do you mean by this? If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Question owner

OK, so here is more of the same thing !! And it's happening on 5 different computers in 2 different locations! Nearly every single fuggen day !! WTH!?

Got in today, used FF for a few hours ..... open and close lots, shut it down again and then when I re-opened it for 5th time ..... boom!!

Cheers' Dave

OK, so here is more of the same thing !! And it's happening on 5 different computers in 2 different locations! Nearly every single fuggen day !! WTH!? Got in today, used FF for a few hours ..... open and close lots, shut it down again and then when I re-opened it for 5th time ..... boom!! Cheers' Dave
FredMcD
  • Top 10 Contributor
4271 solutions 59919 answers

It is possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete all extensions files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":


You will have to approve the updating one last time.

It is possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Folder.''' To its right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Delete all '''extensions''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons ----------- You will have to approve the updating one last time.

Question owner

Hi,

So here's another example, on a different computer completely.

Run it - open and close it lots - its happy - next time open it again and see this across the top of the tool bar:

go in to each one and check: Allow this installation - and restart and for sure it's gonna happen again on all 5 PC's?!? That's just weird.

I'll try Freds suggestion on one of the systems ....

Cheers' Dave

Hi, So here's another example, on a different computer completely. Run it - open and close it lots - its happy - next time open it again and see this across the top of the tool bar: go in to each one and check: Allow this installation - and restart and for sure it's gonna happen again on all 5 PC's?!? That's just weird. I'll try Freds suggestion on one of the systems .... Cheers' Dave

Question owner

Hi Gang,

Nope, tried what Fred suggested ..... went in to about :support and deleted both *.INI's and all of the extensions and NADA.

Turned on FF this morning and got the same damm prompt - "Allow this installation " checked off all three and restarted it and no luck.

Here is a picture of the now current settings and its showing ALL of the extensions still disabled - after the above re-start ( which is better than usual where they're usually all gone from FF Add-On's so at least they're still in FF this time )

So here is Pic 2 where I manually went in an turned them all back on again for the million-th time ..... (grin)

I guess it's not really a crash per se because the FF does load and start but every 3 - 4th time it toasts all of the extensions.

Is there a file I can submit that's a log or something and can you guys make any suggestions on HOW to go about capturing the right info from FF for that file?

Cheers' Dave

Hi Gang, Nope, tried what Fred suggested ..... went in to about :support and deleted both *.INI's and all of the extensions and NADA. Turned on FF this morning and got the same damm prompt - "Allow this installation " checked off all three and restarted it and no luck. Here is a picture of the now current settings and its showing ALL of the extensions still disabled - after the above re-start ( which is better than usual where they're usually all gone from FF Add-On's so at least they're still in FF this time ) So here is Pic 2 where I manually went in an turned them all back on again for the million-th time ..... (grin) I guess it's not really a crash per se because the FF does load and start but every 3 - 4th time it toasts all of the extensions. Is there a file I can submit that's a log or something and can you guys make any suggestions on HOW to go about capturing the right info from FF for that file? Cheers' Dave
FredMcD
  • Top 10 Contributor
4271 solutions 59919 answers

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

'''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save''' '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Question owner

Here's is the usual thing you see after it craps out too ...... opened it this morning and all the extensions are gone again .....

Here's is the usual thing you see after it craps out too ...... opened it this morning and all the extensions are gone again .....

Question owner

Here's the pic and this time 6 where this is happening ......

Here's the pic and this time 6 where this is happening ......
FredMcD
  • Top 10 Contributor
4271 solutions 59919 answers

What are you using as your protection programs? Are you using anything listed in my last post? Have you checked the link?

What are you using as your protection programs? Are you using anything listed in my last post? Have you checked the link?

Question owner

Hi Fred,

Nope, no protection programs running just these three add-ins right now.

I'll run a firefox re-fresh and see what that does.

Cheers' Dave

Hi Fred, Nope, no protection programs running just these three add-ins right now. I'll run a firefox re-fresh and see what that does. Cheers' Dave