Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox/ how to get rid of?

more options

The question says it all actually. I see that everytime I open up Firefox, that and my spellcheck stopped working for some reason. It is checked and turned on always.

The question says it all actually. I see that everytime I open up Firefox, that and my spellcheck stopped working for some reason. It is checked and turned on always.

All Replies (3)

more options

On the first question, I assume if you launch a new window using Ctrl+n or go to your home page using the Home button on the toolbar, you do not see the problem there. Assuming that's true, please check this:

The Firefox icon can be set up to launch specific pages at startup (or more specifically, when you use the icon). To check whether that is set:

First, open the shortcut as follows:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On 64-bit Windows, that usually is no more and no less than the following:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If anything follows after that, try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox

Success?

more options

It wasn't even that difficult, it was more stupid than anything. I use the toolbar at the bottom, I think of the actual name. As it turns out, that short-cut has become currupt so when I unpinned and repinned it, it started working again. Now it is just my spellcheck that isn't working again which has been a recurring problem with firefox in the past. I wonder if that has something to with the updates. If you know of a quick-fix than please tell me.

Modified by davidofga

more options

For spell-checking, here's the behavior I normally see:

  • single-line form controls (<input>): the right-click context menu does not have a checkmark before Check Spelling, and misspellings are NOT marked unless you turn that on (you can change a setting to turn this on by default)
  • multi-line form controls (<textarea> like this one I'm typing into now): the right-click context menu has a checkmark before Check Spelling, and misspellings are marked, unless the site disables it
  • "rich text" editing areas (e.g., composing a message on webmail in an portion of a document marked contenteditable="true"): same as a multi-line form controls, but sometimes it is disabled for strictly

Does yours not follow that pattern?

Probably the most common spelling issues users raise are with missing dictionaries or language confusion. Those are not issues I am familiar with resolving.