Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox spikes CPU usage and stops responding.

  • 13 replies
  • 5 have this problem
  • 49 views
  • Last reply by lemur21

more options

This issue actually started when I *lost* all my add-ons (https://bugzilla.mozilla.org/show_bug.cgi?id=1290457) after updating to FF 47 ... I then downgraded back to FF 46. Shortly after that, my HD failed (and the issue stopped being an issue, obviously). However, Firefox runs slowly now. I know I have a few extensions, and it ran slowly before - but now, with a new SSD in the machine, I thought it would fly.

I tried to diagnose if it might be the connection -- but, I then found that to be unlikely (because I can't imagine a poor connection causing the CPU to spike) -- (see images). In general, it's always using a lot of CPU - but, 3-7 times per HOUR, it locks up (second image); in fact, it happened three times JUST while I was typing this bug report.

I was advised by a volunteer (I believe) to download the "Gecko Profiler extension" and do some analysis.

Here are three links to the data (I believe the third one happened *during* one of the "not responding" episodes:

https://cleopatra.io/#report=c00b64c17745769d47192a885151781dc9438e70 https://cleopatra.io/#report=c7abdc6b83d90f54dad1b04281f46b16bf44739d https://cleopatra.io/#report=43d908fec8b7bf87d2026b059b2f788b37d3308f

But, I have no idea how to read/interpret them.

Can someone please provide me with an idea of what's causing the hang-up? I really don't want to switch to Chrome (how can they insist that the tabs be *above* the address bar?) but, that's starting to look like my only option (which is a shame, since I've used this family of browser since Netscape, years and years ago .....)

Thanks!

Attached screenshots

All Replies (13)

more options

Bumping - and adding another piece of info:

I upgraded from 46 to 47 (despite the fact that 47 caused all my problems initially). I did this so I could run the about:performance tab.

Apparently "all" my add-ons "seem to have slown down Firefox very often ... This seems preposterous.

I have a total of 24 add-ons and 15 (15!) of them have this warning next to them. I can click on each one to read the "more" section; but -- again -- not sure what I'm looking for. I did this, primarily, so whomever sees this has as much information as possible,

more options

Bump?

Really - no one else has ever had this happen? LOL

more options

Sorry, sometimes we get too many calls for help. What version are you using now?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Hi Fred,

I'm using 47.0.1 -- so I could access the about:performance screen.

I didn't think the problem would be there; but yes - when I hit cnn.com, it froze up (and, I had the resource monitor open, so I could see that the cpu had spiked (to about 20) and the line had turned red (as in the pictures above).

more options

Hmm, lots of pics.

Have you tried Safe Mode?

more options

I'm sorry - I wasn't clear ...

When I said "I didn't think the problem would be there" - I meant, yes - that happened while in Safe Mode.

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Yes - I started my computer in safe mode with networking and then tried starting Firefox in safe mode, as well.

Once I got to cnn.com, it went to "not responding"

This time, though, I got an error message, as well:


"A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue.

Script: http://cdn.optimizely.com/js/131788053.js:1124"

more options

I opened several pages but had no problem.


Make sure your Java (Not JavaScript) is up to date Verify Java and Find Out-of-Date Versions {web link}

Version 8 Update 111 Release date October 18, 2016 http://java.com/en/download/manual.jsp


https://support.mozilla.org/en-US/kb/warning-unresponsive-script

more options

Java is up-to-date.

Problem is happening MUCH more regularly now.

I opened a bug report with Buzilla, since my only other option is Chrome :(

more options

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.


more options

I had this problem with all the recent versions of Firefox - open few tabs, run awhile, CPU usage of Firefox makes the entire computer unusable. This is a Core i7 quad - not an old clunker. I followed every trick suggested everywhere (wasting countless hours over countless days), and resorting to re-starting Firefox 5+ times per day as a "workaround."

In lieu of installing a Google-spyware product, I tried the Pale Moon browser - a fork off of the Firefox code before the interface was destroyed. The CPU problem went away entirely, and I no longer need a bunch of "classic" plugins running to "re-create" the original Firefox look, feel, and missing menu-options. I was able to import all my Firefox settings, bookmarks, etc with one copy command - so both painless, and effective.

more options

Yeah -- I was in the same boat. CPU usage of FF was crazy.

I *wish* I only had to restart FF 5x a day ... I was getting "not responding" errors 8-12 times an hour!

I am using Chrome now, nearly exclusively; but using CyberFox to manage my bookmarks (and syncing between the two browsers using EverSync).

I think I did download PaleMoon, and found that it wasn't as CPU-light as CyberFox, ultimately (but, that was when I was still intending to stay in a Mozilla environment).