X
Tap here to go to the mobile version of the site.

Support Forum

Flash doesn't work

Posted

Within the past week, Flash completely stopped working in Firefox 49.0.2 (64-bit) on Windows 7. I can get it working at, e.g., http://www.adobe.com/software/flash/about/ if I remove all of my extensions, but as soon as I reinstall, say, Firebug, it's gone again.

Can anyone help me troubleshoot? Thanks!

Within the past week, Flash completely stopped working in Firefox 49.0.2 (64-bit) on Windows 7. I can get it working at, e.g., http://www.adobe.com/software/flash/about/ if I remove all of my extensions, but as soon as I reinstall, say, Firebug, it's gone again. Can anyone help me troubleshoot? Thanks!

Chosen solution

Some users are having problem with Flash due to an incompatibility with a new feature. You could try turning it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste async and pause while the list is filtered

(3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

This might not take effect until the next time you exit Firefox and start it up again.

Does that help?

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 23.0 r0
  • 5.1.50901.0

Application

  • Firefox 49.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
  • Support URL: https://support.mozilla.org/1/firefox/49.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firebug 2.0.18 (firebug@software.joehewitt.com)
  • Ghostery 7.0.1.4 (firefox@ghostery.com)
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce GT 525M
  • adapterDeviceID: 0x0116
  • adapterDeviceID2: 0x0df5
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 1024
  • adapterSubsysID: 04c41028
  • adapterSubsysID2: 04c41028
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 11-28-2010
  • driverDate2: 6-17-2015
  • driverVersion: 8.15.10.2253
  • driverVersion2: 10.18.13.5330
  • failures: [u'[GFX1-]: CreateShaderResourceView failed for format87', u'[GFX1-]: CreateShaderResourceView failed for format61']
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'blacklisted', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_FEATURE_FAILURE_DL_BLACKLIST_g984', u'type': u'env'}], u'name': u'DIRECT2D'}, {u'status': u'broken', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'broken', u'message': u"Texture sharing doesn't work", u'type': u'runtime'}], u'name': u'D3D11_HW_ANGLE'}]}
  • indices: [0, 1]
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8794 solutions 71950 answers

Chosen Solution

Some users are having problem with Flash due to an incompatibility with a new feature. You could try turning it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste async and pause while the list is filtered

(3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

This might not take effect until the next time you exit Firefox and start it up again.

Does that help?

Some users are having problem with Flash due to an incompatibility with a new feature. You could try turning it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''async''' and pause while the list is filtered (3) Double-click the '''dom.ipc.plugins.asyncdrawing.enabled''' preference to switch the value from true to false This might not take effect until the next time you exit Firefox and start it up again. Does that help?

Question owner

Thanks jscher2000, that fixed it!

Should I be concerned at all about leaving dom.ipc.plugins.asyncdrawing.enabled set to false permanently?

Thanks jscher2000, that fixed it! Should I be concerned at all about leaving dom.ipc.plugins.asyncdrawing.enabled set to false permanently?
jscher2000
  • Top 10 Contributor
8794 solutions 71950 answers

Well, I don't think any sites depend on it, it's just meant to allow some parts of the media to load more quickly than others rather than all waiting their turn. What you get by turning it off is how it worked in Firefox 48. Hopefully in a couple cycles the bugs will all be worked out.

Well, I don't think any sites depend on it, it's just meant to allow some parts of the media to load more quickly than others rather than all waiting their turn. What you get by turning it off is how it worked in Firefox 48. Hopefully in a couple cycles the bugs will all be worked out.