Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't let me go to Google search or any results (SEC_ERROR_UNKNOWN_ISSUER error with no exception box)

  • 12 replies
  • 3 have this problem
  • 1216 views
  • Last reply by MarkTe

more options

Firefox is blocking Google and all results through Google. I don't have the option to except Google. This started yesterday.

edit: removed your mail address from public display, since the only thing it will attract are spam bots. you will be notified per mail once somebody replies to the thread. (philipp)

Modified by philipp

Chosen solution

thanks. so it appears that a traffic monitoring system used in this educational network environment is intercepting the secure connections by using a certificate that is unknown and therefore untrusted by firefox.

you could try if the following steps can address the issue: enter about:config into the firefox address bar (confirm the info message in case it shows up). right-click somewhere on the page to create a new boolean preference - name it security.enterprise_roots.enabled and set its value to false. then restart firefox.

otherwise if this didn't help either you should get in contact with your it department about how to best resolve that...

Read this answer in context 👍 0

All Replies (12)

more options

hi MarkTe, most likely this will be due to your security software on the affected system - please refer to our article on the subject: How to troubleshoot security error codes on secure websites

more options

That was the first place I went, but it doesn't solve my problem. Using Internet Explorer, I found a message board that is talking about this string after google ?gws_rd=ssl

more options

if the article didn't help then we'd need more information on your individual circumstances like shown on the screenshot: click on advanced on that error page [1], then on the blue error code [2] and finally copy the text to the clipboard [3] and then pasting that here into a reply in the forum.

thank you!

more options

https://www.google.com/?gws_rd=ssl

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: true HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIID5DCCAsygAwIBAgIUTtmno5Ff0Hz7oUwLP+3SbgdI8ygwDQYJKoZIhvcNAQEL BQAwgaMxCzAJBgNVBAYTAlVTMQswCQYDVQQIEwJUWDEQMA4GA1UEBxMHTWlkbGFu ZDEsMCoGA1UEChMjTWlkbGFuZCBJbmRlcGVuZGVudCBTY2hvb2wgRGlzdHJpY3Qx HzAdBgNVBAsTFkluZm9ybWF0aW9uIFRlY2hub2xvZ3kxJjAkBgNVBAMTHUNvbnRl bnRLZWVwZXIgSW50ZXJtZWRpYXRlIENBMB4XDTE2MTAwNjEzMDI0NVoXDTE2MTIy OTEyMjgwMFowaDELMAkGA1UEBhMCVVMxEzARBgNVBAgMCkNhbGlmb3JuaWExFjAU BgNVBAcMDU1vdW50YWluIFZpZXcxEzARBgNVBAoMCkdvb2dsZSBJbmMxFzAVBgNV BAMMDnd3dy5nb29nbGUuY29tMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKC AQEAxEbWjv1BtgFsfRWZQ7bRTT1Tb69p9vT9DshG4ULHuflenWsF99kbPIafelw7 5iyDcUcgdNcNnt6B19z2y6Fexey3OgCUt2OlJQPcGfZHGXW94jLDh6uHf0qIxUT/ Hedj7IqfYOa01xBYjjdw8N/P22jeFgoXNzmz+a+ts/ctEKHI0Nm7k8kMMPsB1JJ7 w6nOCkyoqDVJ9a13BYzt/qlOSHIGYRM9bFnHsAkZZkJ6VtQyVJn+5qagRpcaAO+t otYvzU20DSOsBQ9z2s5D2jq7mbSDiB+DkUdxdgT20puOmmXa4stJnrpeOTakMfuf kN90Dvfc8CrsWTI4xdgTaUi3JwIDAQABo0owSDAZBgNVHREEEjAQgg53d3cuZ29v Z2xlLmNvbTAdBgNVHSUEFjAUBggrBgEFBQcDAQYIKwYBBQUHAwIwDAYDVR0TAQH/ BAIwADANBgkqhkiG9w0BAQsFAAOCAQEAUbiAkkAJzLqu5I3+gwZsA6D8TJ3oUoNv wGJD/K132BNuTZmkwII8ABhr0n2iAm1OZLEo1CPQZ098E9fmNxc/BNpiGkYQ1t1Q QAtwElslj+AJc9pd25dYSOr9PoIjxtZhfgLWDF5+EX3qucsOkfoorjNVLE1yVUhr I2pw3VwicLaL+yapGfd0JMzf9rOGW7CM3spzmhPnj+Wv/ryBRT+LiMhngx8pna8N EZv9JUY/Bh6EEhZ6LqhOhRqEL7V5dq48mUpS7ksjRZ/5OI91azOjH362VeQ7vtcZ CjA/21KyuY34DNJtjvdSlzCXF0qTnVszmVsMFU5PajQNOb0kiuhHzw==


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIFrTCCBJWgAwIBAgIKFYffoQAAAAABoDANBgkqhkiG9w0BAQUFADBUMRMwEQYK CZImiZPyLGQBGRYDb3JnMRowGAYKCZImiZPyLGQBGRYKbWlkbGFuZGlzZDEhMB8G A1UEAxMYbWlkbGFuZGlzZC1BRE0zMDVEQzAyLUNBMB4XDTE2MDkyOTE2MzUyNFoX DTE3MDgyNDIxMTIzMlowgaMxCzAJBgNVBAYTAlVTMQswCQYDVQQIEwJUWDEQMA4G A1UEBxMHTWlkbGFuZDEsMCoGA1UEChMjTWlkbGFuZCBJbmRlcGVuZGVudCBTY2hv b2wgRGlzdHJpY3QxHzAdBgNVBAsTFkluZm9ybWF0aW9uIFRlY2hub2xvZ3kxJjAk BgNVBAMTHUNvbnRlbnRLZWVwZXIgSW50ZXJtZWRpYXRlIENBMIIBIjANBgkqhkiG 9w0BAQEFAAOCAQ8AMIIBCgKCAQEAxEbWjv1BtgFsfRWZQ7bRTT1Tb69p9vT9DshG 4ULHuflenWsF99kbPIafelw75iyDcUcgdNcNnt6B19z2y6Fexey3OgCUt2OlJQPc GfZHGXW94jLDh6uHf0qIxUT/Hedj7IqfYOa01xBYjjdw8N/P22jeFgoXNzmz+a+t s/ctEKHI0Nm7k8kMMPsB1JJ7w6nOCkyoqDVJ9a13BYzt/qlOSHIGYRM9bFnHsAkZ ZkJ6VtQyVJn+5qagRpcaAO+totYvzU20DSOsBQ9z2s5D2jq7mbSDiB+DkUdxdgT2 0puOmmXa4stJnrpeOTakMfufkN90Dvfc8CrsWTI4xdgTaUi3JwIDAQABo4ICLzCC AiswHQYDVR0OBBYEFP6mIg5QMI3wK1zKlflLldRA8HFvMA8GA1UdEwEB/wQFMAMB Af8wDgYDVR0PAQH/BAQDAgGGMB8GA1UdIwQYMBaAFNOjF8LuXxjBaKjSQj0YELJr 9OgyMIHcBgNVHR8EgdQwgdEwgc6ggcuggciGgcVsZGFwOi8vL0NOPW1pZGxhbmRp c2QtQURNMzA1REMwMi1DQSxDTj1hZG0zMDVkYzAyLENOPUNEUCxDTj1QdWJsaWMl MjBLZXklMjBTZXJ2aWNlcyxDTj1TZXJ2aWNlcyxDTj1Db25maWd1cmF0aW9uLERD PW1pZGxhbmRpc2QsREM9b3JnP2NlcnRpZmljYXRlUmV2b2NhdGlvbkxpc3Q/YmFz ZT9vYmplY3RDbGFzcz1jUkxEaXN0cmlidXRpb25Qb2ludDCBzQYIKwYBBQUHAQEE gcAwgb0wgboGCCsGAQUFBzAChoGtbGRhcDovLy9DTj1taWRsYW5kaXNkLUFETTMw NURDMDItQ0EsQ049QUlBLENOPVB1YmxpYyUyMEtleSUyMFNlcnZpY2VzLENOPVNl cnZpY2VzLENOPUNvbmZpZ3VyYXRpb24sREM9bWlkbGFuZGlzZCxEQz1vcmc/Y0FD ZXJ0aWZpY2F0ZT9iYXNlP29iamVjdENsYXNzPWNlcnRpZmljYXRpb25BdXRob3Jp dHkwGQYJKwYBBAGCNxQCBAweCgBTAHUAYgBDAEEwDQYJKoZIhvcNAQEFBQADggEB ADeP42l9wNvLaTcGLN6bNezGhYeAePHThLIHzbigxwzajSj58OsXQMeql9hMM72R lSTYujdsKIvrHVySlz61XYAgBD3c5Y9kbpkm0y42P0ulKAcdm/TOuQDMoxgQWlX8 jLTidKz88QV8+bVR3Z+RQXl7lIZsRyHSfqktsfJqO621NP4mrIGu4ew/EPZw9oF1 9YokEQ5avHvBYX9IOTO3usQKP/20T+TLZosQ9mVnUu6qZhtGHMg0MoaCNkepOZoe nVSsVwG9dXh2YKMUuugeeslrlvayVNDwUxzqIAGvb6+ehb0pyJtRzZm4jFGkRSS1 KinfxClq2OpgvyX4EFChq/E=


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIDmzCCAoOgAwIBAgIQd5/a443UYq9BTWW+vK/C2zANBgkqhkiG9w0BAQUFADBU MRMwEQYKCZImiZPyLGQBGRYDb3JnMRowGAYKCZImiZPyLGQBGRYKbWlkbGFuZGlz ZDEhMB8GA1UEAxMYbWlkbGFuZGlzZC1BRE0zMDVEQzAyLUNBMB4XDTEyMDgyNDIx MDIzM1oXDTE3MDgyNDIxMTIzMlowVDETMBEGCgmSJomT8ixkARkWA29yZzEaMBgG CgmSJomT8ixkARkWCm1pZGxhbmRpc2QxITAfBgNVBAMTGG1pZGxhbmRpc2QtQURN MzA1REMwMi1DQTCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEBANEppXWw iYQW0aWnHYeANXCyBOeVfpFCrV77cW+LwrNNQH+ajBceX1f7/5ppU+EcNlk8hjuG 35N5a/m7SeTceHQMHR0GAS6azB5ARh1WBImsl4pWf0dUBDkSaSWiUmOlnqGoXy9U QVYq+Qy7KnW+sy3h/eaxNjFVU/mxeO4xuo6DMwp2D09S1jc2jR0pPfdbSBOVqlmm bf5dPmtMtzgyMcOWbrrqIaZnsVN/+xNPYV7xgCJFhVHrhiBuVFWFwa9hqyWOxxGM cXUecQr/P4ywCn2qf/8kJPE4+vH9t9BqsUyinFP9T9+J5dxiHkxxreK2Caeh2M+p hc7+m+LgKN2i4PcCAwEAAaNpMGcwEwYJKwYBBAGCNxQCBAYeBABDAEEwDgYDVR0P AQH/BAQDAgGGMA8GA1UdEwEB/wQFMAMBAf8wHQYDVR0OBBYEFNOjF8LuXxjBaKjS Qj0YELJr9OgyMBAGCSsGAQQBgjcVAQQDAgEAMA0GCSqGSIb3DQEBBQUAA4IBAQDP ATVNJ48Y1KH9PIHoPiLFQoWqRgI6R9aq2k+c0i+JOU9e4Gk1AVSLL6bBY78+Tfeq LoXuhfURj09J1WuAtiS5fV/CZsFAIlnYyT/L+J3Ae1R8U2VioJV/ZMnog/Ee2xn+ Q/dxo6mvqKKO0rgWwto+oIdhInMI+ykM7zuQcCPa/FiJRIBvWPeTciOS4tPC9ynB FZVnhNQcqqI83GLi+FZwQj7EUdCJuOEzLenep/5oVAMSaHPRLhMYQ04fj+2T/RGU EWsqMKODJ2pS5lDKW5t+WcS/RojrIAF6cTvW2ba/zs0AGtZkqvXiSx+GLm5kKpfd cLt6PGeUAPNNi0tbrmtB


END CERTIFICATE-----
more options

I did try to change my homepage back to https://www.google.com but the extra string still comes up

more options

Chosen Solution

thanks. so it appears that a traffic monitoring system used in this educational network environment is intercepting the secure connections by using a certificate that is unknown and therefore untrusted by firefox.

you could try if the following steps can address the issue: enter about:config into the firefox address bar (confirm the info message in case it shows up). right-click somewhere on the page to create a new boolean preference - name it security.enterprise_roots.enabled and set its value to false. then restart firefox.

otherwise if this didn't help either you should get in contact with your it department about how to best resolve that...

more options

I'll try that with our district's IT dept. then. I figured it was a Firefox issue since Internet Explorer works and all goes through the same district network. Thanks.

more options

that boolean string worked! Thank you.

more options

thanks for the feedback - that string basically makes firefox look in the system's/IE's trust store for the missing certificate to authenticate the connection...

more options

If you don't mind, I'd like to ask one more question since you seemed to know. Is there an advantage to using the https://encrypted.google.com address over the typical google.

more options

i had to look that up myself. it appears that using https://encrypted.google.com would have slight privacy benefits if you clicked on google ads next to the search results (as your search terms wouldn't be transmitted to advertisers over http): https://www.eff.org/deeplinks/2011/10/google-encrypts-more-searches

overall that is a pretty small difference though and if you don't click on ads anyway i'd say you're just as well off with the regular https://www.google.com site...

more options

Thank you.