X
Tap here to go to the mobile version of the site.

Support Forum

Improved performance without hardware acceleration? My firefox became slow.

Posted

With latest update my firefox became slow. It is now taking time to show my already loaded tabs. It is now like chrome. It is now showing something rotating each and everytime i clicked my already opened tabs. I don't want firefox to become chrome. Somebody make a fix for this.

With latest update my firefox became slow. It is now taking time to show my already loaded tabs. It is now like chrome. It is now showing something rotating each and everytime i clicked my already opened tabs. I don't want firefox to become chrome. Somebody make a fix for this.
Attached screenshots

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Google Update
  • Shockwave Flash 23.0 r0
  • VLC media player Web Plugin 2.0.0-rc

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59423 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? -------------- '''https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster''' '''https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix''' '''https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding'''

Question owner

I must say nope.. Then the problem is due to extensions?

I must say nope.. Then the problem is due to extensions?
raghuariga 0 solutions 2 answers

Hi The Invincible

Can you give more info about the version of OS, Computer Hardware and version of browser you are using.

Mostly the slowness of browser tabs relate to the Add ons in the browser, the applications running at that time. Issues related to internet page loading may be problem some time.

Please provide more info.

Hi The Invincible Can you give more info about the version of OS, Computer Hardware and version of browser you are using. Mostly the slowness of browser tabs relate to the Add ons in the browser, the applications running at that time. Issues related to internet page loading may be problem some time. Please provide more info.
FredMcD
  • Top 10 Contributor
4248 solutions 59423 answers

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.