Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

If I use Private Browsing Mode, all is well except I can't save passwords, but when I turn it off and browse "normally" browsing is impractical.

  • 6 replies
  • 1 has this problem
  • 8 views
  • Last reply by KnightLord

more options

This has been an ongoing problem with Firefox for a long time. A month or so back I set Private Browsing Mode under Privacy and browsing was like it used to be, fun. However this mode won't allow for password saving, or changing. I changed back to normal browsing mode and it took almost 10 minutes to get to the site I was trying to log onto, and when I got there for some reason FF wouldn't/couldn't recognize the Log In link {which it does recognize in Private Browsing Mode}. I can't say I blame those who have switched to Chrome or other browsers. Loyalty only goes so far people, and I'm getting close to empty.

Chosen solution

Hi KnightLord, could you also try disabling or removing the MediaPlayer 3.3.2 extension? I don't know whether it has any ill effects on Linux systems, but is considered somewhat "malware-ish" on other platforms.

You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find that suspicious extension on the right side and remove (or, if in doubt, disable).

Often a link will appear above at least one disabled/removed extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Read this answer in context 👍 0

All Replies (6)

more options

Known feature of Private Browsing mode; not saving new Passwords. https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history#w_what-does-private-browsing-not-save

* Passwords: No new passwords will be saved.

more options

Let me rephrase FireFox's problem. In normal browsing mode it reports problems with scripts, greys out, locks up, and crashes. This/these problem(s) don't bother me at all in Private browsing mode, but the problem there is I can't save passwords.

There. Clear as mud?

more options

Now, if this indicates to Mozilla/FireFox what, or where, the problem may be, and if there's a fix for it, Wonderful. If not then I need to follow others who have switched to Chrome. I'm not the only one that's had this problem {from what I've read} and others have simply switched to Chrome, or switched to Private Browsing Mode to bypass the problem.

more options

Hi KnightLord, Private Browsing automatically activates Tracking Protection. While that may occasionally break some sites features, it also does streamline what Firefox loads. Why not try using the Tracking Protection feature in regular mode and see whether it gives you the same benefits there?

First, this article explains the feature and how to make exceptions when needed: What happened to Tracking Protection?.

Second, here's how you can turn it on in regular windows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste track and pause while the list is filtered

(3) Double-click the privacy.trackingprotection.enabled preference to switch the value from false to true

Note: Firefox uses a list from Disconnect, maker of the Disconnect extension, but doesn't provide the full control offered by that extension. If you find this is mostly good but you want more control, try turning off the built-in feature (switch the above back to false) and install Disconnect from the Add-ons site.

more options

Chosen Solution

Hi KnightLord, could you also try disabling or removing the MediaPlayer 3.3.2 extension? I don't know whether it has any ill effects on Linux systems, but is considered somewhat "malware-ish" on other platforms.

You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find that suspicious extension on the right side and remove (or, if in doubt, disable).

Often a link will appear above at least one disabled/removed extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

more options

jscher2000, I did everything you suggested {most I'd already done}. I have the feeling that the MediaPlayer 3.3.2 may have been the culprit. Thanks tons. I'll be back if I have any more issues, but I hope that won't be necessary.