Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

marketwatch.com overview page of stock chart doesn't show selected time frame after recent upgrade

  • 12 replies
  • 1 has this problem
  • 68 views
  • Last reply by jscher2000

more options

Unable to view stock chart for 5 day, 3mo, 6mo etc. selected time frame. Default is 1 day with other time frame offerings, to be selected. These views were available in the past and are available with other browsers. After last upgrade the selections are no longer responsive. What setting needs to be addressed. I can't seem to wake this up.

Chosen solution

Thanks for the example. Do you use any ad blockers or tracking blockers? I can't get the date links to work if I block a script from dianomi (an ad service).

Speaking of tracking blockers, if you are using a private window and see a "shield" icon at the left end of the address bar, check out this article: What happened to Tracking Protection?.

Read this answer in context 👍 1

All Replies (12)

more options

This one worked for me: http://www.marketwatch.com/investing/index/djia -- occasionally it stalled but clicking a different one and clicking back displayed the data that had been displayed.

Did you try the general things?

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

Then reload the chart page and try again.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?


If that doesn't help, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Thanks jscher2000! I don't think you received my first "thank you", at any rate your link performs as it should and the time frame selection buttons work while in safe mode. I'm trying to figure out which add ons would cause selection to be inactive. I do not use many optional tools, if you have any suggestions please share! Thanks again

more options

There are too many extensions in the world for me to guess. Do you want to post a list for discussion? The easiest way is to copy/paste the list from the troubleshooting information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

Then scroll down to Extensions and just below that heading, select and copy the table, then paste that into a reply. It will look a bit messy, but we're used to it.

more options

Not much to work with; only have widevine, primetime decryption and Cisco video codec enabled plug ins; a few others with the "always ask" option checked.

more options

Hi feeneyfox, Safe Mode actually doesn't disable plugins, it only disables extensions. What about the extensions?

more options

The only extension is Avast online security; I've turned it on / off without any changes. I think I might try to "refresh" firefox...

more options

The only extension is Avast online security; I've turned it on / off without any changes.

more options

If the DJIA page works normally in regular mode (without having to go into Safe Mode), do you want to post a link to a page on the site that does NOT work normally in regular mode? Maybe there's some notable difference.

more options

Great idea! Here's the link; I got there from the homepage search option. http://www.marketwatch.com/investing/Index/DJIA

once there I typed in csco and ended up here

http://www.marketwatch.com/investing/Stock/CSCO?countrycode=US

where the time frame options are unresponsive

Perplexing

more options

Chosen Solution

Thanks for the example. Do you use any ad blockers or tracking blockers? I can't get the date links to work if I block a script from dianomi (an ad service).

Speaking of tracking blockers, if you are using a private window and see a "shield" icon at the left end of the address bar, check out this article: What happened to Tracking Protection?.

more options

You nailed it! Disabling the block on the marketwatch chart site activated the time frame selection buttons. What's odd is I always use tracking protection and haven't had this problem in the past. I wonder if there was a bit of change in the last upgrade that caused this sensitivity?

You are indeed one of the top 10 contributors! Thanks for the education.

more options

Glad to hear that helped. Yes, some sites are now wiring their functionality to tracking and ad services to encourage (coerce?) users to allow tracking and show their ads.