X
Tap here to go to the mobile version of the site.

Support Forum

Firefox ran an update and now my vidoes won't play

Posted

Hello - I have to take a training course for my job via pre-recorded sessions. All worked well until Firefox ran an update last night, now the video portion of the display won't work. I can hear the audio but the picture portion is now blank. Does Firefox have a solution for this?

Hello - I have to take a training course for my job via pre-recorded sessions. All worked well until Firefox ran an update last night, now the video portion of the display won't work. I can hear the audio but the picture portion is now blank. Does Firefox have a solution for this?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • Citrix Online App Detector Plugin
  • McAfee MSC FF plugin DLL
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Shockwave Flash 23.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

Wesley Branton
  • Top 10 Contributor
590 solutions 4999 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Question owner

Thanks Wesley for your response. Unfortunately, this did not solve the issue. I restarted the laptop and firefox and I am still able to view the video.

Thanks Wesley for your response. Unfortunately, this did not solve the issue. I restarted the laptop and firefox and I am still able to view the video.
Wesley Branton
  • Top 10 Contributor
590 solutions 4999 answers

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

I tried running it in safe mode and the problem still exists. I have narrowed down the issue further. It appears area within the video that has both pictures and writings will display but those with only pictures does not display. URGH I need to get this training completed.

I tried running it in safe mode and the problem still exists. I have narrowed down the issue further. It appears area within the video that has both pictures and writings will display but those with only pictures does not display. URGH I need to get this training completed.
Wesley Branton
  • Top 10 Contributor
590 solutions 4999 answers

Do you know what type of video player (ex. Flash Player, HTML5, etc.) the website is attempting to use?

Also, are you able to view the video in Internet Explorer? Do not test in Google Chrome because it has some builtin plugins that override Firefox's plugins.

Do you know what type of video player (ex. Flash Player, HTML5, etc.) the website is attempting to use? Also, are you able to view the video in Internet Explorer? Do not test in Google Chrome because it has some builtin plugins that override Firefox's plugins.

Question owner

It is hard for me to tell. When I launch it, the top of the video it says skillsoft course player - Mozilla Firefox and tablet player - Mozilla FireFox. It does work with Internet Explorer with no issues.

It is hard for me to tell. When I launch it, the top of the video it says skillsoft course player - Mozilla Firefox and tablet player - Mozilla FireFox. It does work with Internet Explorer with no issues.
Wesley Branton
  • Top 10 Contributor
590 solutions 4999 answers

I looks like this service may be using Java. Mozilla implemented a block on Java for security purposes. According to your system details, Java is not installed on Firefox, so you will need to install it.

Further information can be found in these Mozilla support articles:

You can also refer to the Skillsoft Customer Support page regarding Firefox usage.

I looks like this service may be using Java. Mozilla implemented a block on Java for security purposes. According to your system details, Java is not installed on Firefox, so you will need to install it. Further information can be found in these Mozilla support articles: *[[Use the Java plugin to view interactive content on websites]] *[[How to allow Java on trusted sites]] You can also refer to the [http://support.skillsoft.com/customer/spjava/firefox.htm Skillsoft Customer Support page regarding Firefox usage].

Question owner

I used all the steps provided and it still doesn't display the pictures. I am extremely frustrated and disappoint. It looks like I will need to revert to using Internet Explorer.

I used all the steps provided and it still doesn't display the pictures. I am extremely frustrated and disappoint. It looks like I will need to revert to using Internet Explorer.
Wesley Branton
  • Top 10 Contributor
590 solutions 4999 answers

Very sorry about that. Perhaps the best solution would be to do the training in Internet Explorer, especially if your training is urgent.

Very sorry about that. Perhaps the best solution would be to do the training in Internet Explorer, especially if your training is urgent.