Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

We have turned pop up blocker off and when clicking on a button from our web site it displays a pop up that the browser is blocking the pop up.

  • 3 replies
  • 1 has this problem
  • 5 views
  • Last reply by jscher2000

more options

We have turned pop up blocker off and also tried adding the website to exceptions list but still getting a pop up message that states the browser is blocking the pop up. I have updated JAVA to latest version and checked the extenstions/add-ons to confirm there is nothing there that would also be blocking pop ups and found nothing. I am not sure what to try next.

All Replies (3)

more options

This is the message.

more options

As to the pop-up blocking, there are add-ons and also Firefox settings.

Type about:preferences#content<enter> in the address bar Under Content turn on Block pop-up windows. To its right, press Exceptions. List any sites that you do not want pop-ups to be blocked.

more options

I wonder how your page determines whether Firefox is allowing popup windows. Perhaps there is a problem in the script, for example, some other feature is blocking the window.open() and the script assumes it is caused by the popup blocker (but can't really tell).

Also, to check the effective permission on the current site, you can use the Permissions panel of the Page Info dialog. While viewing the page, call up the dialog using any of these:

  • right-click (on Mac: Ctrl+click) a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Open Pop-up Windows" and if the "Use default" box is checked, a gray dot will show whether the site is currently allowed or blocked from showing popup windows. (See attached screenshot.)

Note: if you edit the permission here, it should be saved immediately, there's no Save button for this panel.