Search Support

I recently downloaded something for my android tablet and now there is always a link from google play under the Mozilla search bar, how do i get rid of it?

  • 3 replies
  • 1 has this problem
  • 4 views
  • Last reply by Annoyed1

more options

I did the download from my android tablet via wifi from my PC. The link for google play appears under the search bar when I run Firefox on my PC.

Chosen solution

Another user mentioned this is on the built-in home page. Is it what appears in the attached screenshot? Try hovering over the corner of the box to find an "x" button to close that. Then you should return to the routine messages that rotate into the page. Does that work?

Read this answer in context 👍 0

All Replies (3)

more options

What was under the search bar before this happened? For example, you may have been displaying your Bookmarks Toolbar below the main navigation toolbar (the one with the address bar and the search bar), or maybe you had a different add-on toolbar there, or maybe it was the page you were viewing.

If the unwanted link is a bookmark, you should be able to remove it by right-clicking it and choosing Delete.

If the unwanted link is a button on a different toolbar, Delete won't appear on the right-click context menu, but instead maybe "Remove from Toolbar". In that case, you could try that but it would be better to try to track down what add-on injected that button onto your toolbar (or created the toolbar). You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Was there anything that looked Play-related there?

more options

Chosen Solution

Another user mentioned this is on the built-in home page. Is it what appears in the attached screenshot? Try hovering over the corner of the box to find an "x" button to close that. Then you should return to the routine messages that rotate into the page. Does that work?

more options

Thanks for your fast response. Yes it was the link as per your screenshot, however no amount of clicking on the "X" would make it go away. However, I had reason to turn on my tablet after asking my question - I went into settings and found a couple of Google Play apps that weren't there before I downloaded the one I had wanted, I uninstalled them quite easily then when I came back to my PC and started up Firefox again the annoying link had GONE.