Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

an embeded video appears in explorer, and safari but has dissapeared in Firefox.

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by jscher2000

more options

The video has always appeared on my website until today and only when using Firefox. I haven't made any changes in my Firefox options.

Chosen solution

Could you check whether Firefox's Tracking Protection feature is blocking it? In that case, a "shield" icon would appear toward the left end of the address bar. This article has more information on this feature: What happened to Tracking Protection?.

If that's not the issue, did you try "the usual":

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Could you check whether Firefox's Tracking Protection feature is blocking it? In that case, a "shield" icon would appear toward the left end of the address bar. This article has more information on this feature: What happened to Tracking Protection?.

If that's not the issue, did you try "the usual":

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

more options

Hmm, I noticed in your plugins list (next to your question: Question Details > More System Details) that your Flash plugin is very old, so perhaps Firefox now requires you to manually enable it on your site??

Any reason you have Flash 20 instead of Flash 23? To update Flash, you can download a new installer from Adobe here:

https://get.adobe.com/flashplayer/

Make sure to uncheck any unwanted extras offered on that page before downloading.