Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Screen not repainting while switching between tabs on Mac

  • 5 replies
  • 2 have this problem
  • 6 views
  • Last reply by FredMcD

more options

Firefox v48.0.1 OS X yosemite

In the last 2-3 weeks I am noticing that the browser screen isnt repainting when switching between tabs. Typically the browser screen will be frozen on the content of the last tab opened. To see content of the other tabs the last tab needs to be closed. This is pretty making Firefox unusable.

Modified by jsvish

Chosen solution

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Read this answer in context 👍 2

All Replies (5)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Hi FredMcD,

You are on to something!! Issue wasn't seen with firefox in safe mode. What is your recommendation to address the issue with regular start of the browser? Thank you.

more options

Chosen Solution

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

Some "out of date" add-ons were the culprits.... once I updated them screen repainting is as expected when switching tabs.

The 3 add-ons that need to be updated were ColorfulTabs TileTabs YahooToolbar

Thank you for the steps FredMcD!

more options

Glad to help. Safe Surfing.

The settings in the Add-ons Manager can be set to auto check for updates.