Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't view instagram pictures or videos embedded on websites

  • 8 replies
  • 1 has this problem
  • 53 views
  • Last reply by cor-el

more options

I have tried everything to try to figure out the issue. The articles work just fine on chrome, but not on firefox. I have tried running firefox in safemode, still doesn't work. I tried clearing out the cache, the cookies, still nothing. What is going on! It's so annoying to go back and forth between chrome or internet edge to view an article.

All Replies (8)

more options

Sorry you are having problems.

Not sure if this is something that is new or whether it affects many people. You do seem to have tried the obvious fixes, and thanks also for providing your troubleshooting information when you posted the question.

Please remember we can not see what you see, and may not have that problem ourselves, but need more information to try to check this out.

Are you able to give a couple of examples on different sites please with a suitable link. Preferably on sites that are public and not requiring registration.

Please also give a screenshot of what it looks like in Chrome and what it looks like in Firefox.

more options

For prime example: take this article https://www.buzzfeed.com/caitlinjinks/what-is-happening?utm_term=.xvxPxaMQN#.flWaj5PLQ

I am attaching the images, capture 1 is what I am supposed to see (via chrome). capture 2 is what I see on firefox. It just doesn't load for whatever reason. This just started happening too.

more options

Thanks. I have checked that page and can see it somewhat similar to as you see it on Google. It does not seem to be protected content but it does need javascript that you could be blocking. Does it work for you in Firefox's safe mode ? Do you have script blockers or ad blockers that could be preventing you seeing this.

What happens if you try looking at the Instagram site does the video clip play ok for you over there ?

more options

When I go to the actual Instagram, it works fine. It actually shows up. I viewed the page in safemode, and it didn't load. That is why I am really confused why it's not working embedded, but the website it works perfectly.

more options

jcd88 said

When I go to the actual Instagram, it works fine. It actually shows up. I viewed the page in safemode, and it didn't load. That is why I am really confused why it's not working embedded, but the website it works perfectly.

oh! I would like to add that I disabled all the plug ins and it still did not work. So I am at a bit of a loss.

more options

I note from your attached image that the centre of the frame has an icon and says loading, but does not even show the image, nevermind the video clip's start button.

Try clearing the cookies for the buzfeed and instagram sites

Are you seeing any error messages at all ? What security related software do you use ? Company names, software title & Version numbers. Have you been needing to set security exceptions for some sites ? if so you may have security software fighting with Firefox, that may result in parts of webpages not displaying properly.

more options

I can get the result in your second screenshot if block I scripts from either Buzzfeed or from Instagram (both need to be enabled for the Instagram frame to load). However, it's difficult to block scripts selectively without a Firefox add-on, and you obviously would know if scripts were blocked globally.

Do you use Avast's WebShield feature to filter your Firefox browsing? If all else fails, you might try testing with WebShield disabled to see whether that makes any difference. Steps should be in the Avast section of this article: How to troubleshoot security error codes on secure websites.


When I check the Network Monitor, the script files retrieved from the Akamai CDN for Instagram are marked as "weak security" retrievals. (See attached screenshot.) This is because the signing certificate was secured with SHA-1, an algorithm no longer believed to provide good security. Soon it will stop working altogether, but it should still be working fine for now.

If you try the same thing, does the Network Monitor show those files were actually retrieved or that they were not retrieved? To open the network monitor in the lower part of the tab on the Buzzfeed page, either:

  • "3-bar" menu button > Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • Ctrl+Shift+k, then click Network along the bar of buttons for the console

The reload the page bypassing the cache (Ctrl+Shift+r). That's going to take a while to load. Does the page try to fetch those files hosted by Akamai? If so, do you get a success (200) code or something else?

See also: https://developer.mozilla.org/docs/To.../Network_Monitor

more options

I also see a problem with the Instagram video. This also happens on the Instagram website If I right-click that blank space then I always see a link selected that seems to overlay the actual video. If I use the Inspector to give that element a rule display:none; or opacity:0 rule then I see the video. This element seems to block the content and isn't transparent.

Some content shows a Content unavailable error message for me.

Modified by cor-el