X
Tap here to go to the mobile version of the site.

Support Forum

Can't view instagram pictures or videos embedded on websites

Posted

I have tried everything to try to figure out the issue. The articles work just fine on chrome, but not on firefox. I have tried running firefox in safemode, still doesn't work. I tried clearing out the cache, the cookies, still nothing. What is going on! It's so annoying to go back and forth between chrome or internet edge to view an article.

I have tried everything to try to figure out the issue. The articles work just fine on chrome, but not on firefox. I have tried running firefox in safemode, still doesn't work. I tried clearing out the cache, the cookies, still nothing. What is going on! It's so annoying to go back and forth between chrome or internet edge to view an article.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.17
  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 23.0 r0
  • 5.1.50709.0

Application

  • Firefox 48.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
  • Support URL: https://support.mozilla.org/1/firefox/48.0.2/WINNT/en-US/

Extensions

  • Clean Links 2.7.1-signed.1-signed ({158d7cb3-7039-4a75-8e0b-3bd0a464edd2})
  • Firefox Hello Beta 1.4.4 (loop@mozilla.org)
  • HTTPS Everywhere 5.2.4 (https-everywhere-eff@eff.org)
  • Lazarus: Form Recovery 2.3.1-signed.1-signed (lazarus@interclue.com)
  • Multi-process staged rollout 1.2 (e10srollout@mozilla.org)
  • New XKit 7.7.3-amo-unlisted (@new-xkit)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Prevent Tab Overflow 7.2 (noverflow@sdrocking.com)
  • Tab Mix Plus 0.5.0.0 ({dc572301-7619-498c-a57d-39143191b318})
  • Tile Tabs 14.3 (tiletabs@DW-dev)
  • Tumblr Savior 0.5.0 (jid1-W5guVoyeUR0uBg@jetpack)
  • uBlock Origin 1.9.6 (uBlock0@raymondhill.net)
  • URL Fixer 4.1.2 ({0fa2149e-bb2c-4ac2-a8d3-479599819475})
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension.15@web2pdf.adobedotcom) (Inactive)
  • Avast Online Security 12.0.88 (wrc@avast.com) (Inactive)
  • Avast SafePrice 10.3.5.39 (sp@avast.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2:
  • adapterDeviceID: 0x0412
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 06121028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 400 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 400 ]
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 10.0.14393.0
  • driverDate: 4-22-2016
  • driverDate2:
  • driverVersion: 20.19.15.4444
  • driverVersion2:
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
John99 971 solutions 13138 answers

Sorry you are having problems.

Not sure if this is something that is new or whether it affects many people. You do seem to have tried the obvious fixes, and thanks also for providing your troubleshooting information when you posted the question.

Please remember we can not see what you see, and may not have that problem ourselves, but need more information to try to check this out.

Are you able to give a couple of examples on different sites please with a suitable link. Preferably on sites that are public and not requiring registration.

Please also give a screenshot of what it looks like in Chrome and what it looks like in Firefox.

Sorry you are having problems. Not sure if this is something that is new or whether it affects many people. You do seem to have tried the obvious fixes, and thanks also for providing your troubleshooting information when you posted the question. Please remember we can not see what you see, and may not have that problem ourselves, but need more information to try to check this out. Are you able to give a couple of examples on different sites please with a suitable link. Preferably on sites that are public and not requiring registration. Please also give a screenshot of what it looks like in Chrome and what it looks like in Firefox.

Question owner

For prime example: take this article https://www.buzzfeed.com/caitlinjinks/what-is-happening?utm_term=.xvxPxaMQN#.flWaj5PLQ

I am attaching the images, capture 1 is what I am supposed to see (via chrome). capture 2 is what I see on firefox. It just doesn't load for whatever reason. This just started happening too.

For prime example: take this article https://www.buzzfeed.com/caitlinjinks/what-is-happening?utm_term=.xvxPxaMQN#.flWaj5PLQ I am attaching the images, capture 1 is what I am supposed to see (via chrome). capture 2 is what I see on firefox. It just doesn't load for whatever reason. This just started happening too.
John99 971 solutions 13138 answers

Thanks. I have checked that page and can see it somewhat similar to as you see it on Google. It does not seem to be protected content but it does need javascript that you could be blocking. Does it work for you in Firefox's safe mode ? Do you have script blockers or ad blockers that could be preventing you seeing this.

What happens if you try looking at the Instagram site does the video clip play ok for you over there ?

Thanks. I have checked that page and can see it somewhat similar to as you see it on Google. It does not seem to be protected content but it does need javascript that you could be blocking. Does it work for you in Firefox's safe mode ? Do you have script blockers or ad blockers that could be preventing you seeing this. * See [[Troubleshoot Firefox issues using Safe Mode]] What happens if you try looking at the Instagram site does the video clip play ok for you over there ? * It is https://www.instagram.com/p/BIdPzsdjEqA/

Question owner

When I go to the actual Instagram, it works fine. It actually shows up. I viewed the page in safemode, and it didn't load. That is why I am really confused why it's not working embedded, but the website it works perfectly.

When I go to the actual Instagram, it works fine. It actually shows up. I viewed the page in safemode, and it didn't load. That is why I am really confused why it's not working embedded, but the website it works perfectly.

Question owner

jcd88 said

When I go to the actual Instagram, it works fine. It actually shows up. I viewed the page in safemode, and it didn't load. That is why I am really confused why it's not working embedded, but the website it works perfectly.

oh! I would like to add that I disabled all the plug ins and it still did not work. So I am at a bit of a loss.

''jcd88 [[#answer-917195|said]]'' <blockquote> When I go to the actual Instagram, it works fine. It actually shows up. I viewed the page in safemode, and it didn't load. That is why I am really confused why it's not working embedded, but the website it works perfectly. </blockquote> oh! I would like to add that I disabled all the plug ins and it still did not work. So I am at a bit of a loss.
John99 971 solutions 13138 answers

I note from your attached image that the centre of the frame has an icon and says loading, but does not even show the image, nevermind the video clip's start button.

Try clearing the cookies for the buzfeed and instagram sites

Are you seeing any error messages at all ? What security related software do you use ? Company names, software title & Version numbers. Have you been needing to set security exceptions for some sites ? if so you may have security software fighting with Firefox, that may result in parts of webpages not displaying properly.

I note from your attached image that the centre of the frame has an icon and says loading, but does not even show the image, nevermind the video clip's start button. Try clearing the cookies for the buzfeed and instagram sites * [[Delete cookies to remove the information websites have stored on your computer#w_delete-cookies-for-a-single-site]]_delete-cookies-for-a-single-site * And override the cache by using Keyboard Shortcut Alt+F5 to reload without cached items. ** See also [[Firefox can't load websites but other browsers can]] Are you seeing any error messages at all ? What security related software do you use ? Company names, software title & Version numbers. Have you been needing to set security exceptions for some sites ? if so you may have security software fighting with Firefox, that may result in parts of webpages not displaying properly.
jscher2000
  • Top 10 Contributor
8758 solutions 71665 answers

I can get the result in your second screenshot if block I scripts from either Buzzfeed or from Instagram (both need to be enabled for the Instagram frame to load). However, it's difficult to block scripts selectively without a Firefox add-on, and you obviously would know if scripts were blocked globally.

Do you use Avast's WebShield feature to filter your Firefox browsing? If all else fails, you might try testing with WebShield disabled to see whether that makes any difference. Steps should be in the Avast section of this article: How to troubleshoot security error codes on secure websites.


When I check the Network Monitor, the script files retrieved from the Akamai CDN for Instagram are marked as "weak security" retrievals. (See attached screenshot.) This is because the signing certificate was secured with SHA-1, an algorithm no longer believed to provide good security. Soon it will stop working altogether, but it should still be working fine for now.

If you try the same thing, does the Network Monitor show those files were actually retrieved or that they were not retrieved? To open the network monitor in the lower part of the tab on the Buzzfeed page, either:

  • "3-bar" menu button > Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • Ctrl+Shift+k, then click Network along the bar of buttons for the console

The reload the page bypassing the cache (Ctrl+Shift+r). That's going to take a while to load. Does the page try to fetch those files hosted by Akamai? If so, do you get a success (200) code or something else?

See also: https://developer.mozilla.org/docs/To.../Network_Monitor

I can get the result in your second screenshot if block I scripts from either Buzzfeed or from Instagram (both need to be enabled for the Instagram frame to load). However, it's difficult to block scripts selectively without a Firefox add-on, and you obviously would know if scripts were blocked globally. Do you use Avast's WebShield feature to filter your Firefox browsing? If all else fails, you might try testing with WebShield disabled to see whether that makes any difference. Steps should be in the Avast section of this article: [[How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites]]. ---- When I check the Network Monitor, the script files retrieved from the Akamai CDN for Instagram are marked as "weak security" retrievals. (See attached screenshot.) This is because the signing certificate was secured with SHA-1, an algorithm no longer believed to provide good security. Soon it will stop working altogether, but it should still be working fine for now. If you try the same thing, does the Network Monitor show those files were actually retrieved or that they were not retrieved? To open the network monitor in the lower part of the tab on the Buzzfeed page, either: * "3-bar" menu button > Developer > Network * (menu bar) Tools > Web Developer > Network * Ctrl+Shift+k, then click Network along the bar of buttons for the console The reload the page bypassing the cache (Ctrl+Shift+r). That's going to take a while to load. Does the page try to fetch those files hosted by Akamai? If so, do you get a success (200) code or something else? See also: [https://developer.mozilla.org/docs/Tools/Network_Monitor]
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158495 answers

I also see a problem with the Instagram video. This also happens on the Instagram website If I right-click that blank space then I always see a link selected that seems to overlay the actual video. If I use the Inspector to give that element a rule display:none; or opacity:0 rule then I see the video. This element seems to block the content and isn't transparent.

Some content shows a Content unavailable error message for me.

I also see a problem with the Instagram video. This also happens on the Instagram website If I right-click that blank space then I always see a link selected that seems to overlay the actual video. If I use the Inspector to give that element a rule display:none; or opacity:0 rule then I see the video. This element seems to block the content and isn't transparent. Some content shows a Content unavailable error message for me.

Modified by cor-el