Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

abvout config does not work

  • 6 replies
  • 6 have this problem
  • 99 views
  • Last reply by jscher2000

more options

I want to stop Firefox asking me about sharing location. I type "about.config" in the address bar & I get "SERVER NOT FOUND"

All Replies (6)

more options

It is about:config with a : colon as you are typing it with a period.

A about url to remember as it lists all for that version is about:about

more options

Thanks! After I have typed "about:config" the instructions say to type "geo.enabled". That gives me another "server not found". What I had to do was scroll down the 1000 mile long list to find "geo.enabled" then click on it to get "false" FYI

more options

Hi misspiggy, after you open the about:config page, you should see a search bar above the list. That's where you could have typed geo. to filter the list down to the most relevant items. I guess that's just a tip for next time.

Disabling that feature sometimes breaks sites that can't live without it. I think weather.com had that issue earlier this year. If you get to a site that logically needs location information, and it seems broken in a strange way, you could try switching back to true temporarily, and then reload the page, to see whether that helps.

more options

misspiggy said

Thanks! After I have typed "about:config" the instructions say to type "geo.enabled". That gives me another "server not found". What I had to do was scroll down the 1000 mile long list to find "geo.enabled" then click on it to get "false" FYI

Sounds like you typed geo.enabled in the Location (address) bar and not in the Search box on about:config

This may help you on understanding about:config better. https://support.mozilla.org/en-US/kb/about-config-editor-firefox

more options

Thanks again James - Miss Piggy operator error.

I guess my only question would be why would Firefox allow such an annoying irritating feature to exist - surely they must realize (I'm guessing) that 95% of users do NOT want this annoying message popping up every minute - they could at least make it easy to get rid o by putting it in the options menu - easy that is for dummies like moi!! Thanks again guru

more options

Hi misspiggy, there are not very many sites that ask me if I want to share my location, so perhaps we use very different sites.

But it's supposed to be easy. When you get the drop-down, try using the tiny triangle to make a permanent decision to either allow access by the site or to block access by the site.

Alternately, you can use the site permissions panel. This is handy for a variety of things, so here's how it works:

Call up the Permissions panel of the Page Info dialog using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Near the top, you'll find "Access Your Location" and you can uncheck the "Use default" box and select the permission you prefer. In this case Block!

Please see the attached screenshot which shows how the panel and the dialog map to one another.

Note: There no Save button, once you're made that change, you can close the Page Info dialog.

Note #2: If Firefox forgets that the next time you exit Firefox and start it up again, you might have Firefox set to clear history at shutdown, including a category called Site Preferences. Don't clear that category.