Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After following all instructions to change the interface to Russian, it is still in English

  • No replies
  • 1 has this problem
  • 7 views
more options

I downloaded Firefox in Russian. Second time I opened it, it switched to English. I have downloaded and installed Russian language pack. No change. Restarted Firefox and computer. No change. Changed settings under tools... options... content to Russian. No change. Still everything is in English.