Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed Mozilla version 48

  • 3 replies
  • 9 have this problem
  • Last reply by jscher2000

more options

Hello, I am start getting "Secure Connection Failed" on company Citrix sites How I can fix it locally on my Mozilla version 48 or I have downgrade the Mozilla version? I am using Kaspersky Antivirus and those sites are in exception list already. Thank you Mario

All Replies (3)

more options
more options

Those links give me:


When I test the domains using this tool:

They score an "F" for connection security.

Their testbed was not able to connect using Firefox 46 or 47, Chrome 51, Edge, or Internet Explorer 11. Basically, this site is unusable in modern browsers due to how bad its security is.

So the administrator should update these sites ASAP if it is important that users have secure connections and that the site be able to trust those connections. Maybe they don't handle important enough data to worry about that.

Modified by jscher2000

more options

If your company believes you should use these servers despite the risk that no communications are actually private -- due to the combination of TLS 1.0 and RC4 cipher -- Firefox does have a mechanism to allow the specific servers:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste TLS and pause while the list is filtered

(3) Select (for example, triple-click) and copy the following line:,

(4) Double-click the security.tls.insecure_fallback_hosts preference and:

(A) If the preference currently has some value, add a comma to the end and then paste the additional text and click OK

(B) If the preference does not have any value, paste and click OK

To test, reload the insecure pages using Ctrl+Shift+r to bypass the cache.

Added a screenshot

Modified by jscher2000