Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The requested URL not found

  • 7 replies
  • 1 has this problem
  • 129 views
  • Last reply by John99

more options

URL: http://expertsources.choosecaversham.co.uk/ Browser / Version: Firefox 48.0 Operating System: Windows 7

Hi, When there has been some sort of domain related problems that have subsequently been fixed, Firefox continues to display an error page when in fact the domain is fully operational and other browsers such as Google Chrome will display the correct website pages. An example of this is http://expertsources.choosecaversham.co.uk/ where we are setting up a new website for a customer and where we had a problem with the domain configuration. Due to the domain configuration error we were getting returned the URL http://expertsources.choosecaversham.co.uk/home/expertsourcesco/public_html/http(?s)://www.expertsources.co.uk/home/expertsourcesco/public_html/http( With the message on the page: Not Found The requested URL /home/expertsourcesco/public_html/http( was not found on this server.

and after the domain error being fixed and Google Chrome and other web browsers displaying the correct website page, Firefox continues to display the error URL and the error message above, even after refresh, F5 and Ctrl F5, and closing Firefox, waiting for it to completely close by watching Task Manager, and bringing Firefox up again. I consulted my server guys about this and they say I should reboot my machine however this should not be necessary and besides in a working day it is very disruptive. I am also concerned about all those other Firefox users out there who may have gone to a website when there has been a problem with the domain and then being unable to get to the website until they reboot their machine, many of whom would be our customers because we recommend they use Firefox, particularly when they use our backend website content editor for their websites.

I am using Windows 7, Firefox 48.0, and internet connection through Virgin Media in the UK. This problem I have had for a couple of years at least and I believe I have submitted feedback to Firefox on more than one occasion before. You are welcome to contact me about this. Regards, Ken Good www.edgeimpact.co.uk I posted the above on https://webcompat.com/issues/2958 however "karlcow" responded, saying it is working for him - obviously it is because this problem only occurs AFTER someone has gone to the site WHEN there is a domain type problem on it - as I had said. Nobody seems to understand what the problem is and fobs it off as something or other. The point is, Google Chrome works as does Internet Explorer, but Firefox does not in this circumstance. I should not have to expect users, my customers included, to clear cashe whenever they cannot access a website just in case the domain error may have been fixed in the interim. Note this problem still exists after a cold boot of the computer. Please refer this issue to level 3 support who may understand exactly what the issue is here because we have had the problem for a couple of years now and I have taken great lengths to notify Firefox on more than one occasion. Thank you in anticipation. Ken Good

All Replies (7)

more options

Hi   Ken,
I am absolutely not an expert  (far from it   !),   but I did a command prompt:   ipgconfig/flushdns
And then waited over an hour.
It seemed to have done the trick for me   (I'm hoping for confirmation;  cause there is of course a chance that it was a mere coincidence or just a fluke).
Good luck   !
Happy112.

(edit added: And then waited over an hour).

Modified by Happy112

more options

Hi Ken, Firefox stores DNS resolution information only for a brief time, so that should not cause a persistent problem. Also, the error page often has a "Try Again" button to encourage the user to check the current status. Users do report that sometimes you need to bypass the web cache (e.g., Ctrl+Shift+r). I'm not sure why that sometimes would be needed.

To test whether the web cache is the problem, open a new private window and test there. Private windows use a separate cache from regular windows (non-persistent).

Sometimes a "quick fix" is the "Forget about this site" feature. However, since this removes even bookmarks for the site, and since it is a little bit too easy to make an error and forget about other sites, I wouldn't post a general suggestion to your users about that. Reserve it for one-on-one support if it proves useful.

This problem I have had for a couple of years at least and I believe I have submitted feedback to Firefox on more than one occasion before. ... Please refer this issue to level 3 support who may understand exactly what the issue is here because we have had the problem for a couple of years now and I have taken great lengths to notify Firefox on more than one occasion.

As a support volunteer, I'm not aware of a "level 3 support" department. Do you know that one exists somewhere??

If Firefox's features are not working as expected, please file a new bug:

https://bugzilla.mozilla.org/enter_bug.cgi

As you enter the description, the system will check for duplicates. Sometimes that will lead you to an existing discussion where you can vote for the bug to get fixed or contribute technical insights. "Me too" comments are generally not helpful, however.

One challenge in my mind is how to create a test case to demonstrate this problem on demand. Maybe there's a way to set up a demo that alternates bad DNS during odd hours and good DNS during even hours??

more options

Thank you jscher2000. Points: 1. "Firefox stores DNS resolution information only for a brief time" - it seems to be storing DNS information indefinitely, which is my problem - including after refresh, F5 and Ctrl F5, and closing Firefox, waiting for it to completely close by watching Task Manager, and bringing Firefox up again - and also even after I have cold booted the computer. 2. I tried "Ctrl+Shift+r" which did not solve the problem. 3. I tried "Forget About this Site" and it worked, however my point is that I should not have to do this - when other mainstream browsers do not have this problem - especially after I have done all of 1. above.

Recommending clients use Firefox and then expecting them to randomly clear their cache to see if a website is up is not acceptable, particularly to inexperienced customers who merely want to see their website up.

The fact that point 3 does work shows that Firefox does not store DNS resolution information only for a brief time - it stores it even after a restart of Firefox and a cold boot of the computer - and this is my problem with Firefox which is not experienced with Google Chrome or Internet Explorer.

I am at a loss as to how to recreate the DNS problem we had.

more options

The copy of the error page I get is below. There is no Try Again button on it.

more options

kengedgeimpact said

The copy of the error page I get is below. There is no Try Again button on it.

I guess I was thinking of the server not found error page, which has a Try Again button. Your server sent a page, so Firefox didn't display its normal internal page.

In reflecting on why Ctrl+Shift+r didn't help, could it be because Firefox cached a 301 (permanent) redirect from another address you entered to the broken URL? There isn't an obvious way to evict a redirect from the cache through a reload bypassing the cache, because you can't load it, so of course you can't reload it. You would need to clear the cache completely or use Forget About This Site to remove that entry before its natural expiration, whenever that might be.

Note that the DNS cache only stores host name and IP addresses, and very briefly, so unless you changed the server to a new IP address and Firefox keeps accessing the old server, this isn't a DNS problem.

more options

kengedgeimpact said

3. I tried "Forget About this Site" and it worked,

Would you be so kind as to tell me how you did that   (I'm an internet novice)  ?
As I told you:   I did the command prompt:   ipgconfig/flusfdns     --     that seemed to have worked.
I'm saying   seemed to have   because I'm still not sure whether it was mere coincidence or just a fluke.
'Glad things worked out though,   for both you and I   !

more options

Please See