X
Tap here to go to the mobile version of the site.

Support Forum

E-mail link in Firefox 47.0.1 menu stopped working on Windows 10

Posted

Clicking the above link in FF47 has normally displayed until not long ago a list of my e-mail clients present on my Win 10 Pro 64-bit PC. In the list, Thunderbird (my default) was highlighted. After confirming it, Thunderbird (v. 42.2) was launched with the intended URL (of the given Web page) in the e-mail body. This was what I wanted. Several days ago, the e-mail link stopped working and it does not do anything any longer although it behaves (in the toolbar) as "live" (not "dead") icon. I am an advanced user but cannot find out or figure out what has happened and how to restore its previous normal functionality. Let me add that I have quite a number of add-ons in FF, some of which I have added recently (they are all related to security). Please, advise what should be done to solve my problem. Thank you for your attention.

Clicking the above link in FF47 has normally displayed until not long ago a list of my e-mail clients present on my Win 10 Pro 64-bit PC. In the list, Thunderbird (my default) was highlighted. After confirming it, Thunderbird (v. 42.2) was launched with the intended URL (of the given Web page) in the e-mail body. This was what I wanted. Several days ago, the e-mail link stopped working and it does not do anything any longer although it behaves (in the toolbar) as "live" (not "dead") icon. I am an advanced user but cannot find out or figure out what has happened and how to restore its previous normal functionality. Let me add that I have quite a number of add-ons in FF, some of which I have added recently (they are all related to security). Please, advise what should be done to solve my problem. Thank you for your attention.

Chosen solution

I wish to proudly inform my both collaborators on the issue (jscher2000 and guigs) that I have just come across the solution found here:

http://kb.mozillazine.org/Changing_the_mail_program_used_in_Firefox

More precisely, the following has worked for me:

"Reset mailto preference: A preference setting may have been modified that is preventing Firefox from opening your mail application. For example, if you installed an extension that changed the the network.protocol-handler.external.mailto preference to false and you later uninstalled the extension, mailto actions won't work in Firefox (see below). You can see if this is the case and resolve the problem by resetting the preference as follows:

   Type about:config in the Firefox address bar and press Enter
   If you see a page with the warning message, This might void your warranty!, click the button labeled "I'll be careful, I promise!", to continue
   Type mailto in the Search: (Filter) box
   In the list of preferences, find network.protocol-handler.external.mailto
   If its value has been modified to false (it will be in bold) right-click on the preference and select Reset. This will change the preference setting to the default "true" value and should resolve the problem."

Recommended to anybody who installed an extension that changed the the network.protocol-handler.external.mailto preference to false. This was my case. Thank you for your cooperation.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Nokia Suite Enabler Plugin
  • NPWLPG
  • Picasa plugin
  • Shockwave Flash 22.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.4.194
  • 5.1.50428.0
  • Soda PDF 8
  • VLC media player Web Plugin
  • Winamp Application Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

jscher2000
  • Top 10 Contributor
8696 solutions 71081 answers

Could you start by resetting your mailto application handler to "Always Ask". This article leads the way to this setting: Change the program used to open email links.


Hopefully that will restore the previous behavior but, if not, it's possible that the file which stores application handler preferences has become corrupted. The file has a somewhat inscrutable XML format so it's often easiest simply to hide it from Firefox and have those settings return to their defaults. Here's how you do that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, click the "Show Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old.

Start Firefox back up again, and Firefox should rebuild the file with default settings. Does Email Link work any better?

Could you start by resetting your mailto application handler to "Always Ask". This article leads the way to this setting: [[Change the program used to open email links]]. ---- Hopefully that will restore the previous behavior but, if not, it's possible that the file which stores application handler preferences has become corrupted. The file has a somewhat inscrutable XML format so it's often easiest simply to hide it from Firefox and have those settings return to their defaults. Here's how you do that: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, click the "Show Folder" / "Show in Finder" / "Open Directory" button. This should launch a new window listing various files and folders. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit (or Firefox > Quit) Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to mimeTypes.old. Start Firefox back up again, and Firefox should rebuild the file with default settings. Does Email Link work any better?

Question owner

Thank you for the detailed steps. I had "Always Ask", so proceeded to your other steps. Renamed mimeTypes.rdf to mimeTypes.old, restarted FF, but the Email Link still does not work. Rebooted my PC, launched FF, and still no improvement. Really, no idea what's going on... Everything else works normally. Since my local time is 00:01, I'm going to bed and will check my e-mail in about 8 hours from now. For your reference, I have attached the screenshot of my FF add-ons.

Thank you for the detailed steps. I had "Always Ask", so proceeded to your other steps. Renamed mimeTypes.rdf to mimeTypes.old, restarted FF, but the Email Link still does not work. Rebooted my PC, launched FF, and still no improvement. Really, no idea what's going on... Everything else works normally. Since my local time is 00:01, I'm going to bed and will check my e-mail in about 8 hours from now. For your reference, I have attached the screenshot of my FF add-ons.
jscher2000
  • Top 10 Contributor
8696 solutions 71081 answers

Thanks for the update, and sorry, but I don't recognize most of those icons...

The easiest way to rule out an extension as the culprit is to test in Firefox's Safe Mode. In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Thanks for the update, and sorry, but I don't recognize most of those icons... The easiest way to rule out an extension as the culprit is to test in Firefox's Safe Mode. In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Question owner

Still the same when Firefox is running in the Safe Mode. How about reinstalling FF? This, however, would "ruin" all the add-ons and most of the "utility" icons. No better idea comes to my mind...

Still the same when Firefox is running in the Safe Mode. How about reinstalling FF? This, however, would "ruin" all the add-ons and most of the "utility" icons. No better idea comes to my mind...
jscher2000
  • Top 10 Contributor
8696 solutions 71081 answers

There are various intermediate steps short of a full rebuild. These include:

(1) Replace only the program files, described in more detail below (2) Try a Refresh, which removes extensions and settings files

For #1:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

It only take a few minutes.

(A) Download a fresh installer for Firefox 47.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) For maximum plugin compatibility, choose the 32-bit version.

(B) Exit out of Firefox (if applicable).

(C) Using Windows Explorer/My Computer, rename the program folder as follows:

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Any improvement?

There are various intermediate steps short of a full rebuild. These include: (1) Replace only the program files, described in more detail below (2) Try a Refresh, which removes extensions and settings files For #1: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. It only take a few minutes. (A) Download a fresh installer for Firefox 47.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) '''For maximum plugin compatibility, choose the 32-bit version.''' (B) Exit out of Firefox (if applicable). (C) Using Windows Explorer/My Computer, rename the program folder as follows: C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins Any improvement?

Question owner

I did the clean reinstall of Firefox and followed precisely all the steps you indicated. To my surprise (and perhaps yours, too) my "new" Firefox behaves as before, i.e., the Email Link does not do anything. Before you suggest a next move, let me know if the old folder can now be deleted. Its size is 91.3 MB (on disk).

Additional info (could be important): as a result of running AdwCleaner on 19.07.2016, the following registry keys were removed: Key Found : HKLM\SOFTWARE\Classes\CLSID\{EE932B49-D5C0-4D19-A3DA-CE0849258DE6} Key Found : HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects\{EE932B49-D5C0-4D19-A3DA-CE0849258DE6} Key Found : HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\{EE932B49-D5C0-4D19-A3DA-CE0849258DE6} Key Found : HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{EE932B49-D5C0-4D19-A3DA-CE0849258DE6}

However, I cannot state whether or not the "old" Firefox malfunctioned before or only after this operation. The removal of the above keys did not affect any of my numerous programs (at least, those that I used afterwards).

One more additional piece of information: I experimented (tested) with two or three mail add-ons for Firefox offered by developers, but finally uninstalled all of them. And again, I cannot state if my actions related to this affected the Email Link.

I did the clean reinstall of Firefox and followed precisely all the steps you indicated. To my surprise (and perhaps yours, too) my "new" Firefox behaves as before, i.e., the Email Link does not do anything. Before you suggest a next move, let me know if the old folder can now be deleted. Its size is 91.3 MB (on disk). Additional info (could be important): as a result of running AdwCleaner on 19.07.2016, the following registry keys were removed: Key Found : HKLM\SOFTWARE\Classes\CLSID\{EE932B49-D5C0-4D19-A3DA-CE0849258DE6} Key Found : HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects\{EE932B49-D5C0-4D19-A3DA-CE0849258DE6} Key Found : HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\{EE932B49-D5C0-4D19-A3DA-CE0849258DE6} Key Found : HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{EE932B49-D5C0-4D19-A3DA-CE0849258DE6} However, I cannot state whether or not the "old" Firefox malfunctioned before or only after this operation. The removal of the above keys did not affect any of my numerous programs (at least, those that I used afterwards). One more additional piece of information: I experimented (tested) with two or three mail add-ons for Firefox offered by developers, but finally uninstalled all of them. And again, I cannot state if my actions related to this affected the Email Link.
jscher2000
  • Top 10 Contributor
8696 solutions 71081 answers

I think that "BHO" was for IE only; Firefox extensions are not listed under those keys.

What if you change the mailto setting to Thunderbird, so that Firefox doesn't prompt you, does that make any difference? (Of course the old way should still work, I have mine set to Always Ask, but I use Windows 7...)

I think that "BHO" was for IE only; Firefox extensions are not listed under those keys. What if you change the mailto setting to Thunderbird, so that Firefox doesn't prompt you, does that make any difference? (Of course the old way should still work, I have mine set to Always Ask, but I use Windows 7...)

Question owner

My "mailto" setting was "Thunderbird", so I have just changed it to "Always Ask", but still no luck. Let me mention an interesting observation: my old laptop with Win XP synchronized its FF with my Win 10 PC - and the Email Link on the Win XP FF ALSO does not work! Amazing and mysterious. This observation is meaningful, I think, and a conclusion can be drawn from it (but what?)... Anyway, I hope that one day after an update to FF my Email Link will return to normalcy. I understand that "clean" reinstall or Refresh is not worth the efforts that would be necessary to install all the add-ons and arrange all the icons... I think that we have to give up and I will classify the case under the category of "unsolved computer mysteries".

My "mailto" setting was "Thunderbird", so I have just changed it to "Always Ask", but still no luck. Let me mention an interesting observation: my old laptop with Win XP synchronized its FF with my Win 10 PC - and the Email Link on the Win XP FF ALSO does not work! Amazing and mysterious. This observation is meaningful, I think, and a conclusion can be drawn from it (but what?)... Anyway, I hope that one day after an update to FF my Email Link will return to normalcy. I understand that "clean" reinstall or Refresh is not worth the efforts that would be necessary to install all the add-ons and arrange all the icons... I think that we have to give up and I will classify the case under the category of "unsolved computer mysteries".
jscher2000
  • Top 10 Contributor
8696 solutions 71081 answers

Hmm, Sync conveys the value of various "preferences" but I don't know of an efficient way to view that subset (in about:config various of the preferences that are bolded and marked as user set are not sync'd). Perhaps someone else will know of a preference that could be the culprit.

Hmm, Sync conveys the value of various "preferences" but I don't know of an efficient way to view that subset (in about:config various of the preferences that are bolded and marked as user set are not sync'd). Perhaps someone else will know of a preference that could be the culprit.

Question owner

Will that "someone else" notice our correspondence and self-involve in the matter or should I start a new topic? If the latter is the case, I give up. Tell me whether I can safely delete the entire folder: C:\Program Files (x86)\OldFirefox

I don't think that keeping it could be useful in the future...

Will that "someone else" notice our correspondence and self-involve in the matter or should I start a new topic? If the latter is the case, I give up. Tell me whether I can safely delete the entire folder: C:\Program Files (x86)\OldFirefox I don't think that keeping it could be useful in the future...
jscher2000
  • Top 10 Contributor
8696 solutions 71081 answers

The only thing in OldFirefox that you might want is the plugin folders I mentioned.

You should not start a new topic on this same issue.

The only thing in OldFirefox that you might want is the plugin folders I mentioned. You should not start a new topic on this same issue.

Question owner

OK and thank you for your efforts. Maybe, someone will notice the matter and take over.

OK and thank you for your efforts. Maybe, someone will notice the matter and take over.
guigs 1072 solutions 11697 answers

Hi Wlodzislaw, As far as I have tested, the mail to: preference is not in the list of preferences. It may be more reliable to copy the file from the Old Firefox profile data that stores that information over to the new profile: mimeTypes.rdf

Hi Wlodzislaw, As far as I have tested, the mail to: preference is not in the list of preferences. It may be more reliable to copy the file from the Old Firefox profile data that stores that information over to the new profile: mimeTypes.rdf

Question owner

Hi guigs, Thanks for your advice, which I have just followed. However, no improvement to my Email Link - it sturdily does nothing.

Hi guigs, Thanks for your advice, which I have just followed. However, no improvement to my Email Link - it sturdily does nothing.
guigs 1072 solutions 11697 answers

Please make sure to restart Firefox after copying and pasting the file into the new profile folder. It has to reload it. (I think forgot that in my previous post)

Please make sure to restart Firefox after copying and pasting the file into the new profile folder. It has to reload it. (I think forgot that in my previous post)

Question owner

I, naturally, did restart Firefox after this operation and did even more - restart my PC. Still no effect on the Email Link. The unsolved mystery continues...

I, naturally, did restart Firefox after this operation and did even more - restart my PC. Still no effect on the Email Link. The unsolved mystery continues...
guigs 1072 solutions 11697 answers

I am not entirely familiar with Lint, however does the default mail program in the operating system affect what is selected?

I am not entirely familiar with Lint, however does the default mail program in the operating system affect what is selected? *[https://support.mozilla.org/en-US/kb/change-program-used-open-email-links#w_setting-your-operating-systems-default-mail-program]

Question owner

I'm completely unfamiliar with Lint (had to Google the term to find out about its meaning). My answer to your question above is "no". Checking this I even selected now "Use Thunderbird (default)" (was: "Always ask"), but this change has no effect on the functionality of the Email Link button - when pressed, it does nothing. The mystery is becoming greater and greater... I wonder if there will be somebody who will be able to diagnose the symptom properly (perhaps by asking me to copy and send the contents of a file or folder on my PC).

I'm completely unfamiliar with Lint (had to Google the term to find out about its meaning). My answer to your question above is "no". Checking this I even selected now "Use Thunderbird (default)" (was: "Always ask"), but this change has no effect on the functionality of the Email Link button - when pressed, it does nothing. The mystery is becoming greater and greater... I wonder if there will be somebody who will be able to diagnose the symptom properly (perhaps by asking me to copy and send the contents of a file or folder on my PC).

Chosen Solution

I wish to proudly inform my both collaborators on the issue (jscher2000 and guigs) that I have just come across the solution found here:

http://kb.mozillazine.org/Changing_the_mail_program_used_in_Firefox

More precisely, the following has worked for me:

"Reset mailto preference: A preference setting may have been modified that is preventing Firefox from opening your mail application. For example, if you installed an extension that changed the the network.protocol-handler.external.mailto preference to false and you later uninstalled the extension, mailto actions won't work in Firefox (see below). You can see if this is the case and resolve the problem by resetting the preference as follows:

   Type about:config in the Firefox address bar and press Enter
   If you see a page with the warning message, This might void your warranty!, click the button labeled "I'll be careful, I promise!", to continue
   Type mailto in the Search: (Filter) box
   In the list of preferences, find network.protocol-handler.external.mailto
   If its value has been modified to false (it will be in bold) right-click on the preference and select Reset. This will change the preference setting to the default "true" value and should resolve the problem."

Recommended to anybody who installed an extension that changed the the network.protocol-handler.external.mailto preference to false. This was my case. Thank you for your cooperation.

I wish to proudly inform my both collaborators on the issue (jscher2000 and guigs) that I have just come across the solution found here: http://kb.mozillazine.org/Changing_the_mail_program_used_in_Firefox More precisely, the following has worked for me: "Reset mailto preference: A preference setting may have been modified that is preventing Firefox from opening your mail application. For example, if you installed an extension that changed the the network.protocol-handler.external.mailto preference to false and you later uninstalled the extension, mailto actions won't work in Firefox (see below). You can see if this is the case and resolve the problem by resetting the preference as follows: Type about:config in the Firefox address bar and press Enter If you see a page with the warning message, This might void your warranty!, click the button labeled "I'll be careful, I promise!", to continue Type mailto in the Search: (Filter) box In the list of preferences, find network.protocol-handler.external.mailto If its value has been modified to false (it will be in bold) right-click on the preference and select Reset. This will change the preference setting to the default "true" value and should resolve the problem." Recommended to anybody who installed an extension that changed the the network.protocol-handler.external.mailto preference to false. This was my case. Thank you for your cooperation.