X
Tap here to go to the mobile version of the site.

Support Forum

I changed search engine to Google. Yet, it does not hold. How to save?

Posted

I Know that Firefox has Yahoo as default search engine. When I follow the instructions to change it to Google (choosing Google from the bar) there is no button to save the change or one that says OK. And so the change does not register. Because when I open up Firefox again, it still shows Yahoo. Some advice I got (one on Youtube) shows an OK button. Yet it does not show up anywhere on my site. So: How to make the search engine "stick?" Please advise. Thanks Frans

I Know that Firefox has Yahoo as default search engine. When I follow the instructions to change it to Google (choosing Google from the bar) there is no button to save the change or one that says OK. And so the change does not register. Because when I open up Firefox again, it still shows Yahoo. Some advice I got (one on Youtube) shows an OK button. Yet it does not show up anywhere on my site. So: How to make the search engine "stick?" Please advise. Thanks Frans

Chosen solution

I suspect this one is causing the problem:

New Tab by Yahoo 1.3.4 true jid1-G80Ec8LLEbK5fQ@jetpack

Could you try disabling it? You can do that on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find that extension on the right side and click its Disable button. If it is not visible on the list, you may need to remove it using Firefox's Safe Mode. I'll give the steps if needed.

Often a link will appear above a disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.11
  • Provides information about the default web browser
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Lync 2010 Meeting Join Plug-in
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 22.0 r0
  • 5.1.41212.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

thangagiri 0 solutions 3 answers

Type about:preferences#search in URL bar in Firefox. In that page you can change default search engine settings.

Type '''''about:preferences#search''''' in URL bar in Firefox. In that page you can change default search engine settings.

Question owner

Thanks, This what I have been doing each time. Select GOOGLE when scrolling down. To see if it works, I then close the Firefox tab. When I open Firefox again, nothing has changed; it still says Yahoo. After making sure that GOOGLE is selected, shouldn't there be a button that says: SAVE or a button that says: OK, to make sure that the change 'holds?'

So, there is no problem in changing the search engine on the site; the problem is that there is no option to save the choice. Frans

Thanks, This what I have been doing each time. Select GOOGLE when scrolling down. To see if it works, I then close the Firefox tab. When I open Firefox again, nothing has changed; it still says Yahoo. After making sure that GOOGLE is selected, shouldn't there be a button that says: SAVE or a button that says: OK, to make sure that the change 'holds?' So, there is no problem in changing the search engine on the site; the problem is that there is no option to save the choice. Frans
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23374 answers

hello, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

hello, could you go to the firefox ''menu ≡ > help ? > troubleshooting information'', copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Could you test before closing Firefox? In other words:

(1) Select Google as your default search engine.

You can either use the Options page as mentioned earlier, or on the search bar, after typing your query and before submitting it, right-click the Google "g" icon and choose Set as Default Search Engine.

(2) Submit a search using either the search bar or the address bar.

Do you get Google or Yahoo?

If you get Google, does it continue working until you exit out of Firefox?

Could you test before closing Firefox? In other words: (1) Select Google as your default search engine. You can either use the Options page as mentioned earlier, or on the search bar, after typing your query and before submitting it, right-click the Google "g" icon and choose Set as Default Search Engine. (2) Submit a search using either the search bar or the address bar. Do you get Google or Yahoo? If you get Google, does it continue working until you exit out of Firefox?

Question owner

So sorry, but it simply does not work. I'm not the most computer literate person. Is the fact that I'm working on a MacBook Air important? For some reason, Firefox has chosen to consider Yahoo its default search engine. And even that its site says that I should be able to change my search engine from Yahoo to Google, and even if I follow all the steps, it does not do the change. Again, all my advisors tell me to hit the OK button, yet no such thing appears anywhere. The SEARCH site lets me scroll to GOOGLE Since there are no options to save it, I thought this would be enough. It is not. I'm considering dropping Firefox altogether and move to Chrome Frans

So sorry, but it simply does not work. I'm not the most computer literate person. Is the fact that I'm working on a MacBook Air important? For some reason, Firefox has chosen to consider Yahoo its default search engine. And even that its site says that I should be able to change my search engine from Yahoo to Google, and even if I follow all the steps, it does not do the change. Again, all my advisors tell me to hit the OK button, yet no such thing appears anywhere. The SEARCH site lets me scroll to GOOGLE Since there are no options to save it, I thought this would be enough. It is not. I'm considering dropping Firefox altogether and move to Chrome Frans
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Hi Frans, it's normally simple and permanent. As shown in my attached screenshot, there's no OK button, Firefox saves your change as soon as you make it.

However, sometimes users get "infected" with add-ons that override the normal behavior. philipp had asked whether you could paste from the Troubleshooting Information page, which includes a list of your extensions. We can look those over to suggest whether you disable or remove any of them.

Hi Frans, it's normally simple and permanent. As shown in my attached screenshot, there's no OK button, Firefox saves your change as soon as you make it. However, sometimes users get "infected" with add-ons that override the normal behavior. philipp had asked whether you could paste from the Troubleshooting Information page, which includes a list of your extensions. We can look those over to suggest whether you disable or remove any of them.

Question owner

I really appreciate your help with a field I understand so little about. I have here included a screenshot of the trouble-shooting page. Frans

I really appreciate your help with a field I understand so little about. I have here included a screenshot of the trouble-shooting page. Frans
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Oh, it didn't get the Extensions list. Could you try using Command+a to select the whole page, then Command+c to copy it, and you can paste it into a reply and edit out the other parts you don't want to share. It will look a little messy, but we're used to it.

Oh, it didn't get the Extensions list. Could you try using Command+a to select the whole page, then Command+c to copy it, and you can paste it into a reply and edit out the other parts you don't want to share. It will look a little messy, but we're used to it.
Happy112 561 solutions 5694 answers

Hallo   Frans,
Ben jij misschien Nederlander   (dat doet je naam tenminste vermoeden)   ?
In dat geval zul je wellicht dezelfde problemen ondervinden als ik,   want zelfs in het nederlands is het computer-jargon moeilijk te volgen.
Deze vrijwilligers hier doen hun uiterste best, hoor, om e.e.a. duidelijk te maken;  mocht het engels een probleem voor je zijn:  laat het ze weten, zodat ze daar met hun antwoord rekening mee kunnen houden.
Geef het nog niet op,   hoor   !!!
Veel sukses en sterkte   !
Groetjes van   Happy112     (wat natuurlijk mijn echte naam niet is)

Hallo &nbsp; Frans,<BR> Ben jij misschien Nederlander &nbsp; (dat doet je naam tenminste vermoeden) &nbsp; ?<BR> In dat geval zul je wellicht dezelfde problemen ondervinden als ik, &nbsp; want zelfs in het nederlands is het computer-jargon moeilijk te volgen.<BR> Deze vrijwilligers hier doen hun uiterste best, hoor, om e.e.a. duidelijk te maken; &nbsp;mocht het engels een probleem voor je zijn:&nbsp; laat het ze weten, zodat ze daar met hun antwoord rekening mee kunnen houden.<BR> Geef het nog niet op, &nbsp; hoor &nbsp; !!!<BR> Veel sukses en sterkte &nbsp; !<BR> Groetjes van &nbsp; Happy112 &nbsp; &nbsp; (wat natuurlijk mijn echte naam niet is)

Question owner

Dear jscher2000:

Good morning.

Below is the copy and paste version of Extensions


Extensions

Name Version Enabled ID

DownloadManager 0.2.1 true @DownloadManager Firefox Hello 1.3.2 true loop@mozilla.org Multi-process staged rollout 1.0 true e10srollout@mozilla.org New Tab by Yahoo 1.3.4 true jid1-G80Ec8LLEbK5fQ@jetpack Pocket 1.0.2 true firefox@getpocket.com

Dear jscher2000: Good morning. Below is the copy and paste version of Extensions Extensions Name Version Enabled ID DownloadManager 0.2.1 true @DownloadManager Firefox Hello 1.3.2 true loop@mozilla.org Multi-process staged rollout 1.0 true e10srollout@mozilla.org New Tab by Yahoo 1.3.4 true jid1-G80Ec8LLEbK5fQ@jetpack Pocket 1.0.2 true firefox@getpocket.com
jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Chosen Solution

I suspect this one is causing the problem:

New Tab by Yahoo 1.3.4 true jid1-G80Ec8LLEbK5fQ@jetpack

Could you try disabling it? You can do that on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find that extension on the right side and click its Disable button. If it is not visible on the list, you may need to remove it using Firefox's Safe Mode. I'll give the steps if needed.

Often a link will appear above a disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

I suspect this one is causing the problem: <blockquote> '''New Tab by Yahoo''' 1.3.4 true jid1-G80Ec8LLEbK5fQ@jetpack </blockquote> Could you try disabling it? You can do that on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then find that extension on the right side and click its Disable button. ''If it is not visible on the list, you may need to remove it using Firefox's Safe Mode. I'll give the steps if needed.'' Often a link will appear above a disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any improvement?

Question owner

Dear Friend: I'm becoming embarrassed concerning the time you spend on me. I was able to disable the extension you mentioned. No result. When opening Firefox, it gives me Yahoo, even after choosing Google on the Search Link. Maybe I SHOULD move to Chrome. Again, thanks for the effort. Frans

Dear Friend: I'm becoming embarrassed concerning the time you spend on me. I was able to disable the extension you mentioned. No result. When opening Firefox, it gives me Yahoo, even after choosing Google on the Search Link. Maybe I SHOULD move to Chrome. Again, thanks for the effort. Frans
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23374 answers

please try to refresh firefox and see if this can address the issue... in case it doesn't either, then i'd recommend a scan for adware with the tool from https://www.malwarebytes.com/antimalware/mac/

please try to [[Reset Firefox – easily fix most problems|refresh firefox]] and see if this can address the issue... in case it doesn't either, then i'd recommend a scan for adware with the tool from https://www.malwarebytes.com/antimalware/mac/

Question owner

IT WORKED!!!!!!!!!!!! THANKS TO ALLL!!!!!!!! Frans Rijnbout (who, although having a PhD and works as an Associate Professor, was born too early and is thus by far the most computer-illiterate person in the USA.

YOU ALL ROCK Frans

IT WORKED!!!!!!!!!!!! THANKS TO ALLL!!!!!!!! Frans Rijnbout (who, although having a PhD and works as an Associate Professor, was born too early and is thus by far the most computer-illiterate person in the USA. YOU ALL ROCK Frans
Happy112 561 solutions 5694 answers

So happy for you   !!!!
And no,   you are definately  not  the most computer-illiterate person in the USA,  !!!

So happy for you &nbsp; !!!!<BR> And no, &nbsp; you are definately &nbsp;'''not'''&nbsp; the most computer-illiterate person in the USA,&nbsp; !!!